搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Each new browser window has two tabs (one is the plus sign) so how do we close a window with only one page in it without the multi-tab warning?

  • 1 回覆
  • 3 有這個問題
  • 2 次檢視
  • 最近回覆由 unkilbeeg

more options

Firefox 38 has changed tab behavior for me so that every window opens with two tabs open. The second tab is the "plus" sign for creating new tabs. This means that when the window closes, the content vanishes, but the window itself sticks around and has to be closed by hand.

I've tried the "Hide Tab Bar With One Tab" extension, but it doesn't do anything. My additional windows still open with the tab bar (which they didn't in previous versions) and two tabs are there.

I do have "warn me if I try to close multiple tabs" set. I don't know if that is what the problem is. If it is, I don't want to give it up, because it's useful. When I have multiple tabs. But a window that has only one thing in it really needs to behave like a window that has only one thing in it.

附加的畫面擷圖

被選擇的解決方法

unkilbeeg said

Firefox 38 has changed tab behavior for me so that every window opens with two tabs open. The second tab is the "plus" sign for creating new tabs. This means that when the window closes, the content vanishes, but the window itself sticks around and has to be closed by hand. I've tried the "Hide Tab Bar With One Tab" extension, but it doesn't do anything. My additional windows still open with the tab bar (which they didn't in previous versions) and two tabs are there. I do have "warn me if I try to close multiple tabs" set. I don't know if that is what the problem is. If it is, I don't want to give it up, because it's useful. When I have multiple tabs. But a window that has only one thing in it really needs to behave like a window that has only one thing in it.

I went through disabling extensions, and the ImageTweak extension seems to have been the culprit. It's been working fine with all previous version, but 38 apparently screwed it up. Oh well, not a critical extension.

從原來的回覆中察看解決方案 👍 0

所有回覆 (1)

more options

選擇的解決方法

unkilbeeg said

Firefox 38 has changed tab behavior for me so that every window opens with two tabs open. The second tab is the "plus" sign for creating new tabs. This means that when the window closes, the content vanishes, but the window itself sticks around and has to be closed by hand. I've tried the "Hide Tab Bar With One Tab" extension, but it doesn't do anything. My additional windows still open with the tab bar (which they didn't in previous versions) and two tabs are there. I do have "warn me if I try to close multiple tabs" set. I don't know if that is what the problem is. If it is, I don't want to give it up, because it's useful. When I have multiple tabs. But a window that has only one thing in it really needs to behave like a window that has only one thing in it.

I went through disabling extensions, and the ImageTweak extension seems to have been the culprit. It's been working fine with all previous version, but 38 apparently screwed it up. Oh well, not a critical extension.