搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Where is the "Pocket for Firefox" button?

  • 14 回覆
  • 16 有這個問題
  • 720 次檢視
  • 最近回覆由 GCHQ

more options

I'm running Firefox 39.0 beta, but the Pocket button is not visible under Menu > Customise.

about:config, browser.pocket.enabled = is true

被選擇的解決方法

所有回覆 (14)

more options

I found mine already on the address bar, on the right.

more options

FredMcD said

I found mine already on the address bar, on the right.

OK.

由 GCHQ 於 修改

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options
more options

Problem still unresolved... Cor-el as per my first post; I'm running beta and Pocket is not visible under the customise tab.

Fred, if it was already visible on the toolbar I wouldnt be asking for help.

由 GCHQ 於 修改

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type pocket

browser.pocket.enabled = true

browser.pocket.useLocaleList = true

more options

Try to click the Restore Defaults button in the Customize palette to restore the default toolbar setup.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

cor-el said

Try to click the Restore Defaults button in the Customize palette to restore the default toolbar setup. Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

FredMcD said

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type pocket browser.pocket.enabled = true browser.pocket.useLocaleList = true

Tried both. Same issue.

more options

Please do not comment in bug reports. Bug 1155413 - Many icons missing from Add-on Customize Manager https://bugzilla.mozilla.org/show_bug.cgi?id=1155413

more options

Do you see the pocket-button in the value of the browser.uiCustomization.state pref?

You can open the Scratchpad (Firefox/Tools > Web Developer) and paste the value of the pref in the text area. Click the "Pretty Print" button to format the content for readability.

You can open the Browser Console (Firefox/Tools > Web Developer). Paste the JavaScript code in the command line and press the Enter key to run the code.

  • Toggle the devtools.chrome.enabled pref on the about:config page to true to enable the command line
pb = document.querySelector("#pocket-button");
pb.parentNode.id

Does this come up with any result?

more options

cor-el said

Do you see the pocket-button in the value of the browser.uiCustomization.state pref? You can open the Scratchpad (Firefox/Tools > Web Developer) and paste the value of the pref in the text area. Click the "Pretty Print" button to format the content for readability. You can open the Browser Console (Firefox/Tools > Web Developer). Paste the JavaScript code in the command line and press the Enter key to run the code.
  • Toggle the devtools.chrome.enabled pref on the about:config page to true to enable the command line
pb = document.querySelector("#pocket-button");
pb.parentNode.id

Does this come up with any result?

Thanks for the reply.

I'm not sure if I followed what you said.. I enabled commands in the Browser console and pasted

pb = document.querySelector("#pocket-button");
pb.parentNode.id

it returned the error: "TypeError: impl is null1 network-monitor.js:97:6"

I'm not sure where I'm looking/doing in regards to 'browser.uiCustomization.state pref'.

more options

If you enabled the command line in the devtools then you have found the about:config page. The browser.uiCustomization.state is another pref that you can find on this page.

  • about:config?filter=browser.uiCustomization.state

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Make sure that the browser window is selected when you open the Browser Console (Firefox/Tools > Web Developer) to run the code.

由 cor-el 於 修改

more options

cor-el said

If you nabled the command line in the devtools then you have found the about:config page. The browser.uiCustomization.state is another pref that you can find on this page.
  • about:config?filter=browser.uiCustomization.state
You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. Make sure that the browser window is selected when you open the Browser Console (Firefox/Tools > Web Developer) to run the code.

about:config?filter=browser.uiCustomization.state value has a line with this in it: "PersonalToolbar":["personal-bookmarks"],"nav-bar":["urlbar-container","pocket-button",

more options

選擇的解決方法

bump.