搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox crashes

  • 20 回覆
  • 3 有這個問題
  • 133 次檢視
  • 最近回覆由 FredMcD

more options

Firefox is crashing all the time. I am using it since Netscape, Phoenix and its first versions..It is worst when I use Gmail - for instance a filter, or if I open more than one Gmail account. Thanks.

被選擇的解決方法

SilviaAlves said

Firefox is crashing all the time. I am using it since Netscape, Phoenix and its first versions..It is worst when I use Gmail - for instance a filter, or if I open more than one Gmail account. Thanks.

Update your Firefox Browser

從原來的回覆中察看解決方案 👍 0

所有回覆 (20)

more options

Sorry to hear about the crashes. Are you getting the Mozilla Crash Reporter dialog, or the Windows crash dialog? If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the last section of the support article "Firefox crashes - Troubleshoot, prevent and get help fixing crashes" for steps to get those crash IDs from the about:crashes page, and then post some of the recent ones here.

Also and/or meanwhile, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?

more options

Since you mentioned that you use NoScript, there was a conflict reported with the combination of Firefox 38, NoScript, and Trusteer Rapport which causes crashes. If you aren't doing any imminent online banking, you might try disabling Rapport for a few hours and see whether that helps.

more options

選擇的解決方法

SilviaAlves said

Firefox is crashing all the time. I am using it since Netscape, Phoenix and its first versions..It is worst when I use Gmail - for instance a filter, or if I open more than one Gmail account. Thanks.

Update your Firefox Browser

more options

Hi Prasads, the information to the right of the original question shows the poster is already using Firefox 38.0.1, so there isn't any update available.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

I think in Safe Mode this does not happen, I will test it again.

I need to use Scrapbook most of time.

Add ons in use and updated

Evernote web clipper Flash Got No Script Password ExporterSkype Click to call Wot

Plug ins Schockwave flash Primetime Adobe System ( I do not know how this appeared!) Google Earth Google Update iTunes detection

about:crashes I also got a long list of Submitted Crash Reports but do not know how to use it. https://crash-stats.mozilla.com/report/index/4694dedf-df73-4991-9e18-d12b82150524

Thanks for answering me!

more options

jscher2000 said

Since you mentioned that you use NoScript, there was a conflict reported with the combination of Firefox 38, NoScript, and Trusteer Rapport which causes crashes. If you aren't doing any imminent online banking, you might try disabling Rapport for a few hours and see whether that helps.

OK, I use AVG but have no idea how to disable Trusteer Rapport .

Thank you.

more options

I just want to say that this problem is not recent. I think it has been for months. Now it got worst.

more options

SilviaAlves said

I think in Safe Mode this does not happen, I will test it again.

That would be very helpful to know one way or the other.

Add ons in use and updated

Evernote web clipper Flash Got No Script Password ExporterSkype Click to call Wot

Plug ins Schockwave flash Primetime Adobe System ( I do not know how this appeared!) Google Earth Google Update iTunes detection

Primetime is now included with Firefox. It allows you to play DRM-protected content in the native HTML5 video player, if sites support that, if you don't want to use Flash or Silverlight to play it.

If Evernote isn't critical, could you disable that one for a day or so?

I also got a long list of Submitted Crash Reports but do not know how to use it.
https://crash-stats.mozilla.com/report/index/4694dedf-df73-4991-9e18-d12b82150524

You can paste more crash report addresses if you like, in case the causes of the crashes differ.

That one has the signature "OOM | small" which indicates that some process within Firefox wasn't able to allocate enough memory to continue (OOM = Out of Memory). Unfortunately, it's difficult to figure out what Firefox was trying to do when this error occurred to see whether that points to a specific fault. With Windows memory usage at 81% at the time of the crash, it's possible that memory had become fragmented and Windows had to declined Firefox's request for a larger chunk of memory. I'm not sure how to tell. My guess would be that after restarting Firefox, the problem didn't return right away because crashing Firefox often frees a lot of memory.

SilviaAlves said

I just want to say that this problem is not recent. I think it has been for months. Now it got worst.

Okay, then the recently discovered NoScript/Trusteer problem would not be the prime suspect. I actually didn't see any evidence that you run Rapport in that crash report (Rapport likes to inject itself into various Firefox threads).

more options

The crash report flagged these programs;

StretchHook.dll = unknown / hook.dll = Danger: http://www.file.net/process/hook.dll.html

evernote_native.bin = Evernote

igd10umd32.dll = Intel(R) Graphics Technology

msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder

icudt52.dll = International Components for Unicode


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


Make sure all programs are up-to-date.

more options

jscher2000

Primetime is now included with Firefox. It allows you to play DRM-protected content in the native HTML5 video player, if sites support that, if you don't want to use Flash or Silverlight to play it.

- Thanks for explaining. Does it mean I can go without Schockwave flash

If Evernote isn't critical, could you disable that one for a day or so? - Surely, I can do.

You can paste more crash report addresses if you like, in case the causes of the crashes differ. - I will do.

That one has the signature "OOM | small" which indicates that some process within Firefox wasn't able to allocate enough memory to continue (OOM = Out of Memory). Unfortunately, it's difficult to figure out what Firefox was trying to do when this error occurred to see whether that points to a specific fault. With Windows memory usage at 81% at the time of the crash, it's possible that memory had become fragmented and Windows had to declined Firefox's request for a larger chunk of memory. I'm not sure how to tell. My guess would be that after restarting Firefox, the problem didn't return right away because crashing Firefox often frees a lot of memory.

- I do not know what I did, maybe I used the program that eliminates malware ( two were found) now memory usage is 10 - 15%. It has been more than 50% all the time.


Okay, then the recently discovered NoScript/Trusteer problem would not be the prime suspect. I actually didn't see any evidence that you run Rapport in that crash report (Rapport likes to inject itself into various Firefox threads). </blockquote>

Today it happened just once. Thanks a lot for the very detailed answer.

more options

SilviaAlves said

Primetime is now included with Firefox. It allows you to play DRM-protected content in the native HTML5 video player, if sites support that, if you don't want to use Flash or Silverlight to play it.

- Thanks for explaining. Does it mean I can go without Schockwave flash

Not yet... someday...

more options

Thanks a lot for answering me.

I will post more  crash report as soon as I have time.

I disabled more addons.

Evernote web clipper 
Password Exporter
Skype Click to call

In use:

Flash Got
No Script 
Scrapbook by Gomita ( my favourite since its first version)
Wot
more options

It didn't crash in safe mode, but I used for a short time.

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

You can try to disable hardware acceleration in Firefox. I have already done it a few months ago. Sorry for my not mentioning this before.

more options

SilviaAlves said

In use: Flash Got No Script Scrapbook by Gomita ( my favourite since its first version) Wot

Disable All of your add-ons. Is there still a problem?

If not, re-enable One add-on. Later another. Still later, another.

more options

Thanks, Fred McD. A simple idea I really liked and will apply in the future.

more options

No crashes at all in past 48 hours!!! Updated to 38.0.5. Some add ons were also automatically updated before the FF.

Now, there are the Google ads in many pages  : ( Anyway, better than the crashes.

Thank you very much to all that answered me.

more options

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Adblock Plus {web link} Blocks annoying video ads on YouTube, Facebook ads, banners and much more. Adblock Plus blocks all annoying ads, and supports websites by not blocking unobtrusive ads by default (configurable).

Adblock Plus Pop-up Addon {web link} Adblock Plus Pop-up Addon extends the blocking functionality of Adblock Plus to those annoying pop-up windows that open on mouse clicks and other user actions.

Forum; Adblock Plus Homepage {web link}