X
點擊此處開啟此網站的行動版。

技術支援討論區

Can i get some help with bad audio in Firefox streaming?

已張貼

I have the latest Firefox on a brand new laptop and the audio in almost all video streaming is bad. I have always used IE but Firefox was on this laptop so i thought i'd give it a go as i'd heard good things. I'll be honest i'm not impressed. The sound problem ranges from a mild intermitent crackling every twenty seconds or so,to terrible pops and crackles like a badly scratched record. Youtube is the worst but almost all other platforms are effected. I have put up with it for a week or so but it is really annoying now and needs sorting. Reading around the forums i have tried various things but to no avail. Nothing helps.

Windows 8.1,64 bit system. CPU averages about 9-14 when streaming.

Here's what i have tried.

The on/off of hardware acceleration. Clearing of history/cache. Reinstalled latest Adobe Flash. Clearing of Flash Site Data and Settings. Disabling HTML5 via about:config media.ogg etc Refreshing/tune up of Firefox. Messed about with speaker settings checking and unchecking various things,altering sound to different qualities.

As a last resort i am considering a reinstall of Firefox but unsure as i don't want to lose all my bookmarks.

I haven't looked into or am even sure the problem could be the 32 bit Flash and Firefox on a 64 bit machine. I dunno,this all seems a bit much just to watch a video. Can anyone help or is it back to IE?

I have the latest Firefox on a brand new laptop and the audio in almost all video streaming is bad. I have always used IE but Firefox was on this laptop so i thought i'd give it a go as i'd heard good things. I'll be honest i'm not impressed. The sound problem ranges from a mild intermitent crackling every twenty seconds or so,to terrible pops and crackles like a badly scratched record. Youtube is the worst but almost all other platforms are effected. I have put up with it for a week or so but it is really annoying now and needs sorting. Reading around the forums i have tried various things but to no avail. Nothing helps. Windows 8.1,64 bit system. CPU averages about 9-14 when streaming. Here's what i have tried. The on/off of hardware acceleration. Clearing of history/cache. Reinstalled latest Adobe Flash. Clearing of Flash Site Data and Settings. Disabling HTML5 via about:config media.ogg etc Refreshing/tune up of Firefox. Messed about with speaker settings checking and unchecking various things,altering sound to different qualities. As a last resort i am considering a reinstall of Firefox but unsure as i don't want to lose all my bookmarks. I haven't looked into or am even sure the problem could be the 32 bit Flash and Firefox on a 64 bit machine. I dunno,this all seems a bit much just to watch a video. Can anyone help or is it back to IE?

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.7.20033
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • Nitro PDF plugin for Firefox and Chrome
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

更多資訊

FredMcD
  • Top 10 Contributor
4310 個解決方法 60530 個答案

Reinstalling Firefox should only change / replace the program files in the computers Programs Folder. Your user profile is stored in the computers user folders.

Have you tried downloading one of the files and playing it?

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

Reinstalling Firefox should only change / replace the program files in the computers Programs Folder. Your user profile is stored in the computers user folders. Have you tried downloading one of the files and playing it? If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

提出問題者

Hi,thanks for helping.

Ok i've done all the following...

I've downloaded a few video's to try and they play fine. Everything media wise plays perfectly outside of the browser.

I checked updates for Graphics drivers. Best driver software for this device is installed. Checked a few others like sound and speakers,all are updated.

I tried adding the ProtectedMode=0 to the mms.cfg file in SysWOW64 but it says i don't have permission? and then asks if i want to save the file in Documents which i did. I got round this by using about:config >dom.ipc.plugins.flash.disable-protected-mode and set it from 'true' to 'false'

I disabled Hardware Accelaration in flash.

I checked that Shockwave Flash is set to 'always activate' in plug ins.

None of the above have solved the problem.

  • One thing i've noticed (in youtube videos only) is that after a specific point of click or pop,when you drag the play bar back it seems to plays fine.

Still annoying having to drag back all the time but it does stop it,if that gives you any more ideas.

I'm baffled. :(

Hi,thanks for helping. Ok i've done all the following... I've downloaded a few video's to try and they play fine. Everything media wise plays perfectly outside of the browser. I checked updates for Graphics drivers. Best driver software for this device is installed. Checked a few others like sound and speakers,all are updated. I tried adding the ProtectedMode=0 to the mms.cfg file in SysWOW64 but it says i don't have permission? and then asks if i want to save the file in Documents which i did. I got round this by using about:config >dom.ipc.plugins.flash.disable-protected-mode and set it from 'true' to 'false' I disabled Hardware Accelaration in flash. I checked that Shockwave Flash is set to 'always activate' in plug ins. None of the above have solved the problem. * One thing i've noticed (in youtube videos only) is that after a specific point of click or pop,when you drag the play bar back it seems to plays fine. Still annoying having to drag back all the time but it does stop it,if that gives you any more ideas. I'm baffled. :(
FredMcD
  • Top 10 Contributor
4310 個解決方法 60530 個答案

See if any of these help;

You could try disabling Flash plugin's protected mode. The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste flash and pause while the list is filtered (C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.


1) Enter the config by typing about:config in the address bar. 2) Enter media.mediasource.webm.enabled and press enter. 3) Right click on it and change to true, for some reason it is set as "false" which makes MSE & WebM VP9 not work properly. 4) Visit: https://www.youtube.com/html5 and check that everything is OK. 5) Try to watch a video. It should work now.

See if any of these help; You could try disabling Flash plugin's protected mode. The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste flash and pause while the list is filtered (C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox. ------------------------------------- 1) Enter the config by typing about:config in the address bar. 2) Enter media.mediasource.webm.enabled and press enter. 3) Right click on it and change to true, for some reason it is set as "false" which makes MSE & WebM VP9 not work properly. 4) Visit: https://www.youtube.com/html5 and check that everything is OK. 5) Try to watch a video. It should work now.

提出問題者

Thanks,i tried both of those solutions but still no change.

I found IE was also already installed so i gave it a go on that browser but it's just the same. I am convinced this is a flash problem.

This is so annoying!

Thanks,i tried both of those solutions but still no change. I found IE was also already installed so i gave it a go on that browser but it's just the same. I am convinced this is a flash problem. This is so annoying!

提出問題者

Ok i just tried something.

I uninstalled Flash using the Adobe uninstaller to see if it would alter anything but video is still the same. I then went in control panel and in All Control Panel Items there is a Flash (32-bit) icon,this machine is 64-bit. I double clicked it and it opens a Flash Player Settings Manager.

How come this is still here when i completely removed Flash? Could this be a problem?

Ok i just tried something. I uninstalled Flash using the Adobe uninstaller to see if it would alter anything but video is still the same. I then went in control panel and in All Control Panel Items there is a Flash (32-bit) icon,this machine is 64-bit. I double clicked it and it opens a Flash Player Settings Manager. How come this is still here when i completely removed Flash? Could this be a problem?

提出問題者

I reinstalled Flash and then tried this ...

Control Panel>All Control Panel Items>Troubleshooting>Hardware and Sound

Clicked Hardware and Devices and the search found a problem and corrected it.

Hey presto! It's fixed it. :D

No idea what the problem was but thought i'd post this in case it helps someone else out.

Thank you for all the help.

I reinstalled Flash and then tried this ... Control Panel>All Control Panel Items>Troubleshooting>Hardware and Sound Clicked Hardware and Devices and the search found a problem and corrected it. Hey presto! It's fixed it. :D No idea what the problem was but thought i'd post this in case it helps someone else out. Thank you for all the help.
FredMcD
  • Top 10 Contributor
4310 個解決方法 60530 個答案

That was great work. Well Done.

That was great work. Well Done.

提出問題者

Seems it was only temporary and is back,not as bad but still there.

I repeated the Hardware troubleshoot and once again it seems to be ok..for now. I then ran a full hardware check with the pre-installed solution Centre software but it found everything ok???

Still baffled.

Seems it was only temporary and is back,not as bad but still there. I repeated the Hardware troubleshoot and once again it seems to be ok..for now. I then ran a full hardware check with the pre-installed solution Centre software but it found everything ok??? Still baffled.
FredMcD
  • Top 10 Contributor
4310 個解決方法 60530 個答案

It might be something about the drivers. How old are they?

I've called the big guys to help you. Good luck.

It might be something about the drivers. How old are they? I've called the big guys to help you. Good luck.
guigs 1072 個解決方法 11697 個答案

There was a security update to Flash on Tues, however this timeline you may have already reinstalled the latest version. However once its been updated, do all the changes stay? (protectedmode, hardware acceleration, etc? )

You also may have been on to something 32bit version of Flash since Firefox is 32 bit version, but I have not run into issues with this yet.

Last check that yourr soundcards and video drivers are up to date.

Does this happen with different media types?

This may be helpful later:https://developer.mozilla.org/en-US/d.../Web_Audio_Editor

There was a security update to Flash on Tues, however this timeline you may have already reinstalled the latest version. However once its been updated, do all the changes stay? (protectedmode, hardware acceleration, etc? ) You also may have been on to something 32bit version of Flash since Firefox is 32 bit version, but I have not run into issues with this yet. Last check that yourr soundcards and video drivers are up to date. *[[Upgrade your graphics drivers to use hardware acceleration and WebGL]] *[[Fix video and audio playback problems on Firefox for Windows]] Does this happen with different media types? This may be helpful later:[https://developer.mozilla.org/en-US/docs/Tools/Web_Audio_Editor]
guigs 1072 個解決方法 11697 個答案

I was also thinking, we may need the driver information from about:support page if you can copy the troubleshooting info. I wonder if it is driver specific if it does not happen on another computer.

I was also thinking, we may need the driver information from about:support page if you can copy the troubleshooting info. I wonder if it is driver specific if it does not happen on another computer.

提出問題者

Hi guys thanks for all the help,i did all the above but nothing changed. However i found the fix myself and it was something quite simple. For anyone else that has this problem this is what i did..

Control Panel>All Control Panel Items>Administrative Tools>Computer Management>Services And Applications>Services Scroll down and highlight 'Windows Audio' and stop the service,then restart again.

This ^^^^ first part i'm not sure is actually necessary but as it was part of the whole procedure i did i thought i'd post it. You might just get away with just this second part.

Control Panel>All Control Panel Items>Power Options

The Windows default setting is 'Balanced' change to 'High Performance'.

This fixed the audio problems for me.

I created a short cut of the 'Power Option' to my Desktop so i can switch between 'Balanced' when general browsing and 'High Performance' if/when required.

Hope this helps out others with this annoying but quite simple problem.

Thanks

Hi guys thanks for all the help,i did all the above but nothing changed. However i found the fix myself and it was something quite simple. For anyone else that has this problem this is what i did.. Control Panel>All Control Panel Items>Administrative Tools>Computer Management>Services And Applications>Services Scroll down and highlight 'Windows Audio' and stop the service,then restart again. This ^^^^ first part i'm not sure is actually necessary but as it was part of the whole procedure i did i thought i'd post it. You might just get away with just this second part. Control Panel>All Control Panel Items>Power Options The Windows default setting is 'Balanced' change to 'High Performance'. This fixed the audio problems for me. I created a short cut of the 'Power Option' to my Desktop so i can switch between 'Balanced' when general browsing and 'High Performance' if/when required. Hope this helps out others with this annoying but quite simple problem. Thanks

提出問題者

Ok this hasn't solved it completely.

All drivers are up to date as is Flash,and protectedmode and hardware acceleration are still disabled. Video playback seems fine using VLC,WMP etc it is only when streaming that the problem occurs. I have managed to ease the problem a bit by switching from balanced to high performance in power options when streaming. It seems to lessen the pop and click,for some reason.

Any help killing this annoyance completely would be great.

Cheers.

Ok this hasn't solved it completely. All drivers are up to date as is Flash,and protectedmode and hardware acceleration are still disabled. Video playback seems fine using VLC,WMP etc it is only when streaming that the problem occurs. I have managed to ease the problem a bit by switching from balanced to high performance in power options when streaming. It seems to lessen the pop and click,for some reason. Any help killing this annoyance completely would be great. Cheers.