搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Cannot paste pictures from Firefox 37.0.2 to the MS Word 2010 SP1 and/or SP2

  • 3 回覆
  • 1 有這個問題
  • 11 次檢視
  • 最近回覆由 jscher2000

more options

Hi, Due to my work I need to copy very often from the internet entire articles together with their pictures from the Firefox in Office Word 2010.

Unfortunately for some weeks now the following problem occurs: when I copying an article from the Firefox the Word creates just a simple placeholder instead to paste the pictures.

The "crazy" thing is that when I try to do exactly the same from the Internet Explorer then the images are paste properly!!!

Because only use the FFF for many years now and I do not want to start using the IE, do you please have any idea to help me with that?

(I have examine in detail every case for this to happens because of the Word 2010 -options, tips etc. and I have reinstalled it 4 times, with SP1, SP2 but without any success)

I use Firefox 37.0.2 with the same apps for some years and Office 2010 SP2

Thanks, Nick

所有回覆 (3)

more options

As a bypass, right click the image, and save it. Then open it with the viewer.

more options

Thanks FredMcD,

I know this tips and alternatives but they don't help in my case.

Before I write here I was check exhaustively every article I can find in internet and every tip for everything similar to that problem. Unfortunately nothing helps.

I must find WHAT actually happens and this thing (very important for me) suddenly stops to work.

My only other real alternative now is to change in use of another browser. And really I hate this idea…

more options

Hi Nick, there are some differences between pasting from Firefox and pasting from IE. For example, when Firefox loads the copied HTML into the clipboard, you usually do not get global style rules incorporated into it, so background images, sprites, and other images that are not actually embedded using traditional < img > tags may not carry over.

To get a closer look at what is pasting, could you try toggling the display of field codes in your Word document? You can do that by press Alt+F9. Often images pasted from a web browser will then show an {INCLUDEPICTURE} field. Do you see differences for the problem images/placeholders between what you've pasted from IE and Firefox?

Also, I don't know whether it matters, but I have Word set to paste images inline instead of positioned. This is set in the Word Options dialog:

Advanced > Cut, copy & paste section > "Insert/paste pictures as: Inline with text"