搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox invalid security certificate page missing "add exemption"

  • 13 回覆
  • 18 有這個問題
  • 355 次檢視
  • 最近回覆由 cor-el

more options

Suddenly two valid websites that I frequent are now considered by Firefox to have invalid security certificates, Airbnb.com and sanjoseca.gov (the City of San Jose's official website). The return page from Firefox states the certificates are invalid but NO "ADD EXEMPTION" is listed on the page as an option.

I have waited more than 10 minutes to upload the image and it still hasn't loaded. It has the Technical Details, and the "Get me out of here link" but no "add exemption" link.

I use Airbnb.com frequently and I need a stable interface with them. I contacted both companies and they both told me that they were not aware that their certificate wasn't being recognized by Firefox and that I should download and use Google Chrome instead.

This isn't the first time I've had issues with Firefox. Frequently when applying for a job online, the application forms are not properly exhibited in Firefox but are in Internet Explorer. This makes applying for work very difficult!

It's been 15 minutes and still the image hasn't loaded. I can't wait any longer. Please tell me how to fix this glitch. Thank you.

所有回覆 (13)

more options

Both websites work fine here.

Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field type/paste the URL of the website

  • retrieve the certificate via the "Get certificate" button
  • inspect the certificate via the "View..." button

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

sandid2260 said

Suddenly two valid websites that I frequent are now considered by Firefox to have invalid security certificates, Airbnb.com and sanjoseca.gov (the City of San Jose's official website). The return page from Firefox states the certificates are invalid but NO "ADD EXEMPTION" is listed on the page as an option. I have waited more than 10 minutes to upload the image and it still hasn't loaded. It has the Technical Details, and the "Get me out of here link" but no "add exemption" link. I use Airbnb.com frequently and I need a stable interface with them. I contacted both companies and they both told me that they were not aware that their certificate wasn't being recognized by Firefox and that I should download and use Google Chrome instead. This isn't the first time I've had issues with Firefox. Frequently when applying for a job online, the application forms are not properly exhibited in Firefox but are in Internet Explorer. This makes applying for work very difficult! It's been 15 minutes and still the image hasn't loaded. I can't wait any longer. Please tell me how to fix this glitch. Thank you.

Thanks Cor-El for your reply and suggestions. Tried everything you mentioned and Firefox is not accepting the website's certificates. Still tells me they are invalid and still doesn't show the "add exemption" choice!

The image finally uploaded - yeah! Going crazy now....

more options

What does it say under the Technical details if you expand this section?

You can open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field type/paste the URL of the website

  • retrieve the certificate via the "Get certificate" button
  • inspect the certificate via the "View..." button and check details like the issuer

You can inspect more details in the Details tab.

more options

Dear cor-el,

Your solution still does not work. My version of Firefox is not allowing me to create an exception for Airbnb.com no matter how many times I check for the certificate.

Under the Technical Details it states:

www.airbnb.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. (Error code: sec_error_unknown_issuer).

On the error page, there is no :" I understand the risks" link to allow me to add an exemption.

I have gone to the Firefox Tools --> Options --> Certificate --> View Certificates and have manually added multiple times an exception for Airbnb.com and Firefox still won't allow me access.

Now Firefox is also messing up the user html interface for my bank. The login page is normal, but the next page and all subsequent pages are nothing by text documents...no html user interface at all. I am not incapable of tracking banking activity.

I don't know why Firefox has decided to mess up 7 of my most used websites but it does. I have thought to reinstall Firefox but that would mean losing all of my bookmarks. I have tried to Copy & Paste the bookmark's individual website addresses and the all of the bookmark folders with their web addresses, but Firefox won't allow me to paste that information into a Word Doc, Excel Doc, Google Doc, etc.

I think I'm done with this product. It has worked wonderfully for years and now it is dying. I cannot waste anymore time on a product that won't work. I'm using Windows XP that is one of the most stable operating systems I've used next to Windows NT but maybe all your upgrade for Firefox renders it useless for me. I just don't know. Firefox worked just fine 3 weeks ago and then it went crazy.

more options

Did you check who is the issuer of the certificate via the method I posted above by opening the chrome URL via the location/address bar?

  • chrome://pippki/content/exceptionDialog.xul

You can click the View button to open the certificate viewer window.

It is not recommended to add a permanent exception in cases like this, so only use it to inspect the certificate.

Check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

more options

Dear cor-el,

The clock, time and time zone are correct. Yes, I have read the details and no there is no issuer of a certificate. According to Airbnb, their certificate is current and up to 2 or so weeks ago, I had no trouble accessing Airbnb, Fidelity, Yahoo, City of San Jose and several other websites that I use regularly.

I have attached 2 PNG's showing you what the return pages look like. I have done every suggestion you have mentioned meticulously and still Firefox isn't working. I have run malware scans, anti-virus scans, defragged my computer, compressed files and still Firefox won't work properly. In fact, it hasn't worked properly since I uploaded the most recent Firefox updates.

由 sandid2260 於 修改

more options

What do you see if you click the View button to open the certificate viewer?

more options

Sorry for uploading the same image twice. Here's what the certificate viewer says: Could not verify this certificate because the user is unknown. See image.

more options

I see this certificate chain in the Details tab.

more options

I see this certificate chain in the Details tab.

more options

The certificate chain look OK, so why would there be a problem with an unknown issuer.

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

You can use this button to go to the currently used Firefox profile folder:

more options

Dear Cor-El,

Horray! Deleting the cert8.db file fixed the problem with Airbnb.com and with my bank's website.

However, it did not fix the problem trying to access the career page on the City of San Jose's website (https://cityjobs.sanjoseca.gov/psc/prod/EMPLOYEE/HRMS/c/HRS_HRAM.HRS_CE.GBL?Page=HRS_CE_HM_PREAction=ASiteID=1)

I went to chrome://pippki/content/exceptionDialog.xul to try to get the certificate and there wasn't any. Instead I got an error message:

"Secure Connection Failed

An error occurred during a connection to cityjobs.sanjoseca.gov. Cannot communicate securely with peer: no common encryption algorithm(s). (Error code: ssl_error_no_cypher_overlap)

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem."

I have attempted several times to contact the IT department at the City to no avail. Is there someway you can contact them to let them know of the problem? I can access the careers information without problem using IE 8.0.

more options

The website may try to fallback to TLS 1.0 in a way that is no longer allowed in current releases or may be using a deprecated cipher suite.

You can open the about:config page via the location/address bar and use its search bar to locate this pref:

  • security.tls.insecure_fallback_hosts

You can double-click the line to modify the pref and add the full domain (cityjobs.sanjoseca.gov) to the value of this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). There should only be domains separated by a comma in the Value column (example.com,www.example.com).

If this helps then you can contact this website and ask them to look into this and update their security.