搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I can't access a certain website after the recent Firefox update.

  • 5 回覆
  • 9 有這個問題
  • 2979 次檢視
  • 最近回覆由 Dragoness

more options

Before the update, I was able to get to my bank account without any trouble. Now I get "Secure Connection Failed" issue. The problem is not the firewall because any computer that we've tried to access the site with, including one on a different Internet connection, has failed. I am able to access the site on other browsers. None of the troubleshooting supports or forums have helped.

被選擇的解決方法

The reason Firefox is blocking access to this website is because it uses the older RC4 cypher. (and the login page is where you want security, if that is insecure it's going to be the first point of attack to access bank accounts).

I'd suggest you call up the bank immediately and request they use some modern web security.

從原來的回覆中察看解決方案 👍 1

所有回覆 (5)

more options

It is likely that the website is running insecure cyphers, making it unsafe for Firefox to go there. You can run the website address through https://www.ssllabs.com/ssltest/ and see what is wrong, and then contact the site and complain. If this is a bank I'd suggest switching banks, as if they are taking such risks with their website you can't be assured they are keeping your money or information safe.

more options

I should probably clarify that this is a login page, not the actually bank accounts.

I ran the page where the "Secure Connection Failed" issue shows up through the link you posted. Overall rating is B.

more options

The website may try to fallback to TLS 1.0 in a way that is no longer allowed in current releases or may be using a deprecated cipher suite.

You can open the about:config page via the location/address bar and use its search bar to locate this pref:

  • security.tls.insecure_fallback_hosts

You can double-click the line to modify the pref and add the full domain to this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). You should only see domains separated by a comma in the value column.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


more options

選擇的解決方法

The reason Firefox is blocking access to this website is because it uses the older RC4 cypher. (and the login page is where you want security, if that is insecure it's going to be the first point of attack to access bank accounts).

I'd suggest you call up the bank immediately and request they use some modern web security.

more options

I just called. They know the issue and are resolving it.