X
點擊此處開啟此網站的行動版。

技術支援討論區

Plugin Container for Firefox has stopped working.

已張貼

An error message (in a separate window popup) with the phrase "Plugin Container for Firefox has stopped working" is appearing every few minutes. This seems to be related to an update with 37.0.1.

I have opened Firefox in Safe Mode and the problem is still appearing.

All Plugins are disabled due to Safe Mode, but additionally have the "Never activate" option selected.

An error message (in a separate window popup) with the phrase "Plugin Container for Firefox has stopped working" is appearing every few minutes. This seems to be related to an update with 37.0.1. I have opened Firefox in Safe Mode and the problem is still appearing. All Plugins are disabled due to Safe Mode, but additionally have the "Never activate" option selected.

額外的系統細節

已安裝的外掛程式

"extensions": [

   {
     "name": "IDS_SS_NAME",
     "version": "IDS_SS_VERSION",
     "isActive": false,
     "id": "{D19CA586-DD6C-4a0a-96F8-14644F340D60}"
   },
   {
     "name": "Instasaver",
     "version": "1.7.5",
     "isActive": false,
     "id": "instasaver@flerro"
   },
   {
     "name": "LastPass",
     "version": "3.1.1",
     "isActive": false,
     "id": "support@lastpass.com"
   }
 ],
 "modifiedPreferences": {}

}

應用程式

  • Firefox 37.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/37.0.1/WINNT/en-US/

擴充套件

  • IDS_SS_NAME IDS_SS_VERSION ({D19CA586-DD6C-4a0a-96F8-14644F340D60}) (Inactive)
  • Instasaver 1.7.5 (instasaver@flerro) (Inactive)
  • LastPass 3.1.1 (support@lastpass.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2: AMD Radeon HD 7470
  • adapterDeviceID: 0x0152
  • adapterDeviceID2: 0x6778
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2: atiu9p64 atiuxp64 atiuxp64 atiu9pag atiuxpag atiuxpag atiumdva atiumd6a atitmm64
  • adapterRAM: Unknown
  • adapterRAM2: 1024
  • adapterSubsysID: 052c1028
  • adapterSubsysID2: 21201028
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x1002
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-26-2012
  • driverDate2: 12-6-2011
  • driverVersion: 8.15.10.2712
  • driverVersion2: 8.922.0.0
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
rahuldecoded 6 個解決方法 77 個答案

First, update your Shockwave Flash.http://get.adobe.com/shockwave/

First, update your Shockwave Flash.http://get.adobe.com/shockwave/

提出問題者

I don't have Flash installed - it's blocked at my office.

I don't have Flash installed - it's blocked at my office.
rahuldecoded 6 個解決方法 77 個答案

OMG...

for it u have keep all your Shockwave updated

Thank You

OMG... for it u have keep all your Shockwave updated Thank You
rahuldecoded 6 個解決方法 77 個答案

and another thing is that dont open many tabs together

and another thing is that dont open many tabs together

由 rahuldecoded 於 修改

jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

First, a technical point: Safe Mode disables extensions, but it does not disable plugins. The "Never Activate" should indeed disable them.

Is the message you get from Windows or the Mozilla Crash Reporter? If it's the Mozilla Crash Reporter, you may be able to extract some information logged by Firefox about the problem. Please check the last section of the support article "Firefox crashes - Troubleshoot, prevent and get help fixing crashes" for steps to get the crash report IDs for reports you have submitted to Mozilla, and then post some of the recent ones here.

Either way, it's puzzling that Firefox would be starting up plugin-container.exe if all the plugins are set to Never Activate. Especially in Firefox's Safe Mode where we can't point the finger at an extension using a plugin. Hmm...

Is it possible that an external process, such as a security-related process, could be killing plugin-container.exe?

First, a technical point: Safe Mode disables extensions, but it does not disable plugins. The "Never Activate" should indeed disable them. Is the message you get from Windows or the Mozilla Crash Reporter? If it's the Mozilla Crash Reporter, you may be able to extract some information logged by Firefox about the problem. Please check the last section of the support article "[[Firefox Crashes]]" for steps to get the crash report IDs for reports you have submitted to Mozilla, and then post some of the recent ones here. Either way, it's puzzling that Firefox would be starting up plugin-container.exe if all the plugins are set to Never Activate. Especially in Firefox's Safe Mode where we can't point the finger at an extension using a plugin. Hmm... Is it possible that an external process, such as a security-related process, could be killing plugin-container.exe?

提出問題者

Re: technical point - got it. Thanks.

The error is from Windows. I tried to upload a screenshot in the original post, but it kept failing. It's working right now for whatever reason.

I don't have any information connected to crash reports because Firefox itself isn't crashing - just the Plugin Container. Even when I click "Close the program" on the error message, nothing happens, so I assume it's closing the plugin container program itself (as oppose to Firefox). The popup error window closes, and then reappears a short while later.

I suppose an external security process could be doing something, but I've been using Firefox for years without this popup.

Re: technical point - got it. Thanks. The error is from Windows. I tried to upload a screenshot in the original post, but it kept failing. It's working right now for whatever reason. I don't have any information connected to crash reports because Firefox itself isn't crashing - just the Plugin Container. Even when I click "Close the program" on the error message, nothing happens, so I assume it's closing the plugin container program itself (as oppose to Firefox). The popup error window closes, and then reappears a short while later. I suppose an external security process could be doing something, but I've been using Firefox for years without this popup.
guigs 1072 個解決方法 11697 個答案
The two troubleshooting articles recommended are below: *[[Firefox uses too many CPU resources - How to fix]] *[[Firefox uses too much memory (RAM) - How to fix]]

提出問題者

Thanks for the help, but I don't think this solves the problem.

I'm still experiencing the error even when in Safe Mode. I'll still experiencing the error when all plugins are set to "never activate". So, I don't think Firefox is using too may CPU resources or too much memory if Safe Mode and "never activate" are set, right?

Thanks for the help, but I don't think this solves the problem. I'm still experiencing the error even when in Safe Mode. I'll still experiencing the error when all plugins are set to "never activate". So, I don't think Firefox is using too may CPU resources or too much memory if Safe Mode and "never activate" are set, right?
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

In case plugin-container.exe has gotten damaged somehow, or there is some other problem in your Firefox program folder, could you do this:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean. As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 37.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
In case plugin-container.exe has gotten damaged somehow, or there is some other problem in your Firefox program folder, could you do this: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean. As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 37.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox ''(64-bit Windows folder names)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any improvement? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins

提出問題者

Thank you, as well, for the help.

Sadly, the clean reinstall did not work. I am still receiving the error.

Any other suggestions?

Thank you, as well, for the help. Sadly, the clean reinstall did not work. I am still receiving the error. Any other suggestions?
Mark Schmidt 66 個解決方法 362 個答案

You could try using Firefox ESR (Extended Support Release), which is made to be more reliable than the "normal" Firefox releases. Firefox ESR only gets new features every 8 versions, so it may not have some of the newer features that the "normal" release has. But what it does have is stability.

First, download the installer here: https://www.mozilla.org/en-US/firefox/organizations/all/

Next, uninstall Firefox and install Firefox ESR.

Let us know if this fixes the issue.

Thanks!

You could try using Firefox ESR (Extended Support Release), which is made to be more reliable than the "normal" Firefox releases. Firefox ESR only gets new features every 8 versions, so it may not have some of the newer features that the "normal" release has. But what it does have is stability. First, download the installer here: https://www.mozilla.org/en-US/firefox/organizations/all/ Next, uninstall Firefox and install Firefox ESR. Let us know if this fixes the issue. Thanks!
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

I haven't come up with many leads searching around, but by any chance do you use avast! 2015? https://forum.avast.com/index.php?topic=168376.msg1201169#msg1201169 - The only solution seems to be to turn off "Scan for browser add-ons" under Smart Scan.

I haven't come up with many leads searching around, but by any chance do you use avast! 2015? https://forum.avast.com/index.php?topic=168376.msg1201169#msg1201169 - ''The only solution seems to be to turn off "Scan for browser add-ons" under Smart Scan.''