X
點擊此處開啟此網站的行動版。

技術支援討論區

Resolving Repeated Shockwave Flash Crashing Firefox - EXCEPTION_ACCESS_VIOLATION_READ

已張貼

Hey all,

Thanks in advance for any comments.

I've been working on a client's computer and I'm receiving frequent crashes. Previously the logs indicated the same error but pointed in the metadata to an outdated plugin. I've removed the plugin and the crashes still occur ( at least once per day).

In the logs that bit that concerns me is that Sophos may be the culprit and may be hampering or preventing some Flash interaction from working properly.

Logs: https://crash-stats.mozilla.com/report/index/4e75c9e8-a7d9-4dd5-9618-7f62a2150407 https://crash-stats.mozilla.com/report/index/0aeaa8cc-e028-45a2-b928-a816d2150407 https://crash-stats.mozilla.com/report/index/22697c7f-d2a6-4049-b02f-422b62150406

The following actions have been recommended in various kb articles and I have taken them without seeing resolution: -Updated Firefox -Uninstalled and Reinstalled latest version of Flash -Disabled Hardware Acceleration for Flash -Disabled Hardware acceleration for Firefox -Removed previous plugin (LogMeIn).

Greatly appreciated

Hey all, Thanks in advance for any comments. I've been working on a client's computer and I'm receiving frequent crashes. Previously the logs indicated the same error but pointed in the metadata to an outdated plugin. I've removed the plugin and the crashes still occur ( at least once per day). In the logs that bit that concerns me is that Sophos may be the culprit and may be hampering or preventing some Flash interaction from working properly. Logs: https://crash-stats.mozilla.com/report/index/4e75c9e8-a7d9-4dd5-9618-7f62a2150407 https://crash-stats.mozilla.com/report/index/0aeaa8cc-e028-45a2-b928-a816d2150407 https://crash-stats.mozilla.com/report/index/22697c7f-d2a6-4049-b02f-422b62150406 The following actions have been recommended in various kb articles and I have taken them without seeing resolution: -Updated Firefox -Uninstalled and Reinstalled latest version of Flash -Disabled Hardware Acceleration for Flash -Disabled Hardware acceleration for Firefox -Removed previous plugin (LogMeIn). Greatly appreciated

被選擇的解決方法

Each of the 3 reports is different:

(1) Flash is crashing

It is using protected mode (you can see the EXE entries in the crashing thread). This is not stable on all systems, unfortunately. There is a new hidden setting to test with it disabled:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Before that preference was added, the way to disable protected mode was by creating or editing a settings file. The following pages/posts provide different approaches for that if it turns out to be necessary (if Flash EXE processes continue to show up in the Windows Task Manager, Processes tab, even after changing the Firefox preference):

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

Any improvement?


(2) D3D11-related crash

Firefox recently started using this newer version of DirectX. I'm not sure that's significant, because the crash might have happened with the older version, too.

Two of the three crash reports linked to this report indicates problems with different graphics card/chipset driver software. In such cases, if a driver update is not available or not helpful, the workaround usually is to disable Firefox from using hardware acceleration.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit Firefox and start it up again. Any difference?


(3) OOM = Out of Memory crash

With system memory use at 81%, Firefox apparently failed to get the memory block it requested from Windows and died. Hopefully this is not a frequent problem.

從原來的回覆中察看解決方案 0

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/600.4.10 (KHTML, like Gecko) Version/8.0.4 Safari/600.4.10

更多資訊

FredMcD
  • Top 10 Contributor
4266 個解決方法 59806 個答案

See if any of these help;

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

See if any of these help; If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

提出問題者

Hi FredMcD,

Thanks for your response. The hardware acceleration has been disabled for both flash and for firefox so suggestions one and two are out.

Do you see anything in the logs that indicates a root cause ?

Hi FredMcD, Thanks for your response. The hardware acceleration has been disabled for both flash and for firefox so suggestions one and two are out. Do you see anything in the logs that indicates a root cause ?
jscher2000
  • Top 10 Contributor
8783 個解決方法 71823 個答案

選擇的解決方法

Each of the 3 reports is different:

(1) Flash is crashing

It is using protected mode (you can see the EXE entries in the crashing thread). This is not stable on all systems, unfortunately. There is a new hidden setting to test with it disabled:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Before that preference was added, the way to disable protected mode was by creating or editing a settings file. The following pages/posts provide different approaches for that if it turns out to be necessary (if Flash EXE processes continue to show up in the Windows Task Manager, Processes tab, even after changing the Firefox preference):

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

Any improvement?


(2) D3D11-related crash

Firefox recently started using this newer version of DirectX. I'm not sure that's significant, because the crash might have happened with the older version, too.

Two of the three crash reports linked to this report indicates problems with different graphics card/chipset driver software. In such cases, if a driver update is not available or not helpful, the workaround usually is to disable Firefox from using hardware acceleration.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit Firefox and start it up again. Any difference?


(3) OOM = Out of Memory crash

With system memory use at 81%, Firefox apparently failed to get the memory block it requested from Windows and died. Hopefully this is not a frequent problem.

Each of the 3 reports is different: (1) Flash is crashing It is using protected mode (you can see the EXE entries in the crashing thread). This is not stable on all systems, unfortunately. There is a new hidden setting to test with it disabled: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''flash''' and pause while the list is filtered (C) Double-click the '''dom.ipc.plugins.flash.disable-protected-mode''' preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox. Before that preference was added, the way to disable protected mode was by creating or editing a settings file. The following pages/posts provide different approaches for that if it turns out to be necessary (if Flash EXE processes continue to show up in the Windows Task Manager, Processes tab, even after changing the Firefox preference): * Adobe support article under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] * Manual steps: https://support.mozilla.org/questions/968190?page=5#answer-509209 * Batch file to automate the manual steps: https://support.mozilla.org/questions/982093#answer-518078 (alternate version of Carm's batch file with a few changes by me: [https://onedrive.live.com/?cid=f7d304d92388737d&id=F7D304D92388737D!336&ithint=file,.bat&authkey=!AP2FXW2Y_3BXZyo]) Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect. Any improvement? (2) D3D11-related crash Firefox recently started using this newer version of DirectX. I'm not sure that's significant, because the crash might have happened with the older version, too. Two of the three crash reports linked to this report indicates problems with different graphics card/chipset driver software. In such cases, if a driver update is not available or not helpful, the workaround usually is to disable Firefox from using hardware acceleration. "3-bar" menu button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" This takes effect the next time you exit Firefox and start it up again. Any difference? (3) OOM = Out of Memory crash With system memory use at 81%, Firefox apparently failed to get the memory block it requested from Windows and died. Hopefully this is not a frequent problem.

提出問題者

Hey jscher2000,

Thanks for your thorough response. I'm going to attempt the suggestions you made either today or tomorrow and get back to you. Unfortunately this is a frequent problem and I've already disabled the hardware acceleration.

I'm hesitant to disable the protected mode since security is a concern but if it works I can at least explain to the user what is going on.

The memory crash is most likely the culprit as this user does large excel spreadsheets.

I'll attempt the graphics card update and the protected mode change and get back to you. RAM is luckily cheap but I just wouldn't feel good replacing RAM without trying the other fixes first :)

Thanks again :D

Hey jscher2000, Thanks for your thorough response. I'm going to attempt the suggestions you made either today or tomorrow and get back to you. Unfortunately this is a frequent problem and I've already disabled the hardware acceleration. I'm hesitant to disable the protected mode since security is a concern but if it works I can at least explain to the user what is going on. The memory crash is most likely the culprit as this user does large excel spreadsheets. I'll attempt the graphics card update and the protected mode change and get back to you. RAM is luckily cheap but I just wouldn't feel good replacing RAM without trying the other fixes first :) Thanks again :D

提出問題者

1) Flash protected mode disabled == True

2) Hardware Acceleration is turned off.

3) His computer is 32 bit and has 4 gigs so a ram upgrade == replacing the box.

Oh Well.

I'll check in again to update in about a day or two once he's had time to go about it.

1) Flash protected mode disabled == True 2) Hardware Acceleration is turned off. 3) His computer is 32 bit and has 4 gigs so a ram upgrade == replacing the box. Oh Well. I'll check in again to update in about a day or two once he's had time to go about it.
FredMcD
  • Top 10 Contributor
4266 個解決方法 59806 個答案

mhut said

I'm hesitant to disable the protected mode since security is a concern

Try this, turn it off (as a test) then try a web site. Does it work? Then disconnect and report back. You can always turn it on again.

''mhut [[#answer-717918|said]]'' <blockquote> I'm hesitant to disable the protected mode since security is a concern </blockquote> Try this, turn it off (as a test) then try a web site. Does it work? Then disconnect and report back. You can always turn it on again.

提出問題者

jscher2000 , Thank you so much for your quick and thorough response! Protected mode it seems was the culprit.

@FredMcD good advice, the problem is the user was having not when firefox started but just randomly thorough the day. It wasn't that reproducible which was the frustrating part. :/

Thank you both, FredMcD and jscher2000 for your input and troubleshooting! This was a user who had been having this problem for months without resolution.

jscher2000 , Thank you so much for your quick and thorough response! Protected mode it seems was the culprit. @FredMcD good advice, the problem is the user was having not when firefox started but just randomly thorough the day. It wasn't that reproducible which was the frustrating part. :/ Thank you both, FredMcD and jscher2000 for your input and troubleshooting! This was a user who had been having this problem for months without resolution.