搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox after updating to 37.0.1 doesn't play youtube videos.

  • 5 回覆
  • 34 有這個問題
  • 4501 次檢視
  • 最近回覆由 Deben

more options

After updating to 37.0.1 Youtube doesn't play any videos. I don't have Flash Player installed. Never had it installed. I always have used Youtube HTML5 video player and everything was ok. Unfortunately until today when I installed Firefox 37.0.1. I tried deleting hisotry, cache etc. completely but it did not help.

被選擇的解決方法

Is it "An error occurred, please try again later"?

When you visit YouTube's HTML5 page, does it show 5 out of 6 features with a blue checkmark box (all except the last one):

https://www.youtube.com/html5

On my Windows 7, if I have "MSE & H.264" enabled, then YT fails on HTML5 and switches to Flash.

Could you try disabling a Firefox preference and then reload the YouTube page and see whether it plays?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.mediasource.mp4.enabled preference to switch it from true to false

從原來的回覆中察看解決方案 👍 7

所有回覆 (5)

more options

選擇的解決方法

Is it "An error occurred, please try again later"?

When you visit YouTube's HTML5 page, does it show 5 out of 6 features with a blue checkmark box (all except the last one):

https://www.youtube.com/html5

On my Windows 7, if I have "MSE & H.264" enabled, then YT fails on HTML5 and switches to Flash.

Could you try disabling a Firefox preference and then reload the YouTube page and see whether it plays?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.mediasource.mp4.enabled preference to switch it from true to false

由 jscher2000 於 修改

more options

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

more options

Thank you very much for answering guys. Yes, it was "An error occurred, please try again later" error. First of all I tried running Firefox with all extensions disabled. It turned out that NoScript was causing the problem. With NoScript disabled or set to "allow all scripts" Youtube was working fine again.

Than I tried doing what jscher2000 said. I went to youtube.com/html5 and exactly as you said everything was okay except "MSE & WebM VP9" so i changed "media.mediasource.mp4.enabled" to false and Youtube is working again fine even with NoScript turned on.

Thank you again guys <3

more options

I forgot about that: the NoScript menu lists mediasource: as a protocol instead of a website, so even if you have allowed scripts for youtube.com and ytimg.com, you also need to allow the mediasource: protocol. I guess I forgot that I only enabled it temporarily, so thank you for the reminder to check that.

more options

I have noscript installed. HTML5 youtube video worked after allowing scripts from "googlevideo.com". I guess it should be obvious, but it took a while to notice the domain was being blocked.