搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

yahoo hijacking FF

  • 2 回覆
  • 19 有這個問題
  • 1160 次檢視
  • 最近回覆由 Bcav

more options

When I search I get a Bing page with the search results (for example try "wrecking crew"), but when I click on the first result (wreckingcrew.tv), FF takes me to the correct page for a second and then that page disappears and I am on a Yahoo search page. When I click on the top entry, which is wreckingcrew.tv, I get a new tab which is once again a Yahoo search page, now labelled "DNS Solution Yahoo Error Handler". Also the search term has been changed to "wrecking crew bio images". This new page has lots of other links for wrecking crew, but no longer has a direct link to the correct website. This just started happening today (March 24) on my MacBook Air since I started running 36.0.4. I changed the home page to Bing and removed Yahoo from the search engine list but no help. Some other sites do not have this behavior. The other thing is sometimes when this happens, the default FF search engine gets changed to Yahoo even though I have explicitly REMOVED Yahoo from the list of search engines.

This is driving me NUTS! There is no problem in Safari, but I hate Safari.

被選擇的解決方法

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable / remove Yahoo anything.

Also, check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

Remove Yahoo anything.


Bookmark and use this; Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


Settings Guard for Firefox {web link} Detects and resets changes to settings that are frequently done by add-ons and application installers.

從原來的回覆中察看解決方案 👍 2

所有回覆 (2)

more options

選擇的解決方法

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable / remove Yahoo anything.

Also, check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

Remove Yahoo anything.


Bookmark and use this; Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


Settings Guard for Firefox {web link} Detects and resets changes to settings that are frequently done by add-ons and application installers.

more options

rondans said

When I search I get a Bing page with the search results (for example try "wrecking crew"), but when I click on the first result (wreckingcrew.tv), FF takes me to the correct page for a second and then that page disappears and I am on a Yahoo search page. When I click on the top entry, which is wreckingcrew.tv, I get a new tab which is once again a Yahoo search page, now labelled "DNS Solution Yahoo Error Handler". Also the search term has been changed to "wrecking crew bio images". This new page has lots of other links for wrecking crew, but no longer has a direct link to the correct website. This just started happening today (March 24) on my MacBook Air since I started running 36.0.4. I changed the home page to Bing and removed Yahoo from the search engine list but no help. Some other sites do not have this behavior. The other thing is sometimes when this happens, the default FF search engine gets changed to Yahoo even though I have explicitly REMOVED Yahoo from the list of search engines. This is driving me NUTS! There is no problem in Safari, but I hate Safari.

I had this problem also and found a very easy solution. Go to "tools"/"options"/"search" - at the bottom of the text, click on "Add more search engines" which will take you to another page with several options - click on "Google default" - that solved it for me.