搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Application not automatically opening everytime .tvc file

  • 9 回覆
  • 3 有這個問題
  • 78 次檢視
  • 最近回覆由 demetri90

more options

I've set the .tvc file to open Teamviewer 10 automatically, but it never works. The prompt keeps coming up, and I always have to click open every time.

Also, I noticed under the application settings, that when the .tvc entry is not selected, it shows "Use (default)". But when it is selected, it shows "Always Ask".

附加的畫面擷圖

所有回覆 (9)

more options

I've called the big guys to help you. Good luck.

more options

This usually depends on how a server sends the file. If the file is send with a supported file type then it should work. If files are send with a generic MIME (content) type like "application/octet-stream" or a content disposition header then this probably won't work.

more options

In my first post I state that I went under the applications settings, and that there is possibly a bug with the menu. Look at the pictures.

Also, this happens even with .mp3 and .wav files, every time I download something, the prompt appears and "Do this automatically for files like this from now on." defaults to being checked, yet it keeps prompting me what to do, it's not just with the .tvc files.

more options

You can try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

I understand that there is a suspicion that there is an issue with the menu, however sometimes when preferences do not save it can be caused by a locked preference or how the server sends the file as corel has mentioned.

Renaming the mimetype file is one of the recommendations when that preferences file in your profile becomes corrupt, renaming it will tell it that is the issue. It also sounds like the preferences are not saving:

It is even more suspicious that this is happening for other file types. Please post back with the results of trying to generate a new file.

more options

I completely reset my Firefox, no change, still keeps popping up to ask me what to do, even if I've already specified to automatically open.

more options

Check your computers associations. On Win 7, its;

Control Panel\All Control Panel Items\Default Programs\Set Associations

more options

Just did, .tvc opens Teamviewer as it should.