搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Instructions on how to fix one preference that never stays changed leads to dead ends. Please help me figure out what to do next.

  • 4 回覆
  • 1 有這個問題
  • 8 次檢視
  • 最近回覆由 cor-el

more options

Every time I look at Options, my setting always reverts to TELL Sites that I do not want to be tracked. Other people told me not to check anything, so it's a little annoying that it is always checked.

I opened troubleshooting, opened my folders, and discovered that I don't have a User.JS file, so the instructions to fix that preference ended without a solution. The next step to check Pref.JS. Here, I got an error: prefs.js line 1 char 1 invalid character code 800a03f6 Microsoft jscript compilation error.

I have no idea what to do next. Thank you.

所有回覆 (4)

more options
more options

You need to right-click the prefs.js file and use "Open with" to open the file in a text editor (e.g. Notepad) and you shouldn't double-click the file as that gives you the above posted error message.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

cor-el,

I had to guess at which file had notepad in it, then I could open it.

It's telling me not to make any changes there, but to go to about:config. The list of prefs is extremely long. Which file do I want to change? I assume that I would want to change it from false to true.

Thank you.

more options

You can rename the current prefs.js file to prefs.js.old to reset all preferences and make Firefox create a new prefs.js file.