搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

video lags, 1 solution is build in flash plugin like in waterfox or chrome

  • 82 回覆
  • 5 有這個問題
  • 5877 次檢視
  • 最近回覆由 Sugram22

more options

video lags, 1 solution is build in flash plugin like in waterfox or chrome, its impossible for user to fix, my OS: Win 8.1 all worked fine in waterfox until update 35.0, it got memory leak after that, well it had small memory leak before, but after last update id got worse

i have tried meany things, & i'm not talking about YouTube, i'm talking about anime watching AuEngien & MP4Upload as 2 examples

i have 1sec or 2sec video freeze & then it speeds up to make even the 1sec - 2sec

被選擇的解決方法

I figured out how to make Flash run in a single core of your CPU without having to change the affinity in Task Manager manually! You can re-enable protected mode of Flash now. Just follow my instructions on how to disable protected mode except change the value of the setting to False. To make Flash run in a single core, follow the instructions in this video (I put this together "quickly" so forgive me. It actually took me one and a half of an hour to complete it which you probably wouldn't have guessed alone because it looks like a 6 year old put it together): http://youtu.be/F210MyTgZZE Just a quick note: if you update Adobe Flash Player, you might need to repeat the process that I showed you in the video after updating it.

從原來的回覆中察看解決方案 👍 1

所有回覆 (20)

more options

Just-A-User said

The problem might not even be Firefox related. WaterFox and Chrome both have built in Flash versions whereas Firefox uses the Adobe Flash Player installation on your computer. You can solve the problem by setting the affinity of the Flash Player process (not Firefox.exe, right?) to one CPU core, which makes the separate Adobe Flash Player even more suspicious.

that's the thing/reason chrome & Waterfox have build in flash, but firefox uses flash dirrectly, i see flash running in taskmanager, with waterfox i did not & it did not have lag issue, i did not say the issue is between firefox & flash, i said its probably cause of Win8 issue with core multitasking, with systems with multiple cores when it comes to flash, in chrome i had no issues, when i used it last, but in win 8 it crashes a lot, safe mode makes browser insecure

waterfox has even larger memory leak, i have never heard any1 with win7 having this issues, committed memory leaks to not just ram, it just increases with awry video, committed memory leaks only on full-screen, so in full screen i leak 2 types of memory. ram & committed, that's why i haven't used full-screen for a while

anime sources like here are the biggest issue, mostly with memory leak, watching animes make memory leak the most http://www.animeseason.com/toradora-episode-1/ same issue with TV series

the data on the post can't be updated

but for lag itself i have temporary fix, awry time flash launches/starts i need to set flash to 1 core, i have 4 total, i5 processor

由 Sugram22 於 修改

more options

I have a multi-core system and Windows 8 and Flash run just fine. Have you tried reinstalling Flash like I demonstrated in my previous posts? That's really the only hope by this point.

由 user1194064 於 修改

more options

Just-A-User said

I have a multi-core system and Windows 8 and Flash run just fine. Have you tried reinstalling Flash like I demonstrated in my previous posts? That's really the only hope by this point.

it happened ones by accident after i installed firefox to this PC, i wanted to test does VLC plugin play videos without flash so i disabled flash & forgot i disabled it later & when video asked flash i clicked on link & it just installed it & nothing changed, it was few in Nov or Dec 2014

win 8 or 8.1? in 8 chrome works bit better, in 8.1 its impossible, there is slight difference, i have intel processor, Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz (4 CPUs), ~3.1GHz, people on forum mentioned there is issue with win 8.1 & multi-core prepossessing with flash

right when i got new PC & win 8 i started to have issues with flash, first in my new PC, that (lest say it simply) broke down & was replaced with new & different model & it has Win 8.1 & here i have even more issues with videos & with some browsers, like chrome crashing, so i uninstalled it & replaced it with firefox & here this issues

no idea does this count do or not, but my old PC has 32Nit sys & my new broken & replaced PC & this PC have 64Bit sys, cause flash is 32bit, maybe that's part of the issue

由 Sugram22 於 修改

more options

i have a question, can VLC plugin add oil to fire, i ask cause this is connected with video to & OpenH264 Video Codec provided by Cisco Systems, Inc. 1.3, other plugins are ask to active so this should not effect cause i haven't peen on a page where fox asks to use the other plugins, also does fox has any issue with spybot free ver 2.4? asking cause i have spybot, or just issue with its internet protection part? i am not thinking this thing cause the issue, just that this may add oil to fire, if any1 has heard of this things have issues with fox, also its just a question out of curiosity

由 Sugram22 於 修改

more options

i have no idea when ver 37 came out cause i had no notification, i just clicked on help & about firefox & it started downloading, i was surprised, my point is, that i watched 10 min & memory did not go much over 300mb, it was 270-320, i don't know is it a temporary thing, like tomorrow the issues are back, i hope new ver really fixed this issues this time, & i went as far as to go to full-screen (cause it was the worse in full-screen), its just i need to sleep new :D when i come back tomorrow i will report back before i go sleep again or w8 few day's with it, well its already tomorrow (according to clock it is), but to me its not cause i haven't slept yet despite what the clock say's :D

i noticed a huge issue that is fixed, before update Flash started running even when i opened youtube site, any page, mane page & my profile, but it should not do that & new it does not

由 Sugram22 於 修改

more options

Sugram22 said

Just-A-User said
I have a multi-core system and Windows 8 and Flash run just fine. Have you tried reinstalling Flash like I demonstrated in my previous posts? That's really the only hope by this point.

it happened ones by accident after i installed firefox to this PC, i wanted to test does VLC plugin play videos without flash so i disabled flash & forgot i disabled it later & when video asked flash i clicked on link & it just installed it & nothing changed, it was few in Nov or Dec 2014

win 8 or 8.1? in 8 chrome works bit better, in 8.1 its impossible, there is slight difference, i have intel processor, Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz (4 CPUs), ~3.1GHz, people on forum mentioned there is issue with win 8.1 & multi-core prepossessing with flash

right when i got new PC & win 8 i started to have issues with flash, first in my new PC, that (lest say it simply) broke down & was replaced with new & different model & it has Win 8.1 & here i have even more issues with videos & with some browsers, like chrome crashing, so i uninstalled it & replaced it with firefox & here this issues

no idea does this count do or not, but my old PC has 32Nit sys & my new broken & replaced PC & this PC have 64Bit sys, cause flash is 32bit, maybe that's part of the issue

Windows 8.1 is essentially the same as Windows 8. It just has the new Start menu button and some other minor changes. The upgrade from Windows 8 to Windows 8.1 did not cause the problem. About how Adobe Flash Player is 32-bit and you have a 64-bit processor, Flash will run fine on both 32-bit and 64-bit CPUs. 64-bit CPUs can run almost all 32-bit programs (in fact, most programs such as Firefox, your video player, text editors, etc are 32-bit).

more options

I've been snooping around the forums and discovered a potential fix to your problem. Another user had issues with Flash lagging, and disabling Protected Mode, a mode of Flash that "sandboxes" it (limits what Flash can do to increase security), fixed the problem. Try this:

  1. Open Firefox.
  2. Type about:config into the address bar and press Enter on your keyboard.
  3. If a warning that says "This might void your warranty!" appears, click the I'll be careful, I promise button.
  4. You'll be greeted with a screen that has a search bar. Type this into the search bar: dom.ipc.plugins.flash.disable-protected-mode (make sure that there are no spaces at all)
  5. In the space below the search bar, right click the only result and click Toggle so that the value changes to True.
more options

Sugram22 said

i have a question, can VLC plugin add oil to fire, i ask cause this is connected with video to & OpenH264 Video Codec provided by Cisco Systems, Inc. 1.3, other plugins are ask to active so this should not effect cause i haven't peen on a page where fox asks to use the other plugins, also does fox has any issue with spybot free ver 2.4? asking cause i have spybot, or just issue with its internet protection part? i am not thinking this thing cause the issue, just that this may add oil to fire, if any1 has heard of this things have issues with fox, also its just a question out of curiosity

VLC shouldn't cause problems with Flash Player. When you play videos online, they're almost always powered by Adobe Flash Player. Spybot might be causing the problem. If you tried my suggestions from the above post and it didn't help, can you uninstall Spybot, restart your computer, then see if the issue with Flash still occurs? If you're still having problems with Flash after Spybot is uninstalled, you can download Spybot and reinstall it, but if the problems with Flash disappear, Spybot is the cause of the problem...you can then either leave it uninstalled, or if you want Spybot back, visit the Spybot support page and report the problem. If they can roll out a fix in response to the problem report, reinstall it.

由 user1194064 於 修改

more options

Just-A-User said

I've been snooping around the forums and discovered a potential fix to your problem. Another user had issues with Flash lagging, and disabling Protected Mode, a mode of Flash that "sandboxes" it (limits what Flash can do to increase security), fixed the problem. Try this:
  1. Open Firefox.
  2. Type about:config into the address bar and press Enter on your keyboard.
  3. If a warning that says "This might void your warranty!" appears, click the I'll be careful, I promise button.
  4. You'll be greeted with a screen that has a search bar. Type this into the search bar: dom.ipc.plugins.flash.disable-protected-mode (make sure that there are no spaces at all)
  5. In the space below the search bar, right click the only result and click Toggle so that the value changes to True.

some say disabling protection mode is security risk, that it was made to protect against bad-ware & viruses, or is it really so minor thing that it doesn't matter? i have heard some1 in 1 forum mention it before, but with out instructions how, i was just reading a discussion people had in 1 forum & read it, i'm interested about how risky it is to disable it

would disabling spybot protection from Fox work to, it say's blocking 3th party cookies from 2 browser IE & Fox, so there would not be any need of uninstalling spybot?

由 Sugram22 於 修改

more options

Just-A-User said

Sugram22 said
i have a question, can VLC plugin add oil to fire, i ask cause this is connected with video to & OpenH264 Video Codec provided by Cisco Systems, Inc. 1.3, other plugins are ask to active so this should not effect cause i haven't peen on a page where fox asks to use the other plugins, also does fox has any issue with spybot free ver 2.4? asking cause i have spybot, or just issue with its internet protection part? i am not thinking this thing cause the issue, just that this may add oil to fire, if any1 has heard of this things have issues with fox, also its just a question out of curiosity

VLC shouldn't cause problems with Flash Player. When you play videos online, they're almost always powered by Adobe Flash Player. Spybot might be causing the problem. If you tried my suggestions from the above post and it didn't help, can you uninstall Spybot, restart your computer, then see if the issue with Flash still occurs? If you're still having problems with Flash after Spybot is uninstalled, you can download Spybot and reinstall it, but if the problems with Flash disappear, Spybot is the cause of the problem...you can then either leave it uninstalled, or if you want Spybot back, visit the Spybot support page and report the problem. If they can roll out a fix in response to the problem report, reinstall it.

for new it seems disabling protection made helped, i did only that, no idea does memory leak with just browsing to cause mostly i do both, first watch video then brows something, that's why i am not sure, but i update, i mean make new post when i notice something, i guess i keep an eye on it few days unless there isn't anything to tell or ask before that, new taskmanager does not show flash running, 2 processes with flash icon

more options

small thing i want to say, sound is playing games, it starts lower vol & i give it a bit Vol & suddenly vol goes up & i half to take vol down again, it is happening today, vol bar on the player did not move, it has happened 2 times today, once where i watched series fit flash & few times with HTML5, seem that update 37 forced HTML5 on fox for youtube, with out option to turn it off

well its to early to mention this, but seems with lag it helped, but memory leak is just limited new, it went over 400MB, but hasn't gone over that yet

more options

seems memory leak is still a issue, lag seems to be gone, + that sound thing, unless its bad luck & i stumbled on videos that had issue with some1 messing up sound, but 3-4 times can it be bad luck? :D

more options

memory over 600 new, seems fox it self has some stability issues to, or is HTML5 just making it worse? currently watching gameplay videos from youtube

more options

lag came back & new instead of doing this http://www.tech-recipes.com/wp-content/uploads/2013/01/windows7-taskmanager3.jpg on flash.exe i half to do it on plugin-container, should i enable protection mode then?

more options

tried disabling hardware acceleration this time, with out protection mode this seem to work, but how long, maybe it will come back like when i turned off protection mode

more options

seems the issue with me is with how much crores are used with handling videos, i does not effect HTML5, only flash, so only this works http://www.tech-recipes.com/wp-content/uploads/2013/01/windows7-taskmanager3.jpg

also HTML5 cause larger memory leak then flash, memory leak from flash is decreased, this are changes update 37 made for me + it removed option to go back to flash, the link for that is gone from this page https://www.youtube.com/html5

& for lag this http://www.tech-recipes.com/wp-content/uploads/2013/01/windows7-taskmanager3.jpg temporary fix is only think that works for me so far, downside is that awry time flash starts to run i need to do it again

由 Sugram22 於 修改

more options

You should disable or uninstall Spybot temporarily and then see if the problem with Flash still happens. As long as you don't download any files or do anything potentially dangerous while it is disabled, you're fine. Protection mode is a second defense against attacks on Flash Player. When new vulnerabilities in Flash that attackers can use to access your system are discovered, they're patched, but sometimes these patches can take a long time to come out or some vulnerabilities may not be discovered at all. If something tries to attack Flash using a vulnerability that has not been discovered or fixed yet, Protection mode might be able to prevent the attacks from actually affecting your system. Disabling protected mode does decrease security, but if it helps, go for it.

more options

To watch videos on YouTube with the Flash player and not the HTML5 player, just click here then click the "Use Default Player" button. Is that button missing?

由 user1194064 於 修改

more options

I think that your Firefox memory usage is normal. My Firefox uses 324 MB of memory.

由 user1194064 於 修改

more options

選擇的解決方法

I figured out how to make Flash run in a single core of your CPU without having to change the affinity in Task Manager manually! You can re-enable protected mode of Flash now. Just follow my instructions on how to disable protected mode except change the value of the setting to False. To make Flash run in a single core, follow the instructions in this video (I put this together "quickly" so forgive me. It actually took me one and a half of an hour to complete it which you probably wouldn't have guessed alone because it looks like a 6 year old put it together): http://youtu.be/F210MyTgZZE Just a quick note: if you update Adobe Flash Player, you might need to repeat the process that I showed you in the video after updating it.

由 user1194064 於 修改

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5