搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Videos on Weather.Com won't play?

  • 11 回覆
  • 1 有這個問題
  • 75 次檢視
  • 最近回覆由 Norm@Home

more options

A friend of mine asked me to help him out with this and I'm sorry to say, I'm stumped. He's got a Windows 8.1 system (full version, U.S. not K or N), this is his regular office computer (he's the manager at a Electrical Contractor) and he watches Weather.Com and it's videos to try and plan for any snow closings. At some point, the videos on Weather.Com stopped playing and all they show is a black window on the page where the video should be playing.

There was another thread (archived now) about this problem on FireFox 25 (he's using the latest 35.0.1 and the latest Flash player 16.0.0.305) and I tried several of the suggestions in that old thread: First FireFox has minimal addons, uses the Noia Fox 3.0.1 theme and that's it; plugins listed are OpenH264 Video Codec; Shockwave Flash 16.0.0.305; Adobe Acrobat 11.0.10.32; Google Earth Plugin 7.1.2.2041; Google Update 1.3.26.9; iTunes Application Detector 1.0.1.1; NVidia 3D Vision 7,17.13.4411; Picasa 3.0.0.0 and that's all, no AdBlock Plus or anything else. I tried FireFox in safe mode and still couldn't watch; the driver for the nVidia 610 graphics adapter was slightly out of date and I updated it to the latest 347.52 and that made no difference.

I was able to watch Weather.Com videos with IE; I was also able to watch YouTube and MSN videos with FireFox and this problem seems to only affect Weather.Com.

Does anyone have any idea's?

- Norm

I did some basic scans to see if there were viruses or malware with TDSKiller, Malwarebytes and Spybot Search & Destroy and they turned up nothing other than a few tracking cookies.

所有回覆 (11)

more options

BTW, I tested weather.com on my own Windows 7 and 8.1 computers and I didn't have this problem so whatever is wrong here seems to be specific to this computer.

more options

Norm,

Don't know if this will help, or not, but give it a try. If it doesn't correct the problem you can always change it back.

In FF browser click on Tools, then Add-ons, go to plugins, find OpenH264 Video Codec..., in drop down window click on "Never Activate" and then click Options and turn "off" automatic updates.

Let me know if this helps.

more options

SouthernStyle:

I gave that a try and it didn't make any difference; as far at I can tell they're Flash videos; I can right click on the videos and I get a dialog that says this:

AMP Premier - Weather Channel v0.9.0.0004 4.9.0.007 Settings Global Settings About Flash Player 16.0.0.305

the only option that settings and global settings give me is to disable or enable hardware acceleration; hardware acceleration is enabled by default and I've tried disabling it and that doesn't make any difference as far as the problem goes.

- Norm

more options

Actually, I'm sorry but global settings does give me more settings but nothing that seems to pertain to this problem.

more options

Do you see a Lego block icon on the location/address bar that a plugin is used on the web page?

You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Hi Cor-el:

I clicked on the lego block and it says "Adobe Flash is enabled on www.weather.com".

Checking the security tab all permissions are set to "Use Default".

As I indicated in my first post, there was an archived article that mentioned a problem with Weather.Com videos in regards to FireFox 25 and one of the suggestions was to try FireFox in safe mode which I have tested and the problem happens in safe mode as well.

I switched the theme from Noia Fox to the default theme and restarted and tried the Weather.Com video's again and they still would not play.

The computer has Eset Endpoint security 5.0.2237 installed but the enhanced firewall was disabled on install and the system is using the regular windows firewall. I've also tried disabled the anti-virus and trying Weather.Com again but with the same results.

- Norm

more options

Anyone else? I'm still trying to work this problem out.

more options

Tried resetting FireFox, removed all add-ons and extensions and Weather.Com videos still won't play. Can someone give me some idea's on how to fix this?

more options

Anyone? I could really use some help?

more options

Please be patient. We are helping many who have problems.

Download Firefox v36.4 Full Installer For All languages And Systems {web link}

Update your Flash Player Version 17.0.0.134
https://www.adobe.com/products/flashplayer/distribution3.html

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

I had done all of that but no improvement.

I just updated from FireFox 36 to 37.0.1 and it seems like as least some Weather.Com videos play while others do not; so I'll take it and continue to work on it.