Search Support

Local MP4 files always open in Firefox embedded video player

  • 5 回覆
  • 7 有這個問題
  • 2676 次檢視
  • 最近回覆由 Waynerro

more options

I believe prior to Firefox 35 I was able to open local links to mp4 files and Firefox would prompt me for what to do (Open, Save, etc.). Now local links to mp4 files always open in the embedded Firefox video player with no option to do otherwise. I have tried setting 'media.windows-media-foundation.enabled' to 'false' and it has no effect on local links to mp4 files. All other common video formats that I have tested (e.g. avi, mpg, wmv) prompt me for what to do, as is the expected behavior.

To reproduce:

1.) Enter in url: file://///path/to/video.mp4 2.) Observe that the file opens in the embedded video player with no option to do otherwise

被選擇的解決方法

hello, please set media.windows-media-foundation.enabled back to its default preference and try turning media.play-stand-alone to false instead.

從原來的回覆中察看解決方案 👍 8

All Replies (5)

more options

選擇的解決方法

hello, please set media.windows-media-foundation.enabled back to its default preference and try turning media.play-stand-alone to false instead.

more options

And now it looks like FF36 broke this setting. I have media.windows-media-foundation.enabled set to true (default), and media.play-stand-alone set to false, and the behavior is to open mp4 files in the embedded viewer again. Sigh.

more options
more options

Your first link seems to suggest that if EITHER "media.windows-media-foundation.play-stand-alone" or "media.play-stand-alone" is set to false (only the latter is applicable on newer versions of FF) then mp4 videos won't be opened in the embedded video player. However my experience suggests this is not the case.

more options

When I have an issue with this after reinstalling Firefox I typically only have to change media.play-stand-alone to false and do not have to touch the other setting: media.windows-media-foundation.enabled.

It's insulting that Mozilla has not fixed this problem after several updates to Firefox.