搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

resetting fixed the problem, restoring my backed up profile brought it back... what now?

more options

On any site where there was an editing screen, the sprites disappeared (see screenshot). I checked Safari, and the sprites were all in place. So I made sure my FF installation was backed up, and I reset. When FF finally rebooted, the problem was gone, but of course all my add-ons and customizations were gone.

I found the 'old Firefox data' folder on my desktop, quit Firefox and replaced the new profile with the old one. When I opened Firefox, all the customizations were in place, but the sprites had disappeared again.

The idea of turning all extensions off and on to check to see which one is interfering is daunting. Is there a more direct way to pinpoint the source of the problem?

Thanks for any help you can provide.

附加的畫面擷圖

被選擇的解決方法

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead.

Make sure that you allow pages to choose their own fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

從原來的回覆中察看解決方案 👍 1

所有回覆 (3)

more options

I don't know about sprites, but these can help you;


These can't get your data back, but will help in the future.

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences

more options

選擇的解決方法

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead.

Make sure that you allow pages to choose their own fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

more options

Thank you so much for that elegantly simple solution. Whew.