搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Can't undo "always use private surfing"

  • 2 回覆
  • 1 有這個問題
  • 1 次檢視
  • 最近回覆由 Gnospen

more options

I have the box "always use private surfing" checked. After installing 35.0 I can't turn it of. As soon as I uncheck this box FF restarts. BUT again in private mode. And the box stays checked. I tried about:config setting "browser.privatebrowsing.autostart to false. It resets itself to true after restart. What else can I do?

被選擇的解決方法

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. You can check its content with a plain text editor (right-click: Open with). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself. You can reset involved prefs on the about:config page to the default value.

See also:


You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

選擇的解決方法

Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. You can check its content with a plain text editor (right-click: Open with). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can delete the user.js file if you didn't create this file yourself. You can reset involved prefs on the about:config page to the default value.

See also:


You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

more options

Thanks @Cor-el I must be tired, of course it's in user.js. Fixed it and all is fine.