搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why can't I login to Firefox Accounts to set up Sync? FF30+ keeps telling me to Please enable cookies; cookies ARE enabled, already tried Safe Mode.

  • 4 回覆
  • 10 有這個問題
  • 4500 次檢視
  • 最近回覆由 seraphicgate

more options

Exactly what it says on the tin.

Why can't I log-in to Firefox Accounts to set up Sync from my laptop PC? FF30+ keeps telling me to Please enable cookies; cookies ARE enabled, and I already tried Safe Mode. This has been happening ever since the new Sync was implemented, so I'm guessing around FF 30. I am now up to FF version 34 and it still isn't working. I have not been able to sync since the "update."

Problem #1: Going to about:accounts and clicking on the blue Get Started button opens a blank screen. There isn't even a prompt about cookies. It's just blank. Screen shot attached. This is before add-ons are disabled. If they're disabled in Safe Mode, we go to Problem #2.

Problem #2: I skimmed a thread (https://github.com/mozilla/fxa-content-server/issues/1017) and tried logging in to Sync through accounts.mozilla.com instead, but though the screen doesn't turn blank while add-ons are still enabled, the "Enable cookies" warning is as far as I can get. Going to about:accounts in Safe Mode has the same result. I have cleared all my cookies and my cache, restarted FF multiple times with and without add-ons enabled, and still nothing. I have browsed this support forum for similar questions, and while other people are having the same issue, none of the other threads have been resolved yet. Several FF versions later, this is way too long for this issue to still be unresolved.... Screen shot attached.

I know where Firefox's cookie manager is located, and I have toggled all the settings. I even allowed third-party cookies (though I really shouldn't since they're pointless). No difference. Screen shot attached.

I looked in about:config and searched for the word "cookie" in the names, but even doing that is pointless for me since I'm not a programmer and hence ignorant in what all these settings actually mean. Screen shot attached.

I'm at the end of my rope here, guys. It's been months. A year. Maybe more than a year; I don't even know anymore. I just got a new device and I don't want to add all my Firefox information to it one-by-one. There doesn't seem to be any way to contact Mozilla directly, so.... Someone help, please....

附加的畫面擷圖

被選擇的解決方法

Make sure that you allow cookies for the accounts.firefox.com domain if you aren't allowing cookies generally or use the 'Ask me' cookie setting.

You can check if DOM Storage is enabled.

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

NoScript stops cookies, please disable this addon/extension as well as make sure that the language en-us is installed.

  1. 1) Open up the Firefox Preferences tab. You can do this by typing about:preferences in the URL bar.
  2. 2) Click "Content"
  3. 3) Next to "Languages", click "Choose"
  4. 4) Select "English/United States [en-us]", click "Add"
  5. 5) re-open "about:accounts"
  6. 6) Click "Get Started"
more options

guigs2 said

NoScript stops cookies, please disable this addon/extension as well as make sure that the language en-us is installed.
  1. 1) Open up the Firefox Preferences tab. You can do this by typing about:preferences in the URL bar.
  2. 2) Click "Content"
  3. 3) Next to "Languages", click "Choose"
  4. 4) Select "English/United States [en-us]", click "Add"
  5. 5) re-open "about:accounts"
  6. 6) Click "Get Started"

Thank you for replying. Unfortunately, I already did all of these things. As you can see from the below screenshot, the language is already set. Also, this screenshot was taken in Safe Mode, so NoScript is not enabled. About:accounts still says I need to enable cookies for some reason. So, this solution didn't work....

由 seraphicgate 於 修改

more options

選擇的解決方法

Make sure that you allow cookies for the accounts.firefox.com domain if you aren't allowing cookies generally or use the 'Ask me' cookie setting.

You can check if DOM Storage is enabled.

more options

Thank you so much!!! It appears the DOM Storage configuration was the solution. Once I set it to true and restarted in Safe Mode, I was able to Sync. Thanks again!