搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Pandora will not finish loading in firefox though it works fine in chrome

  • 6 回覆
  • 2 有這個問題
  • 18 次檢視
  • 最近回覆由 jmswood

more options

I've been using Firefox for several years and Pandora has played without problems. For the last week or so I've been unable to load Pandora. The screen says Pandora and the spinning wheel spins until I get a message telling me "it is taking longer than expected to fetch the next song ..." . I've tried the troubleshooting suggestions of Pandora and of Firefox. I deleted cookies, cache and history. Finally I reset Firefox . I still get the same message. The strange thing is Pandora works just fine on the Chrome browser on the same computer. Please help if you can. Thanks

所有回覆 (6)

more options

Hi, jmswood!

Let's see what we can do.

I see in your additional system information that under "JavaScript" is says "Activated=false". Having JS disabled could be preventing the page from loading the content.

Do you have JavaScript turned off or some form of JS blocking extention?

more options

Hi Topher,

I don't know. My tech knowledge is very limited. I haven't intentionally changed any JavaScript settings recently. Pandora was playing normally until 10 days ago. As I mentioned it continues to work just fine on Chrome.

Thanks for taking the time to try to help.

more options

Okay, let's try this...

about:config

  1. In the address bar, type "about:config" (with no quotes), and press Enter.
  2. Click "I'll be careful, I promise"
  3. In the search bar, search for "javascript.enabled" (with no quotes).

On the right side, in the "Value" column does it say true or false?

If it says false:

  1. Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now enabled.
more options

Thanks Topher,

I followed your suggestions. The values column indicated "True". I guess that means JavaScript was already enabled.

Must be something else. Do you have any other ideas? I appreciate your efforts.

more options

Yeah, if is saying true, then JS is enabled.

Give this a shot:

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Let us know if that fixes anything...

more options

Hi Topher,

I tried safe mode. Same problem. I don't know if you noticed but in my original post I mentioned that I reset Firefox before starting this conversation. That didn't help either.

I hope you have some other ideas.