搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do i remove tabs on top in v 33.1

  • 15 回覆
  • 5 有這個問題
  • 1587 次檢視
  • 最近回覆由 DMickG

more options

i just did a restore firefox action because i had a firefox message stating that could speed up my browser. After doing this, it has defaulted to putting my tabs on top. i really don't like tabs on top and want to change that setting. i read in one forum that i needed to change the setting in about:config. However I do not see the referenced tabsontop setting that was referenced. Ho can i remove tabs on top?

Bonus question: I have always liked having the description of the icons in the menu bar available. i.e. the home icon not only displays a house, but the text "home" as well.

thanks in advance for any assistance!

被選擇的解決方法

Hello,

I believe you had the Classic Theme Restorer extension which is used to bring back the old design. Learn more here: How to make the new Firefox look like the old Firefox

從原來的回覆中察看解決方案 👍 0

所有回覆 (15)

more options

選擇的解決方法

Hello,

I believe you had the Classic Theme Restorer extension which is used to bring back the old design. Learn more here: How to make the new Firefox look like the old Firefox

more options

You are correct! Thanks for the help!

more options

Note that you can move the tabs to the lower position just above the browsing area without using an extension with code in userChrome.css because you only need to give the Tab bar a higher -moz-box-ordinal-group value (most toolbars have a default -moz-box-ordinal-group:1 to show them in DOM order).


Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#TabsToolbar{-moz-box-ordinal-group:10000!important}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

由 cor-el 於 修改

more options

cor-el said

Note that you can move the tabs to the lower position just above the browsing area without using an extension with code in userChrome.css because you only need to give the Tab bar a higher -moz-box-ordinal-group value (most toolbars have a default -moz-box-ordinal-group:1 to show them in DOM order).

Add code to the userChrome.css file below the default @namespace line.


@namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#TabsToolbar{-moz-box-ordinal-group:10000!important}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

more options

I set up a .txt file called userChrome.css in what I identified as my Profile Folder. I then, as instructed, keyed everything that follows below into it, adding a carriage return after "once */". I saved then the file and restarted FireFox but nothing has changed.

@namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

  1. TabsToolbar{-moz-box-ordinal-group:10000!important}

HELP! when I preview this reply I expect to see what I keyed but I am getting an indented 1. before TabsToolbar instead of just a hash sign!

more options

The userChrome.css file is not a text file with a .txt file extension, but should be a CSS file with as .css file extension as you should be able to verify in the properties via the right-click context menu.

more options

cor-el said

The userChrome.css file is not a text file with a .txt file extension, but should be a CSS file with as .css file extension as you should be able to verify in the properties via the right-click context menu.

Sorry, I should have said - I created it as a .txt file file but then renamed it to a .css file. I have also, since posting my earlier reply, noticed that it should be within the Chrome folder in my profile folder. I have therefore created a Chrome folder - there wasn't one - and moved the userChrome.css file into it, restarted FireFox but still it doesn't work.

more options

The 'chrome' folder name needs to be lowercase chrome.

more options

I had named it "Chrome" but renamed it "chrome". It still didn't work. So I renamed the file "userchrome.css" to get rid of the uppercase 'C' in "chrome". Still no good, so I restored the upper case.

Just in case the error is with the contents of the file, here they are:

@namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

  1. TabsToolbar{-moz-box-ordinal-group:10000!important}
more options

That's really weird! It has replaced the "#" at the beginning of the second line in the file with"indent 1. "

more options

The name if the folder is lowercase chrome, but the name of the userChrome.css file is with an uppercase 'C'.

A line that starts with a "#" (OL) or '*' (UL) generates a list. To avoid that you can start the line with a space.

You can try to open the userChrome.css file in the Scratchpad (Firefox/Tools > Web Developer) to see if it still display correctly and that the file is a .css file.

more options

Thank you for all your help btw.

My folder and file names are correct.

I opened the file in Scratchpad and it displayed ok. And it described it as a Cascading Style Sheet file. I imagine this is all correct. Then I noticed that there was a carriage return between the two statements. I removed that but it still didn't work.

Here is what I currently have in userChrome.css:

@namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

  1. TabsToolbar{-moz-box-ordinal-group:10000!important}
more options

Did you check that an extension isn't blocking this?

Note that the userChrome.css and userContent.css are disabled in Safe Mode, so that wouldn't work as a test.

more options

cor-el said

Did you check that an extension isn't blocking this? Note that the userChrome.css and userContent.css are disabled in Safe Mode, so that wouldn't work as a test.

I appreciate your help. I really do want to sort this out but today I am very busy. I will reply as soon as I get chance to check out your latest suggestion. BIG THANKS.

more options

Hello. I'm back again. Season's Greetings!

I did go to that section you mentioned and started FireFox in Safe Mode which is what it suggests you do. The problem was still there in Safe Mode. But, reading what you wrote below the URL address, you seem to be suggesting that this wouldn't help anyway so I am confused.