搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Add ons do not stay loaded...

  • 5 回覆
  • 6 有這個問題
  • 605 次檢視
  • 最近回覆由 XRaiderV18

more options

I have to reinstall certain certain add ons after computer restart, after disconnecting and reconnecting to the internet, and sometimes even after closing and re-opening Firefox. The add ons are Add Block plus, No Squint, and Classic Theme Restorer. This is a recent issue that arose after the latest upgrade. Is there anything that can be done to solve this???

被選擇的解決方法

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete possible addons.json and addons.sqlite files.

You can also check for problems with preferences.

從原來的回覆中察看解決方案 👍 1

所有回覆 (5)

more options

I keep loosing adblock plus, tabmix plus and videodownload helper on my end. thank you god it isnt just me!

more options

選擇的解決方法

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete possible addons.json and addons.sqlite files.

You can also check for problems with preferences.

more options

Thanks. Since I was not 100% sure of the files the info from the links helped. I went ahead and did the reset Firefox then reloaded the add ons. There was an obvious corruption in one of the files. All seems to be working as it should be.

more options

going to try that myself. will update with progress here https://support.mozilla.org/en-US/questions/1031052#answer-654088

more options

attempt failed. decided to go one further and deleted my browser's profile this time.