X
點擊此處開啟此網站的行動版。

技術支援討論區

Shockwave Flash may be busy or it may have stopped responding error. Can the Mozilla team fix this for Firefox 34?

已張貼

Hello people, sometimes I would get the message "Shockwave Flash may be busy or it may have stopped responding". There is no way I can fix this. I have tried Google and they don't show tutorials on how to permanently fix this. What year is this? 2002? Not it's not. It's almost 2015. Can you please fix this for Firefox 34 or newer?

Hello people, sometimes I would get the message "Shockwave Flash may be busy or it may have stopped responding". There is no way I can fix this. I have tried Google and they don't show tutorials on how to permanently fix this. What year is this? 2002? Not it's not. It's almost 2015. Can you please fix this for Firefox 34 or newer?

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 15.0 r0
  • Google Update
  • 5.1.30514.0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • Unity Player 4.3.5f1
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.9.149
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • npsitesafety
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0

更多資訊

FredMcD
  • Top 10 Contributor
4267 個解決方法 59839 個答案

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) https://forums.adobe.com/message/4468493#TemporaryWorkaround * disable hardware acceleration in the Flash plugin https://forums.adobe.com/thread/891337 See also: * http://kb.mozillazine.org/Flash#Troubleshooting

提出問題者

FredMcD, I can't even disable protected mode, my computer updated yesterday morning and I have hardware acceleration disabled. God I hate Fartwave Crash.

FredMcD, I can't even disable protected mode, my computer updated yesterday morning and I have hardware acceleration disabled. God I hate Fartwave Crash.
FredMcD
  • Top 10 Contributor
4267 個解決方法 59839 個答案

Why can't you disable protected mode?

Start your Computer in safe mode. Then start Firefox.

Starting The Computer In Safe Mode; Free Online Encyclopedia

Why can't you disable protected mode? Start your '''Computer''' in safe mode. Then start Firefox. '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode; Free Online Encyclopedia]'''

有幫助的回覆

FredMcD, I just want this piece of junk fixed.

FredMcD, I just want this piece of junk fixed.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 個解決方法 40290 個答案

Shockwave Flash is an Adobe product - it's up to them to fix it. All we can do here at Mozilla Support is offer suggestions that have worked for us and other users.

Have you tried Adobe Support? https://forums.adobe.com/community/flashplayer

Mozilla is working an a project code named Shumway - http://mozilla.github.io/shumway/ - that will play SWF files and eliminate the for having the Flash Player installed for Firefox.

Shockwave Flash is an Adobe product - it's up to them to fix it. All we can do here at Mozilla Support is offer suggestions that have worked for us and other users. Have you tried Adobe Support? https://forums.adobe.com/community/flashplayer Mozilla is working an a project code named Shumway - http://mozilla.github.io/shumway/ - that will play SWF files and eliminate the for having the Flash Player installed for Firefox.

提出問題者

the-edmeister, here is my report on the error: https://forums.adobe.com/message/6962585

the-edmeister, here is my report on the error: https://forums.adobe.com/message/6962585

提出問題者

the-edmeister, I am on Firefox 34 and it still crashes.

the-edmeister, I am on Firefox 34 and it still crashes.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 個解決方法 40290 個答案

有幫助的回覆

Did you disable smooth scrolling as mentioned here? https://forums.adobe.com/thread/1648411 Plus there's two places to disable hardware acceleration; in Flash abd in Firefox.

Also, Adobe has [once again] released a new version of Flash. Version 16.0.0.235 https://get.adobe.com/flashplayer/

Did you disable '''smooth scrolling''' as mentioned here? https://forums.adobe.com/thread/1648411 Plus there's two places to disable hardware acceleration; in Flash abd in Firefox. Also, Adobe has ''[once again]'' released a new version of Flash. Version 16.0.0.235 https://get.adobe.com/flashplayer/
mrbunnylamakins 9 個解決方法 140 個答案

sabbath99 said

Hello people, sometimes I would get the message "Shockwave Flash may be busy or it may have stopped responding". There is no way I can fix this. I have tried Google and they don't show tutorials on how to permanently fix this. What year is this? 2002? Not it's not. It's almost 2015. Can you please fix this for Firefox 34 or newer?

Most people forget about the "Online Setting" you can do http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html

''sabbath99 [[#question-1030024|said]]'' <blockquote> Hello people, sometimes I would get the message "Shockwave Flash may be busy or it may have stopped responding". There is no way I can fix this. I have tried Google and they don't show tutorials on how to permanently fix this. What year is this? 2002? Not it's not. It's almost 2015. Can you please fix this for Firefox 34 or newer? </blockquote> Most people forget about the "Online Setting" you can do http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html

提出問題者

sabbath99 said

Hello people, sometimes I would get the message "Shockwave Flash may be busy or it may have stopped responding". There is no way I can fix this. I have tried Google and they don't show tutorials on how to permanently fix this. What year is this? 2002? Not it's not. It's almost 2015. Can you please fix this for Firefox 34 or newer?

I'm now using Firefox 35 and it still crashes.

''sabbath99 [[#question-1030024|said]]'' <blockquote> Hello people, sometimes I would get the message "Shockwave Flash may be busy or it may have stopped responding". There is no way I can fix this. I have tried Google and they don't show tutorials on how to permanently fix this. What year is this? 2002? Not it's not. It's almost 2015. Can you please fix this for Firefox 34 or newer? </blockquote> I'm now using Firefox 35 and it still crashes.
cor-el
  • Top 10 Contributor
  • Moderator
17568 個解決方法 158896 個答案

In Firefox 35 and later you can toggle this pref to true on the about:config page to disable protected mode in the Shockwave Flash plugin:

  • dom.ipc.plugins.flash.disable-protected-mode = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

See:

In Firefox 35 and later you can toggle this pref to true on the <b>about:config</b> page to disable protected mode in the Shockwave Flash plugin: *dom.ipc.plugins.flash.disable-protected-mode = true You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config See: *http://www.ghacks.net/2014/12/21/how-to-disable-flash-player-protected-mode-in-firefox/