搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox will not start on homepage. Always starts on last tab(s) open

  • 6 回覆
  • 14 有這個問題
  • 11624 次檢視
  • 最近回覆由 jscher2000

more options

I have confirmed my options are set to open Google as my homepage, but after restarting, Firefox opens to the last open tab instead. A previous, now archived, thread shared this answer: Try opening the user.js file. For me, it only had one line, which was user_pref("browser.sessionstore.resume_session_once", true);. Once I deleted the file, everything went back to normal. However, I can't figure out where that user.js file is and I've tried searching for it to no avail. Help is appreciated. Thank you.

被選擇的解決方法

On about:config, make sure to separate about and config with a colon (:) so that Firefox recognizes it as an internal page.

After exiting Firefox, can you make sure it is fully exiting? To do that, please check the Windows Task Manager, which you can open using Ctrl+Shift+Esc.

  • The Applications tab should show any open windows, which presumably will all be closed. If the tab lists a Firefox window that you can't access, it could be "off-screen".
  • The Processes tab will initially list firefox.exe, which should gradually release memory and eventually disappear (for me, the time to do this varies depending on how long Firefox was running and how much memory it was using).

I'm not sure what you mean by restoring an earlier version. I wouldn't use the Windows system restore feature for this, as it may wipe out recent bookmarks, etc. If you want to experiment with a different version of Firefox, please see this article for the download, and use the Clean Reinstall procedure: Install an older version of Firefox.

從原來的回覆中察看解決方案 👍 1

所有回覆 (6)

more options

Coincidentally, I just posted about the same thing a few minutes ago:

Sometimes external software will create or update an optional settings file named user.js. For some reason, one of the things that often shows up in there is a preference to restore your previous session just once. However, because Firefox uses user.js to override your normal settings every time it starts, that then turns into a permanent change. To check for this and remove any user.js file you find, try this support article: How to fix preferences that won't save.

Note that by default, Windows hides your Firefox profile folder from search and from easy browsing in Windows Explorer. You can access the folder from within Firefox using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch the folder in Windows Explorer.

Any luck?

more options

Actually, I see your More System Details shows you have no user.js file, so it must be something else.

One possibility is that Firefox keeps crashing during shutdown, and so Firefox is recovering from a crash every time. To diagnose this, you can change how Firefox recovers from a crash: instead of trying to restore the session, it will show a list of what you had open so you can be selective or bypass it altogether. Here's where you change that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionstore.max_resumed_crashes preference and change the value from 1 to 0 and OK that.


A second possibility is that the shortcut you use to start Firefox might have been modified. If you right-click it and choose Properties, then the Shortcut tab, the "target" for 64-bit Windows 7 should be just the following, no more, no less:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

A third possibility is another kind of optional configuration file, a lock file. These are fairly rare outside a business environment, but because they are so little know, they sometimes are created by malware. Such a file would be in Firefox's program folder. The easiest way to clean up that folder actually is the following:

"Clean reinstall" procedure

(1) Download a full installer for Firefox 33 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit Firefox or close all open Firefox windows

(3) Rename the Mozilla Firefox program folder

64-bit Windows:

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

32-bit Windows:

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • OldFirefox\Plugins
  • OldFirefox\browser\plugins
more options

Thank you for your clear, thorough and speedy reply; however...none of the solutions worked. Interestingly, when I tried the first one, it got me to the "be careful" box, but I had to close other windows, and when I did that, and tried to re-do this solution, my Cox.net "sorry we can't find this website" page came up. Tried restart. Still the same.

Solution two: the properties were correct.

Solution three: I did that, and still not fixed.

Anything else you can recommend? Should I restore to the earlier version (8/30/14)

more options

選擇的解決方法

On about:config, make sure to separate about and config with a colon (:) so that Firefox recognizes it as an internal page.

After exiting Firefox, can you make sure it is fully exiting? To do that, please check the Windows Task Manager, which you can open using Ctrl+Shift+Esc.

  • The Applications tab should show any open windows, which presumably will all be closed. If the tab lists a Firefox window that you can't access, it could be "off-screen".
  • The Processes tab will initially list firefox.exe, which should gradually release memory and eventually disappear (for me, the time to do this varies depending on how long Firefox was running and how much memory it was using).

I'm not sure what you mean by restoring an earlier version. I wouldn't use the Windows system restore feature for this, as it may wipe out recent bookmarks, etc. If you want to experiment with a different version of Firefox, please see this article for the download, and use the Clean Reinstall procedure: Install an older version of Firefox.

more options

Thank you again for your help. I didn't have a colon in the about:config so that worked, and I changed the value. But the problem persisted. I went into options, and DUH! saw that the setting for when Firefox restarts was to show last opened windows and tabs!! I didn't even think to look at that - I just saw that Google.com was set as my homepage. I don't remember changing that...and in fact, used to like that Firefox would go back after a crash to last opened windows...but anyway, I feel pretty STOOPID...and am so sorry for the time you spent. Perhaps your answers will help someone else who experiences this soon. Regards...

more options

I'm glad you found that. Unfortunately, that isn't captured by the add-on that posts your settings, so I missed mentioning it as a possibility.