搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox won't show the italics on my website, but Chrome and Safari do.

  • 13 回覆
  • 3 有這個問題
  • 1337 次檢視
  • 最近回覆由 Patti

more options

Dear Mozilla Support, I have an editing website that lists many of the books I've edited (see http://www.desertsagebookeditor.com/trade-books-edited-waldygo.html and http://www.desertsagebookeditor.com/professional-and-academic-books-edited-waldygo.html ). When I designed the site in RapidWeaver 5, I put the book titles in italics. But Firefox won't show the titles italicized, although Chrome and Safari do. I'm running OSX 10.7 on a 2009 Macbook Pro (Firefox version 33.0.3). Do you have any idea how I can fix this? The tech guys at RapidWeaver say there is nothing wrong with my code. Thanks, Patti

由 cor-el 於 修改

被選擇的解決方法

This older version of the page in the Internet Archive has the correct italic styling: https://web.archive.org/web/20131208083151/http://www.desertsagebookeditor.com/trade-books-edited-waldygo.html

The newer version of the style.css has the "style reset" I mentioned that disables the em tag from appearing in italic.

Old version: https://web.archive.org/web/20131208083151cs_/http://www.desertsagebookeditor.com/rw_common/themes/blocksbox/style.css

New version: http://www.desertsagebookeditor.com/rw_common/themes/blocksbox/style.css (see Reset section at the top)

I have no idea why this changed, but I think that could be what caused it.

從原來的回覆中察看解決方案 👍 1

所有回覆 (13)

more options

Dear Patti-79399, been looking at your problem and I think that these steps helped.

Click options and go into the content tab, then choose the desired font and click OK.

If the problem persists, let me know.

Thank you,

USERHELP

more options

Dear User Help,

Where is "options"? I don't see it on any pull-down menu when Firefox is running. Also, how can I choose the desired font? My web page is a mixture of roman font, bold, and italics, so I don't want the entire page to be italics--only the booktitles. Should I select each title to be italics? But how can I do this on a completed webpage that is uploaded and online already? And there is no way to do it to the webpage before it's uploaded, because that page is already fine as is: italics are showing.

Still confused, Patti

more options

Maybe add a font-style: italic; rule to cases where you want such a font to show to force using an italic font as not every one may have the Times-Italic font that you specify. I'm not having it on Linux.


由 cor-el 於 修改

more options

Thanks for sending me the link, but when you design a site in RapidWeaver, the code is automatically written for you, and you cannot edit the code. I don't even know how to write code.

But maybe I misunderstood you. Maybe the changes would occur only in Firefox?

At any rate, it's not only two pages with book titles that have italics; every page has bold and italics, and I would have to manually select thousands of separate words throughout the website, while doing a side-by-side comparison of the articles in another browser to see what needs to be italics.

This problem only happened recently. My site looked fine on Firefox for years. I know my computer automatically updates Firefox, but maybe if I went back to an earlier version of Firefox it would be more compatible with my Rapidweaver 5. Did the version of Firefox recently get updated? If so, I should try to go back to an earlier version.

Thanks, Patti

more options

The guys at RapidWeaver must not be checking in Windows, either...

I'm not sure how you assigned the styles to your text, whether you are required to specify the font every time, or you can just specify normal, bold, italic, etc.

I looked at RapidWeaver's support site and I don't see an easy way to edit the HTML directly and having the software accept the change. Hmm... maybe you can link them to this thread.

What you have, for example, is this:

<p style="text-align:left;"><span style="font:14px Times-Bold; font-weight:bold; font-weight:bold; "><br />Arts, Entertainment<br /></span><span style="font:14px Times-Italic; "><em>Let’s Face It,</em></span><span style="font:14px Times-Roman; "> Kirk Douglas, Wiley & Sons, 2006<br /></span>

and what would be better is this:

<p style="text-align:left;"><span style="font-weight:bold; "><br />Arts, Entertainment<br /></span><em>Let’s Face It,</em> Kirk Douglas, Wiley & Sons, 2006<br />

or in other words, there's lots of stuff that could be removed:

<p style="text-align:left;"><span style="font:14px Times-Bold; font-weight:bold; font-weight:bold; "><br />Arts, Entertainment<br /></span><span style="font:14px Times-Italic; "><em>Let’s Face It,</em></span><span style="font:14px Times-Roman; "> Kirk Douglas, Wiley & Sons, 2006<br /></span>

But in testing that, I noticed that your theme has a "reset" rule that overrides Firefox's normal italicizing of content in em tags, so unfortunately you will need to style the title manually to overcome this. Or figure out the official RapidWeaver way.

more options

Hi Patti, it won't help to change your version of Firefox because you can't change the versions of people viewing your site.

I think the problem is the weird font names, such as Times-Bold and Times-Italic. They seem like shorthand for Time New Roman Bold and Times New Roman Italic instead of real font names. Firefox may have changed how it handles such font names.

Edit: See next post.

由 jscher2000 於 修改

more options

選擇的解決方法

This older version of the page in the Internet Archive has the correct italic styling: https://web.archive.org/web/20131208083151/http://www.desertsagebookeditor.com/trade-books-edited-waldygo.html

The newer version of the style.css has the "style reset" I mentioned that disables the em tag from appearing in italic.

Old version: https://web.archive.org/web/20131208083151cs_/http://www.desertsagebookeditor.com/rw_common/themes/blocksbox/style.css

New version: http://www.desertsagebookeditor.com/rw_common/themes/blocksbox/style.css (see Reset section at the top)

I have no idea why this changed, but I think that could be what caused it.

more options

Hi, jscher2000,

The way you assign the font style in RapidWeaver is simply highlight the word or phrase and then click an "I" button for italics in the Font window. Unfortunately, I can't edit the code that you show--or any code. There is only one way to tamper with the code and that is to add a specific piece of code in a little box on one of the design forms. I can't remember the details without opening up RW, but that is how you add Google Analytics code; add it to a little box and then RapidWeaver decides where in the page of code to put it. The user cannot directly insert or delete code.

Patti

more options

Hi, jscher2000,

Actually, there is a Times font, which is skinnier and more compressed than Times New Roman. It's a pretty common font, but in the last decade or so Times New Roman has gotten more popular. I used plain Times in my site. But this is not to say that you could be right about how Firefox handles the font.

Patti

more options

Wow, you are quite a detective to have figured this out! When you say "the newer version of the style.css," do you mean the newer version of Firefox or of RapidWeaver? I think you must mean RapidWeaver, but I just want to be sure before I email the tech guys at RapidWeaver.

Thanks for your help! Patti

P.S. I forgot I couldn't simply hit Reply to your emails in my inbox, so all of them were returned to me. I came here and copied and pasted my same replies, thus the delay . . .

more options

Hi, jscher2000, I just reread one of your emails more carefully, and you did say it was the theme causing this--so I take back my question about whether it was Firefox or RapidWeaver. The theme I used was Blocksbox. I'll get in touch with the developer of that software.

Thanks again for all of your help! Patti

more options

Hi Patti, although the theme's style.css file changed between the earlier version and now, I don't know how that happened, so yes, I think it is a good question to ask the developer.

more options

Hi, jscher2000, I know how it happened: when I upgraded from RapidWeaver 4.2 to RW5, I also had to download the more recent Blocks plug-in and Blocksbox theme.

I just don't know why it happened. It's not an improvement in function, so why did the developers change things?

Anyway, I sent a long email last night to the RW developers in England to see if there is a fix. Thanks for your help, Patti