X
點擊此處開啟此網站的行動版。

技術支援討論區

Flash plugin is installed and enabled, but Firefox doesn't recognize content.

已張貼

I have the latest version of flash player installed and enabled. When I go to Adobe's test page, it recognizes the install and lists the correct version number, but the test animation at the top of the page fails to load properly. Also, the applications handler in Firefox's 'options' menu fails to list any flash compatible file types. On YouTube, I'm met with the video throbber stuck, unmoving, against a black rectangle. Right clicking the video and trying to view the 'settings' dialog does nothing.

I have tried deleting 'pluginreg.dat' and a number of other solutions I've found online, but nothing has made a difference. My other plugins (java, acrobat, etc.) all work fine. Thanks, in advance, for any help.

I have the latest version of flash player installed and enabled. When I go to Adobe's test page, it recognizes the install and lists the correct version number, but the test animation at the top of the page fails to load properly. Also, the applications handler in Firefox's 'options' menu fails to list any flash compatible file types. On YouTube, I'm met with the video throbber stuck, unmoving, against a black rectangle. Right clicking the video and trying to view the 'settings' dialog does nothing. I have tried deleting 'pluginreg.dat' and a number of other solutions I've found online, but nothing has made a difference. My other plugins (java, acrobat, etc.) all work fine. Thanks, in advance, for any help.

由 Donuts 於 修改

額外的系統細節

已安裝的外掛程式

  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0

更多資訊

Application Basics
------------------
Name: Firefox
Version: 33.0
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Multiprocess Windows: 0/1
Crash Reports for the Last 3 Days
---------------------------------
All Crash Reports
Extensions
----------
Name: Adblock Plus
Version: 2.6.5
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Name: Classic Theme Restorer
Version: 1.2.5
Enabled: true
ID: ClassicThemeRestorer@ArisT2Noia4dev
Name: FlashFirebug
Version: 4.8.0
Enabled: true
ID: flashfirebug@o-minds.com
Name: FavIconReloader
Version: 0.8
Enabled: false
ID: FavIconReloader@mozilla.org
Graphics
--------
Adapter Description: Intel(R) HD Graphics
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM: Unknown
Device ID: 0x0152
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 9-26-2012
Driver Version: 9.17.10.2867
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Important Modified Preferences
------------------------------
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20141011015303
browser.startup.homepage_override.buildID: 20141011015303
browser.startup.homepage_override.mstone: 33.0
browser.tabs.warnOnClose: false
browser.urlbar.trimURLs: false
dom.mozApps.used: true
extensions.lastAppVersion: 33.0
font.internaluseonly.changed: true
gfx.direct3d.last_used_feature_level_idx: 0
media.gmp-gmpopenh264.enabled: true
media.gmp-gmpopenh264.lastUpdate: 1413404914
media.gmp-gmpopenh264.version: 1.1
media.gmp-manager.lastCheck: 1413994694
network.cookie.prefsMigrated: true
network.http.pipelining: true
network.http.proxy.pipelining: true
places.database.lastMaintenance: 1414069495
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.java: 2
plugin.state.npdeployjava: 2
plugin.state.nppdf: 2
print.printer_Lexmark_T620_(MS).print_bgcolor: false
print.printer_Lexmark_T620_(MS).print_bgimages: false
print.printer_Lexmark_T620_(MS).print_colorspace:
print.printer_Lexmark_T620_(MS).print_command:
print.printer_Lexmark_T620_(MS).print_downloadfonts: false
print.printer_Lexmark_T620_(MS).print_duplex: 1515870810
print.printer_Lexmark_T620_(MS).print_edge_bottom: 0
print.printer_Lexmark_T620_(MS).print_edge_left: 0
print.printer_Lexmark_T620_(MS).print_edge_right: 0
print.printer_Lexmark_T620_(MS).print_edge_top: 0
print.printer_Lexmark_T620_(MS).print_evenpages: true
print.printer_Lexmark_T620_(MS).print_footercenter:
print.printer_Lexmark_T620_(MS).print_footerleft: &PT
print.printer_Lexmark_T620_(MS).print_footerright: &D
print.printer_Lexmark_T620_(MS).print_headercenter:
print.printer_Lexmark_T620_(MS).print_headerleft: &T
print.printer_Lexmark_T620_(MS).print_headerright: &U
print.printer_Lexmark_T620_(MS).print_in_color: true
print.printer_Lexmark_T620_(MS).print_margin_bottom: 0.5
print.printer_Lexmark_T620_(MS).print_margin_left: 0.5
print.printer_Lexmark_T620_(MS).print_margin_right: 0.5
print.printer_Lexmark_T620_(MS).print_margin_top: 0.5
print.printer_Lexmark_T620_(MS).print_oddpages: true
print.printer_Lexmark_T620_(MS).print_orientation: 0
print.printer_Lexmark_T620_(MS).print_page_delay: 50
print.printer_Lexmark_T620_(MS).print_paper_data: 1
print.printer_Lexmark_T620_(MS).print_paper_height: 11.00
print.printer_Lexmark_T620_(MS).print_paper_name:
print.printer_Lexmark_T620_(MS).print_paper_size_type: 0
print.printer_Lexmark_T620_(MS).print_paper_size_unit: 0
print.printer_Lexmark_T620_(MS).print_paper_width: 8.50
print.printer_Lexmark_T620_(MS).print_plex_name:
print.printer_Lexmark_T620_(MS).print_resolution: 1515870810
print.printer_Lexmark_T620_(MS).print_resolution_name:
print.printer_Lexmark_T620_(MS).print_reversed: false
print.printer_Lexmark_T620_(MS).print_scaling: 1.00
print.printer_Lexmark_T620_(MS).print_shrink_to_fit: true
print.printer_Lexmark_T620_(MS).print_to_file: false
print.printer_Lexmark_T620_(MS).print_unwriteable_margin_bottom: 0
print.printer_Lexmark_T620_(MS).print_unwriteable_margin_left: 0
print.printer_Lexmark_T620_(MS).print_unwriteable_margin_right: 0
print.printer_Lexmark_T620_(MS).print_unwriteable_margin_top: 0
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1413205431
Important Locked Preferences
----------------------------
JavaScript
----------
Incremental GC: true
Accessibility
-------------
Activated: false
Prevent Accessibility: 0
Library Versions
----------------
NSPR
Expected minimum version: 4.10.7
Version in use: 4.10.7
NSS
Expected minimum version: 3.17.1 Basic ECC
Version in use: 3.17.1 Basic ECC
NSSSMIME
Expected minimum version: 3.17.1 Basic ECC
Version in use: 3.17.1 Basic ECC
NSSSSL
Expected minimum version: 3.17.1 Basic ECC
Version in use: 3.17.1 Basic ECC
NSSUTIL
Expected minimum version: 3.17.1
Version in use: 3.17.1
Experimental Features
---------------------

FredMcD
  • Top 10 Contributor
4274 個解決方法 59942 個答案

有幫助的回覆

Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac Then reinstall the latest version.

Flash player v15.0.0.189 http://get.adobe.com/flashplayer/


Flash Player Test Page Shockwave Test Page

Troubleshoot Shockwave Player installation | Windows Troubleshoot Shockwave Player installation | Mac OS

Flash Player Help / Video playback issues

--- fixed first download link as it was linking to Shockwave player and not the proper Flash player. If it says shockwave in end of link then that is not Flash but the shockwave for director or rather shockwave player.

Grab the uninstaller from here: '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows]''' '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac]''' Then reinstall the latest version. Flash player '''v15.0.0.189 http://get.adobe.com/flashplayer/''' --------------- '''[https://www.adobe.com/software/flash/about/ Flash Player Test Page]''' '''[http://www.adobe.com/shockwave/welcome/ Shockwave Test Page]''' '''[http://helpx.adobe.com/shockwave/kb/troubleshoot-shockwave-player-installation-windows.html Troubleshoot Shockwave Player installation | Windows]''' '''[http://helpx.adobe.com/shockwave/kb/troubleshoot-shockwave-player-installation-mac.html Troubleshoot Shockwave Player installation | Mac OS]''' '''[http://helpx.adobe.com/flash-player/kb/video-playback-issues.html Flash Player Help / Video playback issues]''' --- fixed first download link as it was linking to Shockwave player and not the proper Flash player. If it says shockwave in end of link then that is not Flash but the shockwave for director or rather shockwave player.

由 James 於 修改

有幫助的回覆

Thanks for the reply, but it didn't fix anything unfortunately. Shockwave performs just fine, but not flash. I tried everything in those troubleshooting guides. No dice.

Thanks for the reply, but it didn't fix anything unfortunately. Shockwave performs just fine, but not flash. I tried everything in those troubleshooting guides. No dice.
FredMcD
  • Top 10 Contributor
4274 個解決方法 59942 個答案

For some reason, on Firefox, Flash is listed as Shockwave. Shockwave is listed as Shockwave for Director

For some reason, on Firefox, Flash is listed as Shockwave. Shockwave is listed as Shockwave for Director

提出問題者

I noticed that. It is weird. Here's what I'm looking at: (the burgundy rectangle disappears after a moment too)

I noticed that. It is weird. Here's what I'm looking at: (the burgundy rectangle disappears after a moment too)

由 Donuts 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17591 個解決方法 159130 個答案

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

提出問題者

Of those, I only use adBlock Plus and disabling it didn't help. The only other plugin I use is the 'Classic Theme Restorer'.

Of those, I only use adBlock Plus and disabling it didn't help. The only other plugin I use is the 'Classic Theme Restorer'.
FredMcD
  • Top 10 Contributor
4274 個解決方法 59942 個答案

Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, find and check the plugins, make sure they are set properly.

Go to the web page. Once the page is loading, mouse to the address bar and '''Left''' click the icon. A window for displaying site information should come up. Select '''More Information.''' Now select '''Permissions.''' In the menu, find and check the plugins, make sure they are set properly.
jscher2000
  • Top 10 Contributor
8801 個解決方法 71984 個答案

The burgundy rectangle should be replaced quickly by a bouncing cube design. Does it work if you load it "stand-alone" using this link: http://www.adobe.com/swf/software/flash/about/flash_about_793x170.swf

On the "about" page, after a brief time, the animation is replaced by an ad for another Adobe product. Does that part work for you or is that also not happening?

The burgundy rectangle should be replaced quickly by a bouncing cube design. Does it work if you load it "stand-alone" using this link: http://www.adobe.com/swf/software/flash/about/flash_about_793x170.swf On the "about" page, after a brief time, the animation is replaced by an ad for another Adobe product. Does that part work for you or is that also not happening?

提出問題者

@FredMcD: Just tried it. Flash was on Default. I set it and everything else, for the hell of it, to 'Allow' and still nothing.

@jscher2000: I see the ad no problem if I disable adblock. The standalone link you posted gave me the same result. Just a bigger burgundy rectangle. hah

Thanks for all of your suggestions everyone. I appreciate the help.

@FredMcD: Just tried it. Flash was on Default. I set it and everything else, for the hell of it, to 'Allow' and still nothing. @jscher2000: I see the ad no problem if I disable adblock. The standalone link you posted gave me the same result. Just a bigger burgundy rectangle. hah Thanks for all of your suggestions everyone. I appreciate the help.
FredMcD
  • Top 10 Contributor
4274 個解決方法 59942 個答案

I've called for the big guys. I hope they can help you. Good luck.

I've called for the big guys. I hope they can help you. Good luck.
guigs 1072 個解決方法 11697 個答案

As core mentioned the content may be blocked please d poo np poo st back about if this is the case. Please temporarily disable director and reload the page. Director was releases with flash 11. X and it has its own h.265 endoder. It may be the interaction

As core mentioned the content may be blocked please d poo np poo st back about if this is the case. Please temporarily disable director and reload the page. Director was releases with flash 11. X and it has its own h.265 endoder. It may be the interaction
guigs 1072 個解決方法 11697 個答案

I hate auto correct, that should be please disable it to test.

I hate auto correct, that should be please disable it to test.
FredMcD
  • Top 10 Contributor
4274 個解決方法 59942 個答案

Very interesting auto-correct you have there.  ;-)

Very interesting auto-correct you have there. ;-)

提出問題者

Haha. Where do you find the 'poo' toggle? Unfortunately, disabling shockwave didn't help. Same deal. :(

Since I posted my problem, I've been trying everything. It's frustrating because my laptop at home never had any problems like this with Firefox and the rest of the computers here, at work, all run it fine. Maybe it's universal retribution for browsing reddit all day.

Haha. Where do you find the 'poo' toggle? Unfortunately, disabling shockwave didn't help. Same deal. :( Since I posted my problem, I've been trying everything. It's frustrating because my laptop at home never had any problems like this with Firefox and the rest of the computers here, at work, all run it fine. Maybe it's universal retribution for browsing reddit all day.

由 Donuts 於 修改

FredMcD
  • Top 10 Contributor
4274 個解決方法 59942 個答案

Let's go back to the basics for a moment.

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Let's go back to the basics for a moment. '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

提出問題者

There are no problems, but it doesn't solve anything unfortunately.

There are no problems, but it doesn't solve anything unfortunately.