搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

Shockwave Flash is CONSTANTLY not responding and crashing

  • 56 回覆
  • 646 有這個問題
  • 381974 次檢視
  • 最近回覆由 NoahSUMO

more options

Hello there,

I've had this problem for a long time, and I've done most everything suggested in other forums regarding this matter. I've disabled "disabled protected mode, disabled hardware acceleration, made sure everything is updated, and nothing works. Unfortunately, this makes Firefox so unusable that I've had to switch to another browser for the time being, but it's having it's own issues. Very frustrating! I like Firefox and would like to have it working, but this "shockwave flash plugin" problem has been a persistent problem for the last year.

I've seen many other users who have not been able to fix the problem via the above suggestions, so--what's the verdict? Is there something else I can try?

Cheers

被選擇的解決方法

I fixed it. I found a Flash bypass alternative extension in Firefox Add-ons, called "Video WithOut Flash" https://addons.mozilla.org/en-US/firefox/addon/video-without-flash/ installed it, and disabled Flash. No more problems. I know, sounds to good to be true, but there it is.

Now, if only there was a more solid alternative for Flash, or heaven forbid, Adobe get's there sh*t together.

Cheers--I hope this fix helps a few people!

從原來的回覆中察看解決方案 👍 33

所有回覆 (16)

more options

CKJaguar, Mozilla has no involvement with the separate Flash Player plugin from Adobe.

more options

Why then does it still appear on the Mozilla AddOns list? This thread was first posted four months ago. This addOn should be removed until it works properly. If I or anyone else posts this bug on Adobe's Forum someone, somewhere, might someday, read it. But If Mozilla removes their AddOn citing conflicts, Adobe would fix the bug in minutes.

more options

Hi CKJaguar, the Plugins section of the Add-ons page in Firefox displays the plugins you have installed on your system (that Firefox has found). The Flash player plugin is installed by a program you need to get from Adobe; Mozilla does not redistribute or package it.

The reason that Mozilla does not block the current Flash player from running in Firefox is that many websites are coded to use only Flash to play videos or in some cases to display menus or other content. You may be lucky enough not to use such sites, but unfortunately, many users are not...

more options

Sounds reasonable. But I'm happy without the flash plug in activated. All the promo and ad windows in the browser are effective blocked. That frees resources and saves time. Just sorry I didn't learn about this solution earlier.

more options

the problem with your solution (disabling flash in addons) is that i cant play flash game. After disabling i get a message that i need flash to run. Any idea?

more options

Sorry I have no gaming experience. And now I've found that enabling Flash AddOn again for one site allows the problem to recur. I have found that the Flash AddOn is a problem, but disabling it is not a great solution.

more options

Hi mrOnion, it usually works to set the Shockwave Flash plugin to "Ask to Activate" and then use the icon in the address bar, which looks like a small Lego block, to approve Flash when you actually want it to run. Have you already that method?

Hi CKJaguar, if the normal "Ask to Activate" behavior is allowing too much -- that is, content you want on a page AND content you don't want on a page -- there is an add-on which allows you to be more selective in giving permission. I haven't tried it myself, but you can read about it here: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/

more options

Thanks for finding that. I'll try it. When Approving flash on a page the whole page naturally opens, including all video based ads and "news" flashes. It seems Mozilla puts so much video in a page that Flash can't handle it all. You Tube never exhibits this problem, but You Tube is not Mozilla either. And You Tube generally only plays one video file at a time. Well, I tried it. Only one click and the lock ups have stopped.

由 CKJaguar 於 修改

more options

I was wanted to chime in and say that I'm also having huge problems with flash as of the last update or two.

more options

Hi

it has been like that for at least 3 years. This is simply true. You know why apple is on top of the game? Because you all suck! Adobe and Mozilla cannot build a system that is able to stream youtube everyday without crashing. Why? You do that on purpose!

No I do not calm down, I am about to start....!

You have to fix that problem! I install firefox, I install that adobe shockwave, java, flash....I DO NOT EVEN KNOW THE DIFFERENCE BETWEEN SHOCKWAVE AND FLASH AND I DO NOT FUCKIN CARE BECAUSE I DO NOT HAVE TO CARE.

Install and it has to work, there is no doubt about that...one setup file

firefox+shockwave+java! You need it anyway!

YOU ARE GOING TO LOSE YOUR LAST PIECE OF YOUR MARKET IF YOU CONTINUE LIKE THAT!

These days people do not want to have millions of updates, setups and shit. It simply has to work, like funking apple!

What the fuck is wrong with you? It has never been worse like these days. Install and has to work without antivirus and shitty toolbars!

You really believe people buy apple because you and mozilla are so great?

Microsoft should EVENTUALLY, ULTIMATELY buy firefox and VLC!

I WANT A SIMPLE SYSTEM THAT WORKS!

YOU ALL WANT THAT!

SO SCREAM WITH ME!!!!

more options

I could not agree more.

more options

Hi edigiaro, everyone wants their browser to work smoothly, and I'm sorry to hear your experience is driving you to ranting in this thread. Those who posted here before will receive these posts in their email.

This is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case you aren't done trying to fix it:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here:

"3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

That takes effect the next time you exit and start Firefox up again.

(B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. You can disable it by creating or editing a settings file. The following pages/posts provide different approaches for that:

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

Any improvement?

more options

I finally found the fix for this problem, it's called Google Chrome.

more options

hey bro jscher2000

sorry for ranting but sometimes one has to scream to wake people up. I try your settings, but this problem has a much deeper meaning. This is why I was talking about apple. The reason why people buy apple systems is because they want it to be simple and it HAS TO WORK without much effort and doing settings and stuff. Forget about the design, they are nice, but they dont crash like windows that is the main point. Microsoft is unable to build a system that is balanced in comfort and features to influence the system. And ultimately they gonna lose more of their market because people can buy nice cars with nice engines that work. All PCs from Dell are really ugly compared to apple. All Laptops are really thick and ugly compared to apple or much to expensive. And they work, they dont crash.

btw Other browsers? Have you recently taken a look at opera? They removed their dropdown menu and have some new stuff called "speed dial", it is bookmarks with big buttons. And they think they are cool, they just reinvented bookmarks and removed a comfortable feature of their browser everybody was using. How stupid can one be? I really hate it these day when people reinvent the wheel like that guy who got fired because he removed the start button from windows8. Next year chrysler removes doors at their cars, but you can climb in through windows. Its gonna be cool because these days if something is new, they think people gonna eat all poor marketing attempts.

What is wrong these days ? You think I'm getting old? No I think people go very weird paths.

And by the way, what you told me about the list of the dropdown menu works, but is it possible to have it in an alphabetical order? You know like it was in 2006 for example. It was they quickest way to go on recently visited websites...

THX

more options

Hi edigiaro, I'm a slow adopter of Apple products because I like flexibility, but maybe that's just me.

edigiaro said

And by the way, what you told me about the list of the dropdown menu works, but is it possible to have it in an alphabetical order? You know like it was in 2006 for example. It was they quickest way to go on recently visited websites...

I think you mean in this thread: https://support.mozilla.org/questions/1052287

cor-el is much more knowledgeable about me about how to modify the auto-suggest list, so you might want to follow up on that over there.

more options

Locking thread

This question was asked last year in October and was solved for the poster on 10/23/14. The extra comments are sending many emails to the original poster.

For anyone else who comes across this thread, please post your own question. On the last page of the process, you will see a green "Share Data" button. Please click it. That will help us get extra information about your Firefox setup to give you better answers.

Use this link to ask your question: https://support.mozilla.org/en-US/questions/new

  1. 1
  2. 2
  3. 3