X
點擊此處開啟此網站的行動版。

技術支援討論區

How can I get Firefox to default to Unicode rather that Western ?

已張貼

This is the same question as the unanswered, archived thread https://support.mozilla.org/en-US/questions/989012?fpa=1

Firefox 33.0 displays mojibake+English instead of Japanese+English. It shouldn't matter whether the web page is encoded in ShiftJIS, EUC, raw JIS (though that's rare), or UTF8; all of them should be easy to autodetect.

I can go to the View menu, Character Encoding, and select Japanese, but this should not be necessary. I shouldn't have to teach it to ordinary users.

View - Character Encoding - Auto-detect is off, but even if I set that to Japanese it doesn't help. Hypothetically even if it helped Japanese it wouldn't help Greek.

If I understand correctly there used to be an option View - Character Encoding - Universal, but that option was removed? WTF???????????????????????????????

I've read a few expert opinions that I should change the web server to ... I'm not sure what I should change it to, because looking at the page again it seems that it already says Unicode ... but anyway, I don't think one of Japan's largest transportation companies will let one of their smallest personal individual customers barge in and reprogram their web server.

http://www.sagawa-sgx.com/sgx/trackeng.asp?CAT=AWB&enc=ENG&AWB=25903880-0

This part probably didn't help but shouldn't hurt too much: body{

 background-color:darkblue;
 font-family:Arial;
 font-size:12px;
 background: #ffffff;

}

This part should help, shouldn't it?: <meta http-equiv="Content-Type" content="text/html; charset=unicode">

How can I set auto-detect to use information from the web page, and to turn on auto-detection for web sites that don't say?

This is the same question as the unanswered, archived thread https://support.mozilla.org/en-US/questions/989012?fpa=1 Firefox 33.0 displays mojibake+English instead of Japanese+English. It shouldn't matter whether the web page is encoded in ShiftJIS, EUC, raw JIS (though that's rare), or UTF8; all of them should be easy to autodetect. I can go to the View menu, Character Encoding, and select Japanese, but this should not be necessary. I shouldn't have to teach it to ordinary users. View - Character Encoding - Auto-detect is off, but even if I set that to Japanese it doesn't help. Hypothetically even if it helped Japanese it wouldn't help Greek. If I understand correctly there used to be an option View - Character Encoding - Universal, but that option was removed? WTF??????????????????????????????? I've read a few expert opinions that I should change the web server to ... I'm not sure what I should change it to, because looking at the page again it seems that it already says Unicode ... but anyway, I don't think one of Japan's largest transportation companies will let one of their smallest personal individual customers barge in and reprogram their web server. http://www.sagawa-sgx.com/sgx/trackeng.asp?CAT=AWB&enc=ENG&AWB=25903880-0 This part probably didn't help but shouldn't hurt too much: body{ background-color:darkblue; font-family:Arial; font-size:12px; background: #ffffff; ; } This part should help, shouldn't it?: <meta http-equiv="Content-Type" content="text/html; charset=unicode"> How can I set auto-detect to use information from the web page, and to turn on auto-detection for web sites that don't say?

被選擇的解決方法

charset=unicode is not a valid parameter value. That should be charset=utf-8 to make Firefox use Unicode.

從原來的回覆中察看解決方案 4

額外的系統細節

已安裝的外掛程式

  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.3.153
  • 5.1.30514.0
  • Picasa plugin

應用程式

  • Firefox 33.0
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/33.0/WINNT/en-US/

擴充套件

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • avast! Online Security 9.0.2021.112 (wrc@avast.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA Quadro NVS 120M
  • adapterDescription2:
  • adapterDeviceID: 0x01d8
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum,nvd3dumx nvwgf2um, nvwgf2umx.dll
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'182.65']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 3-6-2009
  • driverDate2:
  • driverVersion: 7.15.11.7967
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'182.65']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'182.65']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 1
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141011015303
  • browser.startup.homepage: about:blank
  • browser.startup.homepage_override.buildID: 20141011015303
  • browser.startup.homepage_override.mstone: 33.0
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 33.0
  • font.language.group: ja
  • media.gmp-gmpopenh264.lastUpdate: 1413360327
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1413585766
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1413621908
  • places.history.expiration.transient_current_max_pages: 53638
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npdeployjava: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1413347488

其他

  • User JS: 否
  • 輔助功能: 否
guigs 1072 個解決方法 11697 個答案

By default he unicode is selected. In View > Character Encoding > Auto detect can be selected to change this.

By default he unicode is selected. In View > Character Encoding > Auto detect can be selected to change this.

提出問題者

"By default he unicode is selected."

It is not. Just now I opened the same page again. The Japanese text is still mojibake. Clicking on the View menu, pointing the mouse cursor at the Character Encoding menu entry, FF 33.0 says that the encoding it's using is Western not Unicode. The meta tag is the same as before: <meta http-equiv="Content-Type" content="text/html; charset=unicode"> but FF doesn't obey it, FF doesn't autodetect, FF displays mojibake.

"In View > Character Encoding > Auto detect can be selected to change this."

The options in Auto detect are (off), Japanese, Russian, and Ukrainian. Wouldn't it be nice to have an (on) option, but other people asked the same question and got no answer. Wouldn't it be nice to have a Universal option, but other people asked the same question, and Universal used to exist but was removed! So if someone's site has a mixture of Greek and Japanese I can't set the default to Universal and FF doesn't autodetect.

View > Character Encoding > Auto detect > Japanese did correct the display of this page, but automatic auto detecting would be better than manual auto detecting. I still doubt whether View > Character Encoding > Auto detect > Japanese would correct the display of a page that is a mix of Japanese and Russian encoded in Unicode with a unicode meta tag.

"By default he unicode is selected." It is not. Just now I opened the same page again. The Japanese text is still mojibake. Clicking on the View menu, pointing the mouse cursor at the Character Encoding menu entry, FF 33.0 says that the encoding it's using is Western not Unicode. The meta tag is the same as before: <meta http-equiv="Content-Type" content="text/html; charset=unicode"> but FF doesn't obey it, FF doesn't autodetect, FF displays mojibake. "In View > Character Encoding > Auto detect can be selected to change this." The options in Auto detect are (off), Japanese, Russian, and Ukrainian. Wouldn't it be nice to have an (on) option, but other people asked the same question and got no answer. Wouldn't it be nice to have a Universal option, but other people asked the same question, and Universal used to exist but was removed! So if someone's site has a mixture of Greek and Japanese I can't set the default to Universal and FF doesn't autodetect. View > Character Encoding > Auto detect > Japanese did correct the display of this page, but automatic auto detecting would be better than manual auto detecting. I still doubt whether View > Character Encoding > Auto detect > Japanese would correct the display of a page that is a mix of Japanese and Russian encoded in Unicode with a unicode meta tag.
cor-el
  • Top 10 Contributor
  • Moderator
17482 個解決方法 158020 個答案

If the page uses Unicode then this should always work. A fallback is only required if an 8-bit encoding is used (Western or Windows or otherwise). There will only be problems if the server sends an encoding that is not correct for that page.

What matters is what encoding the server sends via the HTTP response headers. If the server sends an encoding then Firefox will always switch to that encoding. The default is only used on pages where the server does not send an encoding via the HTTP response header and the page code doesn't specify the encoding via a meta tag or possible byte order mark in case of Unicode.

If the page uses Unicode then this should always work. A fallback is only required if an 8-bit encoding is used (Western or Windows or otherwise). There will only be problems if the server sends an encoding that is not correct for that page. What matters is what encoding the server sends via the HTTP response headers. If the server sends an encoding then Firefox will always switch to that encoding. The default is only used on pages where the server does not send an encoding via the HTTP response header and the page code doesn't specify the encoding via a meta tag or possible byte order mark in case of Unicode.

有幫助的回覆

For the third time: THE PAGE SENDS A META TAG: <meta http-equiv="Content-Type" content="text/html; charset=unicode"> but FF is auto-defaulting to Western and mojibake.

"If the page uses Unicode then this should always work."

What does the word "this" refer to? The fallback (manual auto-detect setting) worked for this page because this page only contains Japanese and English, and Japanese character sets include the Italian characters that are used in writing English. But, for the third time again, shouldn't FF automatically auto-detect it, and even for manual auto-detecting why was the Universal option deleted?

For the third time: THE PAGE SENDS A META TAG: <meta http-equiv="Content-Type" content="text/html; charset=unicode"> but FF is auto-defaulting to Western and mojibake. "If the page uses Unicode then this should always work." What does the word "this" refer to? The fallback (manual auto-detect setting) worked for this page because this page only contains Japanese and English, and Japanese character sets include the Italian characters that are used in writing English. But, for the third time again, shouldn't FF automatically auto-detect it, and even for manual auto-detecting why was the Universal option deleted?
cor-el
  • Top 10 Contributor
  • Moderator
17482 個解決方法 158020 個答案

It will never work automatically in Firefox if the server sends a western encoding via the HTTP response headers and that page is actually UTF-8 and uses characters outside the first 8 bit plane. In such a case you will see the combining Unicode characters. You can see the encoding in Tools > Page Info > General and check the HTTP response headers via the Live Http Headers extension or by using the Web Console (Firefox/Tools > Web Developer).

It will never work automatically in Firefox if the server sends a western encoding via the HTTP response headers and that page is actually UTF-8 and uses characters outside the first 8 bit plane. In such a case you will see the combining Unicode characters. You can see the encoding in Tools > Page Info > General and check the HTTP response headers via the Live Http Headers extension or by using the Web Console (Firefox/Tools > Web Developer). *https://developer.mozilla.org/Tools/Web_Console

提出問題者

Shipment Tracking SGX: Address: http://www.sagawa-sgx.com/sgx/trackeng.asp?CAT=AWB&enc=ENG&AWB=25903880-0 Type: text/html Render Mode: Quirks mode Encoding: windows-1252 Modified: 2014年10月22日 12:27:05 Meta (7 tags) Keywords norobot

Robots noindex,nofollow googlebot noarchive googlebot noindex Robots noarchive description SAGAWA GLOBAL EXPRESS Content-Type text/html; charset=unicode

It looks to me like FF is auto-detecting "Encoding: windows-1252" because the page put "charset=unicode" in a META tag.

Internet Explorer 10 displays the page correctly.

Shipment Tracking SGX: Address: http://www.sagawa-sgx.com/sgx/trackeng.asp?CAT=AWB&enc=ENG&AWB=25903880-0 Type: text/html Render Mode: Quirks mode Encoding: windows-1252 Modified: 2014年10月22日 12:27:05 Meta (7 tags) Keywords norobot Robots noindex,nofollow googlebot noarchive googlebot noindex Robots noarchive description SAGAWA GLOBAL EXPRESS Content-Type text/html; charset=unicode It looks to me like FF is auto-detecting "Encoding: windows-1252" because the page put "charset=unicode" in a META tag. Internet Explorer 10 displays the page correctly.
cor-el
  • Top 10 Contributor
  • Moderator
17482 個解決方法 158020 個答案

選擇的解決方法

charset=unicode is not a valid parameter value. That should be charset=utf-8 to make Firefox use Unicode.

charset=unicode is not a valid parameter value. That should be charset=utf-8 to make Firefox use Unicode.

提出問題者

OK, I advised a company related to that web site that the meta tag should be changed to: <meta http-equiv="Content-Type" content="text/html; charset=utf-8">

OK, I advised a company related to that web site that the meta tag should be changed to: <meta http-equiv="Content-Type" content="text/html; charset=utf-8">