X
點擊此處開啟此網站的行動版。

技術支援討論區

Flash animation doesn't display on firefox

已張貼

I have three flash banners embedded with swfobject in a javascript slider (jquery bxslider plugin). Each banner has three ActionScript ExternalInterfaces:

  • calling restartBanner() from JavaScript restarts the animation so that I can restart it whenever the slide is selected
  • calling stopFlash() stops the animation
  • on the last frame of each banner, bannedEnd() is called so that I know when to proceed to the next banner

Everything seems to be working correctly in Safari and Chrome, but in Firefox the last (third) banner doesn't seem to start playing. The weird thing is that even though you can't see the animation (it simply displays the first frame), at some point bannerEnd() is called, so internally the flash animation is working.

At first I thought it's because the container with the banner is not visible and tried modifying the slide's DOM in hope of triggering a re-render and forcing the browser to start the animation (as seen in onSlideAfter method), but that didn't help. I don't have much experience with flash and couldn't find any relevant solutions or similar problems online, so I don't really know where to look.

It's also not the issue of the one particular banner - if you change the order, the problem persists with the last (third) banner.

I isolated the code from the rest of the page and it can be seen here: https://pang.fraktal.ee/~stepan/flash_banner_issue/

As I said, the issue seems to only be with the Firefox browser, so it seemed appropriate to seek help here.

I have three flash banners embedded with swfobject in a javascript slider (jquery bxslider plugin). Each banner has three ActionScript ExternalInterfaces: * calling restartBanner() from JavaScript restarts the animation so that I can restart it whenever the slide is selected * calling stopFlash() stops the animation * on the last frame of each banner, bannedEnd() is called so that I know when to proceed to the next banner Everything seems to be working correctly in Safari and Chrome, but in Firefox the last (third) banner doesn't seem to start playing. The weird thing is that even though you can't see the animation (it simply displays the first frame), at some point bannerEnd() is called, so internally the flash animation is working. At first I thought it's because the container with the banner is not visible and tried modifying the slide's DOM in hope of triggering a re-render and forcing the browser to start the animation (as seen in onSlideAfter method), but that didn't help. I don't have much experience with flash and couldn't find any relevant solutions or similar problems online, so I don't really know where to look. It's also not the issue of the one particular banner - if you change the order, the problem persists with the last (third) banner. I isolated the code from the rest of the page and it can be seen here: https://pang.fraktal.ee/~stepan/flash_banner_issue/ As I said, the issue seems to only be with the Firefox browser, so it seemed appropriate to seek help here.

額外的系統細節

已安裝的外掛程式

  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Shockwave Flash 15.0 r0
  • Unity Web Player version 4.5.2f1. (c) 2013 Unity Technologies ApS. All rights reserved.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Allows digital signing with Estonian ID cards
  • Picasa plugin.

應用程式

  • Firefox 32.0.3
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/32.0.3/Darwin/en-US/

擴充套件

  • Adblock Plus 2.6.5 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Backbone Eye v0.2.0 (spa_eye@dhruvaray.github.io)
  • Firebug 2.0.4 (firebug@software.joehewitt.com)
  • Firefox OS Simulator 4.0.2 (r2d2b2g@mozilla.org)
  • Greasemonkey 2.2 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • JSONView 0.9 (jsonview@brh.numbera.com)
  • Pocket 3.0.5 (isreaditlater@ideashower.com)
  • Reddit Enhancement Suite 4.5.0.2 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Estonian ID Card PKCS11 module loader 3.7.0.877 ({aa84ce40-4253-a00a-8cd6-0800200f9a66}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x 116
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140923175406
  • browser.startup.homepage_override.buildID: 20140923175406
  • browser.startup.homepage_override.mstone: 32.0.3
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.mozTCPSocket.enabled: True
  • extensions.lastAppVersion: 32.0.3
  • font.internaluseonly.changed: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1413456314
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 3
  • security.disable_button.openCertManager: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1413134778

其他

  • User JS: 否
  • 輔助功能: 否
guigs 1072 個解決方法 11697 個答案

Hi Stalaryn, Thank you for your question, I understand that you have three flash banners on your website.

In your test the title and the span are different, but the active class is working. Its just that last div that is not loading. As well as the data target in the last tile is not as specific as the others, is it the url of the swf file? I can understand the frustration here.

Can you please file a bug in bugzilla.mozilla.org under web compatibility with reference to your silder?

Hi Stalaryn, Thank you for your question, I understand that you have three flash banners on your website. In your test the title and the span are different, but the active class is working. Its just that last div that is not loading. As well as the data target in the last tile is not as specific as the others, is it the url of the swf file? I can understand the frustration here. Can you please file a bug in bugzilla.mozilla.org under web compatibility with reference to your silder?