搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Addons Manager is blank Get Addons never loads

  • 4 回覆
  • 1 有這個問題
  • 8 次檢視
  • 最近回覆由 FredMcD

more options

I am using FF 32.0.3. My problem started when I selected a link to a music file from Google search, and my FF screen went black for a few seconds, and then came back, but a number of toolbar buttons were gone, i.e. the previous page button changed from the left arrow in a circle, to a blank circle. I ran malwarebytes, and found 23 potentially unwanted programs. They were removed successfully. Now when I open Firefox, my Home page is a blank new tab, even though I have a web page defined. When I click on the Home button, my web page opens up. When I go into Tools->Addons, Get Addons never loads anything, Extensions and Plugins are completely blank. I read in Support, that removing the contents of the User.js file, might fix the problem. The only entry in that file was:

user_pref("extensions.autoDisableScopes",14);user_pref("browser.sessionstore.resume_session_once", true);

Removing it, and restarting FF, did not clear the problem. I am ready to re-install FF, but I wanted to know if this type of problem has already been fixed. Any help will be greatly appreciated.

I am using FF 32.0.3. My problem started when I selected a link to a music file from Google search, and my FF screen went black for a few seconds, and then came back, but a number of toolbar buttons were gone, i.e. the previous page button changed from the left arrow in a circle, to a blank circle. I ran malwarebytes, and found 23 potentially unwanted programs. They were removed successfully. Now when I open Firefox, my Home page is a blank new tab, even though I have a web page defined. When I click on the Home button, my web page opens up. When I go into Tools->Addons, Get Addons never loads anything, Extensions and Plugins are completely blank. I read in Support, that removing the contents of the User.js file, might fix the problem. The only entry in that file was: user_pref("extensions.autoDisableScopes",14);user_pref("browser.sessionstore.resume_session_once", true); Removing it, and restarting FF, did not clear the problem. I am ready to re-install FF, but I wanted to know if this type of problem has already been fixed. Any help will be greatly appreciated.

被選擇的解決方法

Hello,

Are you able to run in Safe Mode? Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause. If you are unable to remove your add-ons, then see below.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


Alternatively, you can try Resetting Firefox which will restore it to the default factory state. Further information can be found in the Refresh Firefox - reset add-ons and settings article. The "Reset Firefox" button can be found in:

  • Click the menu button New Fx Menu, click Help Help-29 and select Troubleshooting Information.

If you figure out what's causing your issues, please let us know. It might help others with the same problem.

從原來的回覆中察看解決方案 👍 0

所有回覆 (4)

more options

選擇的解決方法

Hello,

Are you able to run in Safe Mode? Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause. If you are unable to remove your add-ons, then see below.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


Alternatively, you can try Resetting Firefox which will restore it to the default factory state. Further information can be found in the Refresh Firefox - reset add-ons and settings article. The "Reset Firefox" button can be found in:

  • Click the menu button New Fx Menu, click Help Help-29 and select Troubleshooting Information.

If you figure out what's causing your issues, please let us know. It might help others with the same problem.

由 CoryMH 於 修改

more options

Did you delete the user.js file?

It shouldn't be there and the presence of the browser.sessionstore.resume_session_once wil cause the previous session to get restored automatically.

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

more options

Thank you CoreyMH, I followed your steps to open FF in safe mode. It came up, in my home page, and all my Add-ons were listed. Then I restarted FF in normal mode, and every thing was fixed. I appreciate your assistance.

more options

Separate Issue; Your System Details shows;

Installed Plug-ins

Shockwave Flash 15.0 r0 Shockwave Flash 11.9 r900

Having more than one version of a program may cause issues.

Flash is notorious for not cleaning out the older version as part of an update. Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac Then reinstall the latest version.

Shockwave Flash v15.0.0.152 http://get.adobe.com/shockwave/