X
點擊此處開啟此網站的行動版。

技術支援討論區

firefox experiences random crashes which persist even in safe mode (linux + gnome)

已張貼

Since maybe version 29, my Firefox has become less stable than before and started to crash for seemingly no reason; sometimes it crashed shortly after started with few tabs on, and sometimes it crashed when many tabs were open or (not constantly) with music playing. In short I cannot find an exact pattern by which crashes are triggered. Only one thing is certain, once it broke down, it kept crashing on every restart (even in safe mode or with the user preference directory reset by a complete removal), until a reboot.

I checked some threads, where people suggest that such random crashes may be caused by a flawed RAM, but I feel it unlikely because in this same system no other software (including Chromium) have shown similar problem, and on Windows the same computer Firefox (v31) has been rather stable.

Although it didn't happen frequently, the need to reboot the computer before Firefox gets usable again is really annoying. I appreciate a lot if anyone could give some hints, thanks.

The environment: base system: openSUSE 13.1 (Bottle) (i586) 32-bit desktop: Gnome 3.10.2 cpu: AMD C-60 APU with Radeon(tm) HD Graphics × 2 RAM: 4G

==============UPDATE=================

Sorry I forgot the crash reports, here they are: bp-53142ca2-076d-4413-9d1a-2d2c72140928 bp-ec9c9990-0cde-48e5-a792-27bd22140928 bp-425bcbf0-5c79-4050-999f-ebc692140928 bp-30bc9187-5a52-47ba-a193-9c6b82140928 bp-d39f099c-758a-405d-a566-d3bd72140928 bp-7aff96dc-bbc2-4e41-9888-af5d62140928 bp-fef7b101-e586-4a8c-94a7-6dc842140928 bp-c8785c65-4c72-4f9b-b0fb-439ac2140928 bp-47244ab2-dfa5-49a9-9345-500342140928 bp-cc104c04-516f-4f48-a2cf-ff4fa2140926 bp-f38876f1-48c2-4788-b5aa-54cce2140926 bp-3057d6a8-59d8-4cfe-8720-338072140926 bp-c17b4506-fde9-4389-8b2d-ac6a72140923 bp-a3d651aa-613b-457f-9cc9-44e812140922 bp-af7593e9-b7d1-44f6-aebc-bd0d72140920 bp-7055424f-8212-4c54-9fcc-39bb32140917 bp-026ab307-ace0-4ef5-a286-7d70a2140917 bp-ab4e4111-33f1-4d0c-820d-3b8332140917 bp-be24878b-eda9-4afd-a942-204502140917

Since maybe version 29, my Firefox has become less stable than before and started to crash for seemingly no reason; sometimes it crashed shortly after started with few tabs on, and sometimes it crashed when many tabs were open or (not constantly) with music playing. In short I cannot find an exact pattern by which crashes are triggered. Only one thing is certain, once it broke down, it kept crashing on every restart (even in safe mode or with the user preference directory reset by a complete removal), until a reboot. I checked some threads, where people suggest that such random crashes may be caused by a flawed RAM, but I feel it unlikely because in this same system no other software (including Chromium) have shown similar problem, and on Windows the same computer Firefox (v31) has been rather stable. Although it didn't happen frequently, the need to reboot the computer before Firefox gets usable again is really annoying. I appreciate a lot if anyone could give some hints, thanks. The environment: base system: openSUSE 13.1 (Bottle) (i586) 32-bit desktop: Gnome 3.10.2 cpu: AMD C-60 APU with Radeon(tm) HD Graphics × 2 RAM: 4G ====================UPDATE======================= Sorry I forgot the crash reports, here they are: bp-53142ca2-076d-4413-9d1a-2d2c72140928 bp-ec9c9990-0cde-48e5-a792-27bd22140928 bp-425bcbf0-5c79-4050-999f-ebc692140928 bp-30bc9187-5a52-47ba-a193-9c6b82140928 bp-d39f099c-758a-405d-a566-d3bd72140928 bp-7aff96dc-bbc2-4e41-9888-af5d62140928 bp-fef7b101-e586-4a8c-94a7-6dc842140928 bp-c8785c65-4c72-4f9b-b0fb-439ac2140928 bp-47244ab2-dfa5-49a9-9345-500342140928 bp-cc104c04-516f-4f48-a2cf-ff4fa2140926 bp-f38876f1-48c2-4788-b5aa-54cce2140926 bp-3057d6a8-59d8-4cfe-8720-338072140926 bp-c17b4506-fde9-4389-8b2d-ac6a72140923 bp-a3d651aa-613b-457f-9cc9-44e812140922 bp-af7593e9-b7d1-44f6-aebc-bd0d72140920 bp-7055424f-8212-4c54-9fcc-39bb32140917 bp-026ab307-ace0-4ef5-a286-7d70a2140917 bp-ab4e4111-33f1-4d0c-820d-3b8332140917 bp-be24878b-eda9-4afd-a942-204502140917

由 foehn 於 修改

額外的系統細節

已安裝的外掛程式

  • Aliedit (www.alipay.com security control)
  • Shockwave Flash 11.2 r202
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • The IcedTea-Web Plugin executes Java applets.
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The Videos 3.10.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • Plugin for Installing Applications (new)

應用程式

  • Firefox 31.1.0
  • 使用者代理:Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/31.1.0/Linux/en-US/

擴充套件

  • FoxyProxy Standard 4.4.1 (foxyproxy@eric.h.jung)
  • Greasemonkey 2.2 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Hide Caption Titlebar Plus 2.8.6 (hidecaptionplus-dp@dummy.addons.mozilla.org)
  • openSUSE Firefox Extensions 1.0.2 (susefox@opensuse.org)
  • Pocket 3.0.5 (isreaditlater@ideashower.com)
  • Print pages to PDF 0.1.9.3 (printPages2Pdf@reinhold.ripper)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Xmarks 4.3.5 (foxmarks@kei.com)
  • Zotero 4.0.22 (zotero@chnm.gmu.edu)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: X.Org -- Gallium 0.4 on AMD PALM
  • adapterDeviceID: Gallium 0.4 on AMD PALM
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • driverDate:
  • driverVersion: 3.0 Mesa 9.2.3
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • webglRenderer: X.Org -- Gallium 0.4 on AMD PALM
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 512000
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 1
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 2014082900
  • browser.startup.homepage: https://www.google.com/ncr
  • browser.startup.homepage_override.buildID: 2014082900
  • browser.startup.homepage_override.mstone: 31.1.0
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.1.0
  • network.cookie.prefsMigrated: True
  • network.dns.disablePrefetch: True
  • places.database.lastMaintenance: 1411942274
  • places.history.expiration.transient_current_max_pages: 98591
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.cache: False
  • privacy.cpd.cookies: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1410300991

其他

  • User JS: 否
  • 輔助功能: 否
FredMcD
  • Top 10 Contributor
4230 個解決方法 59027 個答案

All of your crash reports say;

Signature: libxul.so@0x3868df | libxul.so@0x38691f | libxul.so@0x10ee1b0 | firefox@0x12f15

Crash Reason SIGSEGV

Someone else will have to talk to you about it.

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences<Enter> in the address bar

Select Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

All of your crash reports say; Signature: libxul.so@0x3868df | libxul.so@0x38691f | libxul.so@0x10ee1b0 | firefox@0x12f15 Crash Reason SIGSEGV Someone else will have to talk to you about it. '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences'''<Enter> in the address bar Select '''Advanced > General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

提出問題者

@FredMcD, hardware acceleration is off, and till now no crash has happened. Wait for longer observation, but thank you first. BTW, is there any side effect of turning off hardware acceleration, say, on the performance?

@FredMcD, hardware acceleration is off, and till now no crash has happened. Wait for longer observation, but thank you first. BTW, is there any side effect of turning off hardware acceleration, say, on the performance?
FredMcD
  • Top 10 Contributor
4230 個解決方法 59027 個答案

I'm not really sure what it does but many users with problems find the problems gone after turning it off.

I'm not really sure what it does but many users with problems find the problems gone after turning it off.