搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

My firefox doesn't show icon fonts!

  • 13 回覆
  • 11 有這個問題
  • 13336 次檢視
  • 最近回覆由 milad

more options

I use fontello.com for my web designing project. but recently it doesn't show the icon.

and the weird thing is that, its OK on my friends Firefox and just my PC has the problem.

for example this page shows icon on my friends firefox but i cant see the icons https://dl.dropboxusercontent.com/u/28793409/fontello-d3b0f38a/demo.html

this is what i see https://dl.dropboxusercontent.com/u/28793409/shot.jpg

由 milad 於 修改

被選擇的解決方法

If Safe Mode is good, the most likely culprits are one of your extensions or graphics driver incompatibility. To work around the second issue, you can disable Firefox's use of hardware acceleration to see whether that helps.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit and start Firefox up again.

從原來的回覆中察看解決方案 👍 1

所有回覆 (13)

more options

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

more options

This may not be an issue with Firefox. There are a number of reasons that this could be happening. Here are a few ideas to get you started:

  1. Where is this webpage hosted? Is this on a server somewhere? Or is this a local page?
  2. If on a server, are all of the paths correct in the code? (CSS and links to font files?
  3. If hosted locally, do you have ALL of the needed files on your computer? (CSS, Fonts, etc.) And are the paths correct?

Outside of those issues, I can't think of anything else that would be causing this without looking through some HTML/CSS.

more options

@cor-el : I done all that but still have the problem, i also reset Firefox but still have the problem

more options

@seancannon i test it local and online its OK on my friends Firefox and it just my problem.

its a test page for example that i have the problem with https://dl.dropboxusercontent.com/u/28793409/fontello-d3b0f38a/demo.html

i cant see icons , and i also put a screenshot it the question if you take a look

由 milad 於 修改

more options

What does the inspector show if you check those elements with class "icon-" in the Inspector?

You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector or click show all fonts to see if Firefox is using the rooeen font.

You can also check the Web Console (Firefox/Tools > Web Developer) for error messages about downloading fonts.

more options

I done it, it seems that font is not rendering. please look at screenshots.

more options

Did you check the Fonts tab in the right pane?

You can also check the Web Console for error messages about downloading the font file(s) like I posted above if you haven't done this yet.

more options

i done that console is empty with no errors.

由 milad 於 修改

more options

i have no problem in firefox safe mode ! please help to fix this problem :(

more options

選擇的解決方法

If Safe Mode is good, the most likely culprits are one of your extensions or graphics driver incompatibility. To work around the second issue, you can disable Firefox's use of hardware acceleration to see whether that helps.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit and start Firefox up again.

more options

Firefox's Safe Mode also disables style rules you might have created in a userContent.css file, if applicable.

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

thank you jscher2000 it solved my problem. you made my day :D