X
點擊此處開啟此網站的行動版。

技術支援討論區

A dialog box "Please enter the master password for the FIPS 140 Cryptographic, Key and" will not go away.

已張貼

I do not have a Master Password that I am aware of.

i got an email from Google that someone had tried to hack into my account and to change my password immediately.

When I tried to follow their instructions on how to change a Password this dialog box came up and I cant cancel it.

Any help greatly appreciated

I do not have a Master Password that I am aware of. i got an email from Google that someone had tried to hack into my account and to change my password immediately. When I tried to follow their instructions on how to change a Password this dialog box came up and I cant cancel it. Any help greatly appreciated

被選擇的解決方法

I think that the FIPS state is stored in the key3.db file or the secmode.db file and such files can hardly be modified by accident. You can usually only do this via the button in the "Options/Preferences > Advanced : Encryption: Security Devices" window.

從原來的回覆中察看解決方案 1

額外的系統細節

應用程式

  • User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB7.5; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.4506.2152; yie8)

更多資訊

jscher2000
  • Top 10 Contributor
8775 個解決方法 71729 個答案

有幫助的回覆

Hmm, first, never trust email links urging you to reveal your password (in the process of changing it). Always go to the site through your usual means when you need to access your account. Please do that now and make sure you can update it as you usually would.

Hmm, first, never trust email links urging you to reveal your password (in the process of changing it). Always go to the site through your usual means when you need to access your account. Please do that now and make sure you can update it as you usually would.
jscher2000
  • Top 10 Contributor
8775 個解決方法 71729 個答案

Do you recall what the email steps were? Did you install any new software or add-ons? Did you change any settings in Firefox?

Do you recall what the email steps were? Did you install any new software or add-ons? Did you change any settings in Firefox?

提出問題者

Thanks for replies. I did go through the usual means to access my account. I also got the message on my back up email address . Addressed to me personally. So it appears to be genuine. My problem now is that I can not use Firefox with this dialog box up. How can I get rid of it. Should I just uninstall and download a new Firefox browser ? I am using the hated Internet Explorer until this gets fixed.

Thanks for replies. I did go through the usual means to access my account. I also got the message on my back up email address . Addressed to me personally. So it appears to be genuine. My problem now is that I can not use Firefox with this dialog box up. How can I get rid of it. Should I just uninstall and download a new Firefox browser ? I am using the hated Internet Explorer until this gets fixed.
jscher2000
  • Top 10 Contributor
8775 個解決方法 71729 個答案

Uninstalling and reinstalling Firefox usually doesn't wipe out problems, unless the problem is that Firefox itself is corrupted. I don't think that is the issue here.

If you can't cancel the dialog, you may need to "kill" Firefox using the Windows task manager. You can pop that up using Ctrl+Esc. Then click the Applications tab and try to End Task on the Firefox window(s).

This thread has next steps: getting rid of enter master password FIPS140 Cryptographic,Key and. Two notes:

Uninstalling and reinstalling Firefox usually doesn't wipe out problems, unless the problem is that Firefox itself is corrupted. I don't think that is the issue here. If you can't cancel the dialog, you may need to "kill" Firefox using the Windows task manager. You can pop that up using Ctrl+Esc. Then click the Applications tab and try to End Task on the Firefox window(s). This thread has next steps: [https://support.mozilla.org/questions/944552 getting rid of enter master password FIPS140 Cryptographic,Key and]. Two notes: * If you are not displaying the classic menu bar, you can display it temporarily by tapping the Alt key. * To find your currently active Firefox profile folder (if needed to remove the old saved passwords file) , please see this article: [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]].

提出問題者

When I "kill" Firefox the dialog box returns as soon as I open up the browser again and thus locking me out of performing any other tasks on Firefox. If I click on "cancel" rapidly about ten times the dialog box will disappear allowing me to open up another tab etc, but as soon as I try to make a search on Google, it reappears. Which virtually shuts me out of Google - including my email! I guess I'll just have to go back to IE or Chrome which I really didnt want to do. Can't believe there's no way to cancel this crap. Considering I didn't even have a "master password" in the first place.

When I "kill" Firefox the dialog box returns as soon as I open up the browser again and thus locking me out of performing any other tasks on Firefox. If I click on "cancel" rapidly about ten times the dialog box will disappear allowing me to open up another tab etc, but as soon as I try to make a search on Google, it reappears. Which virtually shuts me out of Google - including my email! I guess I'll just have to go back to IE or Chrome which I really didnt want to do. Can't believe there's no way to cancel this crap. Considering I didn't even have a "master password" in the first place.

提出問題者

Ok! For some reason FIPS was enabled in tools> options>advanced>Security devices> security modules and devices. When I click on "disable" the dialog box disappears. Thank you for your help but it should not be this difficult to get to the bottom of such an obvious answer. Firefox should be on top of this and make it easier for their customers to fix problems. Now I still have the problem of changing my ""master password". Any ideas?

Ok! For some reason FIPS was enabled in tools> options>advanced>Security devices> security modules and devices. When I click on "disable" the dialog box disappears. Thank you for your help but it should not be this difficult to get to the bottom of such an obvious answer. Firefox should be on top of this and make it easier for their customers to fix problems. Now I still have the problem of changing my ""master password". Any ideas?
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

有幫助的回覆

You probably will have to delete the two files signons.sqlite and key3.db to recover from this.

Rename the key3.db and signons.sqlite files in the Firefox profile folder. You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost. If that has worked then you can remove the renamed files that are no longer needed.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

See also:

You probably will have to delete the two files signons.sqlite and key3.db to recover from this. Rename the key3.db and signons.sqlite files in the Firefox profile folder. You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost. If that has worked then you can remove the renamed files that are no longer needed. You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) See also: * "Troubleshooting" in http://kb.mozillazine.org/Password_Manager

提出問題者

Ok I cold rebooted again after disabling the FIPS and magically I can now change my Google password without having to change any files! Thanks everyone for your help! I appreciate my iPad even more now.

Ok I cold rebooted again after disabling the FIPS and magically I can now change my Google password without having to change any files! Thanks everyone for your help! I appreciate my iPad even more now.
jscher2000
  • Top 10 Contributor
8775 個解決方法 71729 個答案

Hi cornawilla, unfortunately add-ons and external software can update Firefox's main settings file on disk (and create other overriding files) to force FIPS or other settings. Perhaps that's how it got set in the first place?

Mozilla doesn't supply an external editor to view and repair those settings files. It might be a useful tool for someone to put together.

Hi cornawilla, unfortunately add-ons and external software can update Firefox's main settings file on disk (and create other overriding files) to force FIPS or other settings. Perhaps that's how it got set in the first place? Mozilla doesn't supply an external editor to view and repair those settings files. It might be a useful tool for someone to put together.
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

選擇的解決方法

I think that the FIPS state is stored in the key3.db file or the secmode.db file and such files can hardly be modified by accident. You can usually only do this via the button in the "Options/Preferences > Advanced : Encryption: Security Devices" window.

I think that the FIPS state is stored in the key3.db file or the secmode.db file and such files can hardly be modified by accident. You can usually only do this via the button in the "Options/Preferences > Advanced : Encryption: Security Devices" window.
dhilberg 0 個解決方法 2 個答案

There seems to be a relation to RoboForm. When I attempt to load Firefox I not only get the dialogue box, I am also taken to the page/site "start.roboform.com" Can't do anything there either.

I'm not even sure if I have Firefox installed.

There seems to be a relation to RoboForm. When I attempt to load Firefox I not only get the dialogue box, I am also taken to the page/site "start.roboform.com" Can't do anything there either. I'm not even sure if I have Firefox installed.
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

Hi dhilberg

Could you please start a new thread for your question?

Then you can provide more information like your operating system and installed extensions and installed plugins.

Hi dhilberg Could you please start a new thread for your question? Then you can provide more information like your operating system and installed extensions and installed plugins. *[[/questions/new start a new thread]] *[[/kb/Using+the+Troubleshooting+Information+page]]
dhilberg 0 個解決方法 2 個答案

Most of the potential solutions given here seem to involve being able to utilize functions of firefox, Thanks very much for your ideas. The problem is that the "FIPS 140..." message does not allow any access to the firefox program.

Most of the potential solutions given here seem to involve being able to utilize functions of firefox, Thanks very much for your ideas. The problem is that the "FIPS 140..." message does not allow ''any'' access to the firefox program.
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

The only way to get rid of (disable) FIPS 140 once enabled is to delete the logins.json and key3.db files and start with a fresh password list because doing this will remove all stored passwords.

The only way to get rid of (disable) FIPS 140 once enabled is to delete the logins.json and key3.db files and start with a fresh password list because doing this will remove all stored passwords.