X
點擊此處開啟此網站的行動版。

技術支援討論區

All of my pdf docs have been changed to Firefox HTML docs and I can not change them back.

已張貼

All of my pdf docs have been changed to Firefox HTML docs and I can not change them back.

Only the icon is changed, not the .PDF extension.
All of my pdf docs have been changed to Firefox HTML docs and I can not change them back. Only the icon is changed, not the .PDF extension.

額外的系統細節

已安裝的外掛程式

  • VLC media player Web Plugin 2.1.3
  • Shockwave Flash 14.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.2.152
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Adobe Acrobat Plug-In Version 6.00 for Netscape

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0

更多資訊

FredMcD
  • Top 10 Contributor
4306 個解決方法 60455 個答案

Using your file browser, right click one of the files and select Properties. Now select Opens With.

Using your file browser, right click one of the files and select '''Properties.''' Now select '''Opens With.'''
cor-el
  • Top 10 Contributor
  • Moderator
17679 個解決方法 159906 個答案

If there is currently no file handler application that handles PDF files then the Firefox updater/installer registers Firefox as the default application to handle PDF files and thus they get a Firefox icon (Bug 452254). You can right-click a PDF file in Windows Explorer and use the open with dialog to change the default application to the Adobe Reader or your preferred application to handle PDF file. You may have to change the icon on the desktop via other means to the icon of that application like via the Windows Control Panel in Windows XP.

  • Control Panel > Folder Options > File Types: .pdf
If there is currently no file handler application that handles PDF files then the Firefox updater/installer registers Firefox as the default application to handle PDF files and thus they get a Firefox icon (Bug 452254). You can right-click a PDF file in Windows Explorer and use the open with dialog to change the default application to the Adobe Reader or your preferred application to handle PDF file. You may have to change the icon on the desktop via other means to the icon of that application like via the Windows Control Panel in Windows XP. *Control Panel > Folder Options > File Types: .pdf
philipp
  • Top 25 Contributor
  • Moderator
5330 個解決方法 23534 個答案

hello ahumayoun, does it work when you go into the acrobat reader > edit > preferences > general & click on the default application option at the bottom? in there reselect adobe's application and confirm this selection...

hello ahumayoun, does it work when you go into the ''acrobat reader > edit > preferences > general ''& click on the default application option at the bottom? in there reselect adobe's application and confirm this selection...

有幫助的回覆

Dear Philp, Thanks for your reply I am using Adobe Acrobat 6.0 Professional & There is no option in it like that.

Dear Philp, Thanks for your reply I am using Adobe Acrobat 6.0 Professional & There is no option in it like that.
philipp
  • Top 25 Contributor
  • Moderator
5330 個解決方法 23534 個答案

you could try to run a repair-installation of acrobat 6 pro...

you could try to run a repair-installation of acrobat 6 pro...

有幫助的回覆

I have already done repair installation and a refresh installation of both Firefox and adobe.

I have already done repair installation and a refresh installation of both Firefox and adobe.
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

Is this the current status:

  • Windows correctly associates (opens) PDFs with Adobe Acrobat 6
  • Windows incorrectly describes .pdf files as Firefox HTML files

That's where a lot of users are ending up.

You can install Adobe Reader XI alongside Adobe Acrobat 6 to use the workaround a user posted in a different thread (post), but I'm not sure it makes sense to make Reader your default application for PDFs if you prefer Acrobat by default. Hmm...

Is this the current status: * Windows correctly associates (opens) PDFs with Adobe Acrobat 6 * Windows incorrectly describes .pdf files as Firefox HTML files That's where a lot of users are ending up. You can install Adobe Reader XI alongside Adobe Acrobat 6 to use the workaround a user posted in a different thread ([https://support.mozilla.org/questions/1014919#answer-618531 post]), but I'm not sure it makes sense to make Reader your default application for PDFs if you prefer Acrobat by default. Hmm...

提出問題者

Windows correctly associates (opens) PDFs with Adobe Acrobat 6

I do not want to use XL as it makes my system heavy and no body in my home like it ,moreover i also need a professional to make pdf . Every thing was good before coming this new version of Mozilla . Mozilla must take an urgent action and must remove this irritating updates.

Windows correctly associates (opens) PDFs with Adobe Acrobat 6 I do not want to use XL as it makes my system heavy and no body in my home like it ,moreover i also need a professional to make pdf . Every thing was good before coming this new version of Mozilla . Mozilla must take an urgent action and must remove this irritating updates.

提出問題者

I have already done this please read above reply.

I have already done this please read above reply.
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

I think the problem is the file type description in the registry. Other users have reported that making IE their default browser switches the description back to Adobe Acrobat document. Hopefully this won't be necessary in the future, but if you find the incorrect description intolerable, you could try that.

I think the problem is the file type ''description'' in the registry. Other users have reported that making IE their default browser switches the description back to Adobe Acrobat document. Hopefully this won't be necessary in the future, but if you find the incorrect description intolerable, you could try that.
trevor34smith 0 個解決方法 8 個答案

Can you please elaborate on your instruction regarding changing the association (is that the right term??) via Control Panel.

I want to change it for all the documents that now seem to be Firefox HTML rather than pdf, and if I understood your instruction better I think this would enable me to do it.

Can you please elaborate on your instruction regarding changing the association (is that the right term??) via Control Panel. I want to change it for all the documents that now seem to be Firefox HTML rather than pdf, and if I understood your instruction better I think this would enable me to do it.
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

Hi trevor34smith, the following steps shared by another user may work better than making a manual change:

  1. Open Adobe Reader / Acrobat
  2. Edit->Preferences
  3. In the Categories column click 'General'
  4. Near the bottom of the page click the button marked 'Select Default PDF Handler'
  5. In the dialog, select 'Adobe Reader XI' (or Adobe Acrobat, as the case may be) and click 'Apply'
  6. A Windows Configuration screen will appear. Allow it to do its stuff (takes a few minutes), then restart your computer when prompted.
Hi trevor34smith, the following steps shared by another user may work better than making a manual change: # Open Adobe Reader / Acrobat # Edit->Preferences # In the Categories column click 'General' # Near the bottom of the page click the button marked 'Select Default PDF Handler' # In the dialog, select 'Adobe Reader XI' (or Adobe Acrobat, as the case may be) and click 'Apply' # A Windows Configuration screen will appear. Allow it to do its stuff (takes a few minutes), then restart your computer when prompted.

提出問題者

The association of all pdf documents are correct all pdf opens through Adobe Acrobat 6.0 Professional but the i con are totally change from pdf to fire fox which create a lot of confusing in documents search and also cause a wastage of time.

The association of all pdf documents are correct all pdf opens through Adobe Acrobat 6.0 Professional but the i con are totally change from pdf to fire fox which create a lot of confusing in documents search and also cause a wastage of time.

提出問題者

Windows correctly associates (opens) PDFs with Adobe Acrobat 6

I do not want to use XL as it makes my system heavy and no body in my home like it ,moreover i also need a professional to make pdf . Every thing was good before coming this new version of Mozilla . Mozilla must take an urgent action and must remove this irritating updates

Windows correctly associates (opens) PDFs with Adobe Acrobat 6 I do not want to use XL as it makes my system heavy and no body in my home like it ,moreover i also need a professional to make pdf . Every thing was good before coming this new version of Mozilla . Mozilla must take an urgent action and must remove this irritating updates
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

Hi ahumayoun, I'm sorry for the confusion but correcting this seems to require some registry changes and I have not seen a thread where they are clearly documented yet.

Would you consider installing Adobe Reader XI to make the settings change, and then switching your preference back to Adobe Acrobat 6? I believe Adobe supports side-by-side coexistence of different versions of Reader and Acrobat.

Hi ahumayoun, I'm sorry for the confusion but correcting this seems to require some registry changes and I have not seen a thread where they are clearly documented yet. Would you consider installing Adobe Reader XI to make the settings change, and then switching your preference back to Adobe Acrobat 6? I believe Adobe supports side-by-side coexistence of different versions of Reader and Acrobat.

提出問題者

I do not want to use XL as it makes my system heavy and no body in my home like it ,moreover i also need a professional to make pdf . Every thing was good before coming this new version of Mozilla . Mozilla must take an urgent action and must remove this irritating updates

I do not want to use XL as it makes my system heavy and no body in my home like it ,moreover i also need a professional to make pdf . Every thing was good before coming this new version of Mozilla . Mozilla must take an urgent action and must remove this irritating updates
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

Hi ahumayoun, I don't understand your reference to "XL". What is "XL"? I was referring to Adobe Reader 11 and suggesting a temporary one-time use.

Nothing is going to happen in this thread to modify Firefox itself. What we do here in support is try to get your system into a state where it works for you. If you do not want the support we can provide, I can stop replying.

Hi ahumayoun, I don't understand your reference to "XL". What is "XL"? I was referring to Adobe Reader 11 and suggesting a temporary one-time use. Nothing is going to happen in this thread to modify Firefox itself. What we do here in support is try to get your system into a state where it works for you. If you do not want the support we can provide, I can stop replying.

提出問題者

The complete name of Adobe Reader 11 is XL see your above earlier statement you also mention it.I have already install this and this solve the problem temporary but as I already told you that according to my need I require professional version moreover no other member in my home ,like the adobe 11 XL as it make the computer heavey.So as soon as I un install it the situation is the same as it was before. If you do not mind can you please tell me that are u helping me on Mozila behalf or voluntary. Thanks

The complete name of Adobe Reader 11 is XL see your above earlier statement you also mention it.I have already install this and this solve the problem temporary but as I already told you that according to my need I require professional version moreover no other member in my home ,like the adobe 11 XL as it make the computer heavey.So as soon as I un install it the situation is the same as it was before. If you do not mind can you please tell me that are u helping me on Mozila behalf or voluntary. Thanks
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

I see, I meant the Roman numeral 11 (capital x capital i).

I am a volunteer, as are most of the contributors on this forum.

I see, I meant the Roman numeral 11 (capital x capital i). I am a volunteer, as are most of the contributors on this forum.