搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

my pdf file icons are now firefox html icons

more options

Issue: PC thinks PDF's are HTML documents eventhough I can get them to open in Adobe. I followed instructions in several of the posts, except for deleting profiles, however nothing has changed. I still have XP, if I follow the path, control panel, folder options, and go to Tab that says File Types, and scroll to PDF, it says, you have customized files with extension PDF, to restore these files to their default type(Firefox HTML Document) click Restore. So currently they are opening in Adobe, however all icons are firefox. Every single PDF, not just ones that were downloaded from net, as I've created some of these myself with PDF995. I don't want to mess anything up, I've changed the way Mozilla handles PDF from Tools, options, under application. I think this is a mozilla issue because under the Mozilla options, the icon for their PDF is the mozilla icon.

被選擇的解決方法

hello Orleanslady, does it work when you go into the acrobat reader > edit > preferences > general & click on the default application option at the bottom? in there reselect adobe's application and confirm this selection...

從原來的回覆中察看解決方案 👍 7

所有回覆 (13)

more options

Hi Orleanslady, In Windows, do you have a default program selected for pdf files, and is it Firefox? You can change it back with these steps: http://www.ehow.com/how_5959350_do-default-pdf-viewer-xp...

more options

No changes have been made after trying that, After I select Adobe and select always use this program to open this type of file, the icon remains a Mozilla icon, and I go in to repeat process and the check mark to always open this type of file with that program is mysteriously cleared

more options

You can try to make the change for .PDF files in "Control Panel > Folder Options > File Types"

more options

Hi Corel, I've tried that as well, please look at my original post where it says in viewing the file types under control panel all PDF are are listed as Firefox HTML documents. Once Firefox is uninstalled all docs return their original correct state.

more options

Go into Control Panel->Programs under Default Programs go into Make a file type always open in a specific program find the file extension .pdf then click on the button change program Then select the program you would like it to open with. If the program you would like to use is not in there, you can browse for your program.

more options

You need to change the icon as well if that wasn't done automatically.

more options

In Windows XP, changing file type associations is under the Folder Options Menu, there is no Programs folder and I've already changed that under Folder Options however Mozilla has somehow changed my pdf files to be listed as Firefox HTML documents and the Icons remain the firefox icon even when changed to Adobe

more options

I uploaded the screenshot where I believe the issue starts which shows PDF defaults are somehow Firefox HTML docs and even though the Adobe icon shows here all files in folders show the mozilla icon

由 Orleanslady 於 修改

more options

選擇的解決方法

hello Orleanslady, does it work when you go into the acrobat reader > edit > preferences > general & click on the default application option at the bottom? in there reselect adobe's application and confirm this selection...

more options

Thank you so much, I had to update my version of Adobe in order to see the default application handler, all pdf icons have changed back and files are listed as pdfs under the control panel file folder options

more options

This has also been addressed with fresh installs of Firefox. It has a patch and a fix is on the way: https://bugzilla.mozilla.org/show_bug.cgi?id=1049521

more options

This is a known bug in Firefox: https://bugzilla.mozilla.org/show_bug.cgi?id=1069375 You do not have to reinstall Firefox to fix this problem. Here is the solution, that I have done: Click on: Settings > Control Panel > Folder Options > File Types > New > type in "pdf" in empty box > click on: Advanced > select "Adobe Reader Document" in the: Associated File Type > click on: OK and if there is a pop-up from Windows, click YES. If you select "Adobe Acrobat Reader" instead of "Adobe Reader Document", you will not get a preview icon of the document!

more options

Hello everyone,

I am using Window XP SP2, installed Firefox 33.0.3 and Adobe Reader 8.0.0

I had the same issue and came here to find the solution. Even though the steps provided here doesn't solved this issue but helped to find a solution.

I couldn't find any options mentioned in this forums like "Select Default PDF Handler" in Adobe Reader > Edit > Preferences > General

May be its not available in older Adobe versions.

Here are the steps I have followed to solve:

1. Go to My Computer > Tools > Folder Options > File Types. Now, find PDF in the Registered file types and select. You will see "Restore" button. (Pic 1)

2. Click on "Restore" button. The button will be changed to "Advanced" and the default program changes to Firefox. (Pic 2)

3. Click on "Advanced" button. Now you can see "Change Icon" button. Click on it and browse and select "AcroRd32.exe". Usually it is located in Program Files > Adobe > Reader (Pic 3). Check the icons of pdf files. They will changed back to Adobe icons.

NOTE: Instead of AcroRd32.exe, may be we can download Adobe Icon and select it. Someone try it.

4. Now, we need to change the default program back to Adobe. Go to My Computer > Tools > Folder Options > File Types > select PDF > click on Change button > select Adobe Reader from the list.

Finally, I assume it has something to do with the versions of Adobe and Firefox. If we run the similar versions, then we may not have any problem. If we install one older version and the other newer version, we may come across these kind of issues.

Hope it helps you. :)

由 RaGHaV WiD LuV 於 修改