X
點擊此處開啟此網站的行動版。

技術支援討論區

How do I fix the truncated right-click options (http://screencast.com/t/KsF2PWeqieL) in Firefox 30 on OS X Mavericks?)

已張貼

How do I fix the truncated right-click options in Firefox 30 on OS X Mavericks? When I attempt to right click, the options are so truncated I can't see what I'm choosing, which makes the options virtually non-functional. This happened only recently and apart from my adjusting any of the browser settings, so I'm at a loss as to the cause. I also cannot replicate the issue in any other browser, which means it's a Firefox issue, not a Mavericks issue. For your convenience, I have created a screencast to illustrate the problem:

                http://screencast.com/t/KsF2PWeqieL

Can someone please suggest possible fixes for this?

How do I fix the truncated right-click options in Firefox 30 on OS X Mavericks? When I attempt to right click, the options are so truncated I can't see what I'm choosing, which makes the options virtually non-functional. This happened only recently and apart from my adjusting any of the browser settings, so I'm at a loss as to the cause. I also cannot replicate the issue in any other browser, which means it's a Firefox issue, not a Mavericks issue. For your convenience, I have created a screencast to illustrate the problem: http://screencast.com/t/KsF2PWeqieL Can someone please suggest possible fixes for this?

由 T h e o • p h i l o g u e 於 修改

額外的系統細節

已安裝的外掛程式

  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 14.0 r0
  • Provides information about the default web browser
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.30514.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.06

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0

更多資訊

guigs2
  • Top 10 Contributor
  • Administrator
  • Moderator
661 個解決方法 7515 個答案

Hi T h e o • p h i l o g u e, Thank you for the screencast, this makes it alot easier to know what is happening!

I have never seen that before to be honest. It looks like you reported this from version 31 as well and the issue still exists.

  1. Does this happen in Troubleshoot Firefox issues using Safe Mode?
  2. Does this happen with extensions disabled?
  3. Does this happen in a new profile with nothing added to it? Use the Profile Manager to create and remove Firefox profiles
Hi T h e o • p h i l o g u e, Thank you for the screencast, this makes it alot easier to know what is happening! I have never seen that before to be honest. It looks like you reported this from version 31 as well and the issue still exists. # Does this happen in [[Troubleshoot Firefox issues using Safe Mode]]? # Does this happen with extensions disabled? # Does this happen in a new profile with nothing added to it? [[Use the Profile Manager to create and remove Firefox profiles]]

提出問題者

@guigs2,

I'm using FF 31 on Mac OS X 10.9.4 with Javascript enabled, cookies enabled, Flash installed and up-to-date, Java installed and up-to-date, no add-ons, no extensions. Here is a screencast image with all my browser plugins:

        http://screencast.com/t/oiNJuS0eH

It's odd, but the same day you posted your comment, the issue mysteriously resolved itself without my changing any settings. This will make the bug impossible to investigate further at this time, but when the issue recurs, I will answer your questions (1) and (3).

Thank you,

T h e o • p h i l o g u e

 [theophilogue.com]
@guigs2, I'm using FF 31 on Mac OS X 10.9.4 with Javascript enabled, cookies enabled, Flash installed and up-to-date, Java installed and up-to-date, no add-ons, no extensions. Here is a screencast image with all my browser plugins: [http://screencast.com/t/oiNJuS0eH] It's odd, but the same day you posted your comment, the issue mysteriously resolved itself without my changing any settings. This will make the bug impossible to investigate further at this time, but when the issue recurs, I will answer your questions (1) and (3). Thank you, T h e o • p h i l o g u e [theophilogue.com]
guigs2
  • Top 10 Contributor
  • Administrator
  • Moderator
661 個解決方法 7515 個答案

Hi T h e o • p h i l o g u e, For now I will mark your post as solved, however please do not hesitate to references this thread if you see the issue again in a new thread. :-)

Hi T h e o • p h i l o g u e, For now I will mark your post as solved, however please do not hesitate to references this thread if you see the issue again in a new thread. :-)

提出問題者

@guigs2,

I checked when you updated the thread and the issue recurred. Safe Mode indicates it's a plug in. I have provided a video below for your convenience that indicate my plugins and their settings, along with my other browser settings.

http://screencast.com/t/QdcncGJS

Can you investigate and advise what is causing this issue?

Thank you,

T h e o • p h i l o g u e

@guigs2, I checked when you updated the thread and the issue recurred. Safe Mode indicates it's a plug in. I have provided a video below for your convenience that indicate my plugins and their settings, along with my other browser settings. [http://screencast.com/t/QdcncGJS http://screencast.com/t/QdcncGJS] Can you investigate and advise what is causing this issue? Thank you, T h e o • p h i l o g u e
cor-el
  • Top 10 Contributor
  • Moderator
12269 個解決方法 113635 個答案

有幫助的回覆

You can try to disable hardware acceleration in Firefox.

  • Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

You can try to disable hardware acceleration in Firefox. *Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

有幫助的回覆

I think it may be Silverlight, as this was the only add on I had set to "Always Run" instead of "Ask before running."

http://screencast.com/t/BJ0m9KktL2HR

That's my best shot. I guess I'll have to just keep restarting in safe mode all the time? That's a bummer. Silverlight is made by Microsoft.

Perhaps I should take this issue to them?

I think it may be Silverlight, as this was the only add on I had set to "Always Run" instead of "Ask before running." [http://example.com http://screencast.com/t/BJ0m9KktL2HR] That's my best shot. I guess I'll have to just keep restarting in safe mode all the time? That's a bummer. Silverlight is made by Microsoft. Perhaps I should take this issue to them?
cor-el
  • Top 10 Contributor
  • Moderator
12269 個解決方法 113635 個答案

If it works when Silverlight is set to "Ask to Activate" then you can leave it at that setting.

Does it help if you disable hardware acceleration in Firefox?

If it works when Silverlight is set to "Ask to Activate" then you can leave it at that setting. Does it help if you disable hardware acceleration in Firefox?