搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Flash blocked on a site, doesn't load (remains invisible) and has no error messages

  • 12 回覆
  • 3 有這個問題
  • 4 次檢視
  • 最近回覆由 cor-el

more options

Hello,

I like to listen to a radio station but whenever I open their site the embedded player on top is simply not visible at all. It should be right on top of the add but it is not loading: http://i.imgur.com/e14UPsy.png

The site uses flash but I have flash (the latest) and do not have problems on other websites using it such as Youtube, Dailymotion or Vimeo. It is also listed in my add on page and the website to check runs correctly.

However I can't do much on the website of the radio since nothing is visible concerning the player.

The site itself is: http://seoul.fm/

I tried IE which I only use to see if something is a browser problem or a site problem and the player loads correctly in that browser.

I get no error messages, popups or anything when visiting it through Firefox. I also installed the latest Javaa to see if this was the problem, and verified it on the Javaa website that it is working.

Flash is not blocked in the add on menu.

I turned off all my add block extensions to see if it caused the problem. No result.

On IE I have to enable Flash runtime to run it. I don't think it is a Javascript problem but Flash (I stated in a respond that perhaps it is java related but that is not true I think).

由 WaffleToaster 於 修改

被選擇的解決方法

Hi BlueWaffle, I should have checked before: after I approve the Flash, I don't hear any audio, either.

What I see in Google Chrome is that the player uses the HTML5 audio tag, and Flash is only used in the comment area. So Flash isn't the problem. The problem is that the script which builds the player area isn't running. This page is very complex, using a lot of deferred script loading, and I can't follow it very well. After 45 minutes, I give up.

從原來的回覆中察看解決方案 👍 1

所有回覆 (12)

more options

Adding that starting in Safemode changed nothing for the website

more options

<please ignore this>

由 WaffleToaster 於 修改

more options

If you are just playing audio, there would only be the controls. Are you saying you don't see any?

Please post some of the web links so we can look at them.

more options

Yes. The weblink was a;ready added in the opening post but here it is again http://seoul.fm/

I have a comparison shot as well of the element that should be loaded and loads properly in IE http://i.imgur.com/Oi6YDfu.png

But as mentioned before in FF it doesn't show anything: http://i.imgur.com/e14UPsy.png

There are no messages of anything being blocked. So far I tried safe mode, I tried resetting FF, made sure Flash and everything is working as well and Flash (as well as Java) is working correctly.

Other people there use Chrome and it loads correctly in that browser too. Just not in FF. It shows no messages nothing regarding the player.

由 WaffleToaster 於 修改

more options

Do you have Flash set to "Ask to Activate" on the Add-ons page?

You can check using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins and look for "Shockwave Flash".

What is supposed to happen with that setting is that any visible player shows a message to activate the plugin, and if the player is not visible, an infobar should slide down between the toolbar area and the page. On some sites, a "poster" image blocks the player or the player is hidden in some other manner that Firefox cannot currently detect. Or if you click "Continue Blocking" then Firefox might never show the infobar again.

To activate Flash without the in-player link or infobar, you need to click the notification icon in the address bar which looks like a "Lego" block. (see screenshot)

Is that it?

more options

The thing is Flash/Shockwave is already set to Always Activate but I am not getting the pop up bar like in your screenshot.

I have never seen the pop up bar since yesterday was the first time visiting the site on my new system and clean browser.

由 WaffleToaster 於 修改

more options

I see the (Flash?) player in Google Chrome, but not in Firefox, so it is possible that the script that creates the player isn't compatible with Firefox or otherwise isn't working.

There are errors in the Browser Console (Firefox/Tools > Web Developer).

more options

選擇的解決方法

Hi BlueWaffle, I should have checked before: after I approve the Flash, I don't hear any audio, either.

What I see in Google Chrome is that the player uses the HTML5 audio tag, and Flash is only used in the comment area. So Flash isn't the problem. The problem is that the script which builds the player area isn't running. This page is very complex, using a lot of deferred script loading, and I can't follow it very well. After 45 minutes, I give up.

more options

Thank you both for verifying it. At least then I can exclude that this is caused on my side and most likely related to their own coding. I found a work around by using the channel in my mediaplayer but at least I know there is nothing wrong on my system.

more options
more options

I don't know if this will help, I have not tried it;

https://addons.mozilla.org/en-US/firefox/addon/video-without-flash/ Video WithOut Flash 1.4.2 by TheDrev

Watch videos without flash

more options

The script to create and show the player doesn't get started or doesn't finish and thus no player is created, so it is not possible to have a workaround for this issue as there is no stream URL or other data available. I think that the problem is elsewhere as there are error about "$" in the Web Console and Browser Console, so there is already a JQuery problem.