X
點擊此處開啟此網站的行動版。

技術支援討論區

All my pdf files on my computer are labeled Firefox html documents; how do I restore them to pdf documents?

已張貼

I see that others have had this problem. I tried uninstalling Firefox but now the documents won't open at all. One posted solution suggested deleting some application profiles and re-installing firefox. I can't find the profiles. One posted solution is to change the way each file opens by individually clicking on each file and changing the program it opens with; this may work but I have hundreds of pdfs and this is too time consuming. Any other ideas how to solve this?

I see that others have had this problem. I tried uninstalling Firefox but now the documents won't open at all. One posted solution suggested deleting some application profiles and re-installing firefox. I can't find the profiles. One posted solution is to change the way each file opens by individually clicking on each file and changing the program it opens with; this may work but I have hundreds of pdfs and this is too time consuming. Any other ideas how to solve this?
John99 971 個解決方法 13138 個答案

Hi Lynn761,

Hopefully this explantion will help you. Deleting Firerfox profiles would not normally be a recommended solution if your problem is what I think it is.

I note you have posted in

  • My PDF files are now identified as Firefox HTML documents, how to fix it?(only icons changed, extension is still .pdf) /questions/1012676

I have added some additional information to that thread.


The latest release Firefox 31 (for Windows) has changed so that it may open some video and also .pdf files if it thinks nothing else can.

If you right click the files you will get the option to open them with another application instead of Firefox. You can change the choice (see links under).

Firefox 31 is not converting or renaming your files. All it is doing is registering with the Windows OS as an application that is able to open the files and Windows then changes the file's icons accordingly.

This should only occur if no other application has already registered your .pdf files.

Some of the following links may be useful

Hi Lynn761, Hopefully this explantion will help you. Deleting Firerfox profiles would not normally be a recommended solution if your problem is what I think it is. I note you have posted in * ''My PDF files are now identified as Firefox HTML documents, how to fix it?(only icons changed, extension is still .pdf)'' [/questions/1012676] I have added some additional information to that thread. -------- The latest release Firefox 31 (for Windows) has changed so that it may open some video and also .pdf files if it thinks nothing else can. If you right click the files you will get the option to open them with another application instead of Firefox. You can change the choice (see links under). Firefox 31 is not converting or renaming your files. All it is doing is registering with the Windows OS as an application that is able to open the files and Windows then changes the file's icons accordingly. This should only occur if no other application has already registered your .pdf files. Some of the following links may be useful * [https://www.mozilla.org/en-US/firefox/31.0/releasenotes/ Firefox 31 release notes] (Mentions the change) <br /> <sup>This was bug 452254 - Register for audio/video .ogg and .pdf file handlers if nothing else has </sup> * How to change or select which program starts when you double-click a file in Windows XP http://support.microsoft.com/kb/307859 (Also explains how to display file extensions) * http://windows.microsoft.com/en-gb/windows/change-default-programs (Win 7 or Vista) * http://pcsupport.about.com/od/fixtheproblem/ht/default-program-windows-7.htm a tutorial with further links including for other Windows versions
cor-el
  • Top 10 Contributor
  • Moderator
17277 個解決方法 156156 個答案

You should only have to do this once via the "Open with" dialog and tick the box to remember this choice of always using the Adobe Reader to handle PDF files.

You should only have to do this once via the "Open with" dialog and tick the box to remember this choice of always using the Adobe Reader to handle PDF files.
Pharteon 1 個解決方法 4 個答案

有幫助的回覆

This happened to me as well. You need to reassign Adobe Acrobat or Adobe Reader as the default PDF handler...

Open up Adobe Reader (not Acrobat, if you have it on your system); go to "Edit", "Preferences", "General"; at the bottom of the General settings screen to the right "Select Default PDF Handler"; pull down and choose the PDF handler (e.g., Adobe Acrobat or Adobe Reader).

The other options described above and in other threads did not fix the problem for me.

This happened to me as well. You need to reassign Adobe Acrobat or Adobe Reader as the default PDF handler... Open up Adobe Reader (not Acrobat, if you have it on your system); go to "Edit", "Preferences", "General"; at the bottom of the General settings screen to the right "Select Default PDF Handler"; pull down and choose the PDF handler (e.g., Adobe Acrobat or Adobe Reader). The other options described above and in other threads did not fix the problem for me.
tonymay49 0 個解決方法 1 個答案

I've followed the above instructions & have successfully reclaimed my pdf icons & files that open with adobe reader, relieved. I had also seen a pop-up box from a banking site telling me to look in firefox, options, applications, select adobe reader as default in there as well, that was not wholly successful at first. Thanks

I've followed the above instructions & have successfully reclaimed my pdf icons & files that open with adobe reader, relieved. I had also seen a pop-up box from a banking site telling me to look in firefox, options, applications, select adobe reader as default in there as well, that was not wholly successful at first. Thanks