搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Won't open homepage on open, won't open web pages from the menu 'open new window', Can't open menu button

  • 70 回覆
  • 44 有這個問題
  • 1727 次檢視
  • 最近回覆由 supmozilla

more options

Ok, since update to version 31.0, I have been having some problems. I have tried doing everything stated in the support page about resetting, reinstalling, safe mode, restarting pc etc. First problem, when I open Firefox no web page loads. It just says New Tab and a blank white page. If I press the home button I am taken to my homepage which is google.

Second problem, when I right click on a link and the menu pops up, if I click open in new window, a new window opens but it just says New Tab with a blank page and no URL information, just blank.

Third problem, the Open Menu button just doesn't work at all. You can click all you like, that thing is not opening.

I am really stuck as to what to do. I have only been using Firefox for about a month and t was good until these problems. If I can't resolve it, I will have to use another browser as it is really annoying.

I am using Windows 8.1 by the way and have scanned my computer thouroughly for both virus's and malware.

所有回覆 (20)

more options

Hi healy1948, I would love to figure this out if I can. Unfortunately, it seems to be a Windows 8.1 issue and I don't have regular access to Windows 8.1. When I did get hands on the OS I didn't encounter the problem. Obviously that isn't the end of the story, I'm still trying to collect data and appreciate your trying the new profile test to test whether the home page issue seems settings related.

Hi valley1, you can email me via my username @gmail.com if you like, or if it's easier, you can send me a link to a Dropbox or other cloud storage folder through this site's message facility (click my username).

more options

Hi valley1, thank you for the comparison files. There is something peculiar in the prefs.js file for the computer that isn't working correctly:

user_pref("browser.sessionstore.resume_session_once", true);

This would cause Firefox to restore your previous session windows and tabs instead of showing the home page.

Could you exit out of the "bad" Firefox and start it up again and check whether that preference is still set to true in about:config?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

Normally, the preference would be default/boolean/false.

You might also check for a user.js file as described in this article: How to fix preferences that won't save.

more options

Hi jscher2000, the boolean value for "browser.sessionstore.resume_session_once" was still 'true' when I got back into Firefox. However, even after I manually changed it to false, it did not fix anything.

Also, neither computer has a user.js file, so the article you referenced does not apply.

more options

Hi valley1, I should have asked you to check prefs.js again before the next startup to see whether your change was saved and retained or whether it was lost.

Regarding the toolbar button not working, I do not see a good explanation for that in the settings files. There is a small driver difference --

Intel(R) HD Graphics 4600
"Good"
Driver Date: 5-16-2014
Driver Version: 10.18.10.3621
"Bad"
Driver Date: 12-18-2013
Driver Version: 10.18.10.3379

-- but it seems unlikely that is the explanation.

In case Firefox 31 is using an incompatible legacy file in its program folder that wasn't cleaned out during the upgrade, you can try this "Clean Reinstall" approach to replacing just that folder:

(1) If needed, download a fresh installer for Firefox 31 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox.

(3) Rename the folder (64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement with the menu button?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • C:\Program Files (x86)\OldFirefox\Plugins
  • C:\Program Files (x86)\OldFirefox\browser\plugins
more options

Glad to see an active thread that's actively trying to deal with this issue. I'm desperate! I replied on this question with all the steps I've taken and got the sound of silence: https://support.mozilla.org/en-US/questions/1002157?esab=a&s=&r=0&as=s

Here's my symptoms and what I've done.

  • I tried safe mode.
  • I tried resetting Firefox.
  • I uninstalled and reinstalled multiple times, both with keeping my profile and without - both ways don't solve the problem. I tried the install stub file and the full install file. Neither solve the problem.
  • I ran ccleaner to clean out the registry between installs. No help.
  • I manually renamed all the plugin files to eliminate plugins being the culprit, but my colleagues have the exact same plugins installed and they're not having issues on the latest version. Note I'm not talking about addons - that possibility was eliminated by reinstalling with a new profile so that's not it
  • I uninstalled WebRoot (a small, simple rootkit detection software which banks usually offer you free of charge to ensure security while you're logged into their online services)
  • I even went so far as to uninstall Chrome (since Chrome has a Google Update plugin which shows up in Firefox for some reason, so I thought it might be a conflict) and even Adobe Flash Player! Nothing.

The only thing that works is if I roll back to Firefox version 28, the last version before all the layout changes, and it's not really an option since all the plugins I need don't support that version anymore.

  • Can't open the hamburger menu.
  • Can't customize. Typing about:customizing into the address bar opens a blank tab
  • The Firefox home page doesn't work (as in, Firefox opens a blank tab instead of the home page, and if you click the home button and type something into the search bar and hit search, nothing happens)
  • The firefox message that pops up just below the address bar, for example when you're downloading an add-on and it shows the download rate, doesn't work.

Worth nothing is that I'm also on the [sarcasm]wonderful/sarcasm Windows 8.1.

I'm at a complete loss. If anyone has any more ideas I'd be glad to hear them. Alternatively, I think the devs should hear about this. I'm happy to provide whatever debug or take whatever steps you think might help, although I'm in no mood to repeat any of the steps I've already taken above.

Thanks in advance!

more options

You can check for problems caused by a corrupted localstore.rdf file.

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Hi Cor-el,

If you read my post, I mentioned having already done this:

  • uninstalled and reinstalled multiple times, both with keeping my profile and without - both ways don't solve the problem.

Thanks, Ruggero

more options

Tried creating a new profile using the profile manager. No good.

more options

I feel your pain as I have had these issues since the version 31 came out. Same issues and same results on the postings. I have reverted my browser to version 30 and have given up on version 31. Seems this 31 was released in haste and incomplete testing. I have always had a lot of confidence in Firefox but it has definitely taken a hug dip with no one apparently knowing what to do. I don't really want to revert to using IE as my web browser but the longer this goes on the more of an option that becomes. Apparently no one at Mozilla/Firefox cares or something would be happening to correct this I would think. Very disappointed in Firefox developers.

more options

Hi RuggeroSB, if you have the same problem with the toolbars in Firefox 30-31 but not Firefox 29: it could be that switching most plugins from "Always Activate" to "Ask to Activate" is part of the problem. Some plugins that monitor all pages do not work correctly in click-to-play mode and can interfere with the toolbars. Try switching them either to "Always Activate" or "Never Activate" to see whether that makes any difference (you may need to exit Firefox and start it up again in order for this to take effect in existing windows).

I don't recall anyone reporting an unresponsive menu button in Firefox 29, so you may have discovered a new issue. (Then again, it's impossible to keep up on all the threads here.)

more options

Hi Jscher2000,

I tried installing from scratch, with NO plugins or addons (I physically removed ALL plugins completely). So, fresh install with no plugins and no addons installed and a fresh profile, and the issue persists.

Also worth mentioning is that while I also have issues with version 30, it's far worse with 31/32.

由 RuggeroSB 於 修改

more options

I see version 32 is out, so I dutifully upgraded. Disappointed that it didn't fix anything... :S

more options

Ok, clearly there's nothing anyone can do at this point in terms of first-line support.

I'm not the only one with this issue - a quick Google search turns up a number of support threads which are at least very closely related to my issue if not exactly the same issue, and as Jscher2000 pointed out, we may have identified an actual bug here.

So, if the mod's or dev's or whoever the powers that be are on this forum would please escalate this, many of us would be very grateful.

I'm ready to provide logs, screenshots, video recordings or even remote access if need be if second-line support (a developer) would please take an interest and investigate the issue.

Just let me know what you need. I REALLY don't want to have to switch to Chrome!

more options

I would concur 110%. This has gone on way too long. Chrome or IE is not far away at this point Mozilla. If you don't care then please say so and I'm out of here. Get it, Mozilla?

more options

Hi healy1948 and RuggeroSB, I've kept this thread open in a tab hoping for news or a new idea but so far, I haven't seen a solution or workaround.

There is a bug on file for this but I think they need more information, so this would a good place to direct screen shots and other documentation: https://bugzilla.mozilla.org/show_bug.cgi?id=1042458

Some background information on using Bugzilla:

more options

With all due respect jscher I feel I have already gone above and beyond what I should have to with little or no results or interest from corporate developers and or application people. The user should not be expected to fix developers flaws. I am tired of this and when Firefox 30 is so antiquated that it is of no use I will change to a different browser because Firefox is not the only tool available to browse the web. If I sound bitter...I am!

more options

jscher2000, I've added my notes to the bug report.

Happy to help anyway I can to fix this!

more options

Updated to version 32.0.0.5350 and still have the same issues going on. How do we talk to a software designer. This is so ridiculous.

more options

None of this has helped, this happens on a fresh install of windows 8.1 x64 enterprise. MEANING NO PROFILE! Not sure what was really tested in beta, but ever since you release 31 its been broke.

由 zenithtwc 於 修改

more options

Pretty soon this is going to affect plugins, and its ready a security issue. Don't know if we should have this on our universities computer anymore. I might have to have it pulled.

由 zenithtwc 於 修改

  1. 1
  2. 2
  3. 3
  4. 4