搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I am using firefox 24.4 version along with r_kiosk plugin in linux but the address bar is not hiding , it use to workin firefox17, we recently updated to 24.4

  • 1 回覆
  • 1 有這個問題
  • 2 次檢視
  • 最近回覆由 guigs

more options

I am using firefox 24.4 version along with r_kiosk plugin in linux but the address bar is not hiding , it use to work with firefox17, we recently updated to 24.4 firefox.

In kiosk mode , we have requirement of disabling the Address (url) bar but need to enable the tab. this use to work in FF-17 ver now with FF 24.4 is not working. all other menu and buttons are disabled that is still disable after upgrade of ff. which properties do I need to set which meet my requirement.

Env - Centos 6.5

所有回覆 (1)

more options

The add on has an explanation of how this works: https://addons.mozilla.org/en-us/fire.../r-kiosk/ It looks like it depends on a user.js file. Does this still exist in the profile?

Javascript needs to be enabled. In Firefox 23, as part of an effort to simplify the Firefox options set and protect users from unintentially damaging their Firefox, the option to disable JavaScript was removed from the Firefox Options window.

However, the option to disable JavaScript was not removed from Firefox entirely. You can still access it from about:config or by installing an add-on.

about:config

  1. In the address bar, type "about:config" (with no quotes), and press Enter.
  2. Click "I'll be careful, I promise"
  3. In the search bar, search for "javascript.enabled" (with no quotes).
  4. Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now disabled.

To Re-enable JavaScript, repeat these steps.

Add-ons

You can alternatively install an add-on that lets you disable JavaScript, such as

  • No-Script (to disable JavaScript on a per page basis, as required)
  • QuickJava (to easily disable and enable JavaScript, automatic loading of images, and other content)
  • SettingSanity (adds back removed options for JavaScript, Advanced JavaScript Settings, loading images, and showing the Tab Bar)

Thank you, please reply back with the results. I also recommend updating to Firefox 30.