搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How to get FF to auto insert user name and password to open a site

  • 14 回覆
  • 2 有這個問題
  • 133 次檢視
  • 最近回覆由 HowieE

more options

Fire Fox has an option to save User name and Password so they are automatically used and the site opens directly. This works on my older computer but not on my new one. FF is asking to save the UN & PW as if it intended to use them but it does not.

All setting that I can see are set the same on both computers.

所有回覆 (14)

more options

Details like websites remembering you (log you in automatically) are stored in a cookie.

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

more options

Under Settings for Clearing history I can not deselect cookies. I attempt to deselect cookies but when I hit apply cookies is rechecked.

If I remove and reload FF I assume I will loose all of my tool bars and bookmarks.

more options

What is LastPass and does it apply to this question

由 HowieE 於 修改

more options

Does Firefox save the name and password in the Password Manager?

  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"

If not then it is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox. Rename the key3.db and signons.sqlite files in the Firefox profile folder. You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost. If that has worked then you can remove the renamed files that are no longer needed. Otherwise you can rename the files to their previous names (signons.sqlite and key3.db).

more options

Yes FF saves the UN and PW. The problem is when I attempt to set this up I can not cause the delete cookies option to remain UNCHECKED when I hit apply.

more options

If I can not get FF to work would LastPass do the job and if so can you elaborate on how to set it up. My computer skills are less than yours.

This has been a pain in the butt for years as FF will work for a while and then it takes weeks to get it to work again.

more options

I must be missing something. I installed Lastpass on my computer, that had been working as far as applying UN and PW to sites as I open them.

With Lastpass I now have to open Lastpass to see what sites are available and click on a site. After that it takes almost a minute to open the site. I could have typed the UN and PW in several time while waiting.

There must be someone out there that knows how to make this work in FF. I can't be the only person that has ever used this option.

I removed Lastpass and now FF will not apply UN and PW on this computer even though they are saved. The option in tools "save passwords for sites is no longer enabled.

由 HowieE 於 修改

more options

I can't be the only individual that has ever used this option in FF.

I am not that computer literate but when I originally set up FF it was a simple process o set this up. My confusion is why can't I duplicate that now?

Periodically I loose this feature because of some change that has taken place on the computer, update software, and getting it back is a challenge.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

more options

When I attempt to open FF in Safe Mode per these instructions.

How to start Firefox in Safe Mode

Click the menu button New Fx Menu , click help Help-29 and select Restart with Add-ons Disabled.... Firefox will start up with the Firefox Safe Mode dialog. Nothing happen related to these instructions. The Safe Window box does not appear and thus I can go no further. I also tried to start in Safe Mode using the shift key option. Nothing

Cor_el

I have to ask. Do you use the auto open feature with web sites or am I the only one that does?

由 HowieE 於 修改

more options

I use this for instance for this forum and have a cookie allow exception for the support.mozilla.org website.

You will have to find the cause of the problems with the cookies if you do not keep settings or cookies.

You can only start Firefox in Safe Mode if Firefox isn't running, so make sure that all Firefox processes are close if you check this in the Windows Task Manager on the Processes tab.

more options

Hi

I can open FF in safe mode by holding down the shift key.

However there seams to be a conflict in the instructions. Your post says Do Not click the Reset Button. Safe mode say clicking the Reast Button may fix most problems. Which is it?

Don't know if you can get to this tread but it looks like some progress was made while working with "bookmark file https://support.mozilla.org/en-US/questions/930048?esab=a&as=s&r=6&page=2

HowieE

由 HowieE 於 修改

more options

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need close and restart Firefox after toggling this setting.

There is usually no need to reset Firefox in most cases and when cookies are involved then the problem might be carried over (a reset includes importing cookies).

more options

I asked a question on the Airstream Forum and had an answer in less than 10 min. It all turned out to be just Resetting FF.

The complete tread can be read here.

http://www.airforums.com/forums/f317/anyone-have-deep-knowledge-of-fire-fox-122950.html#post1486251


Comment by a Forum Moderator: Cross link to a more recent post

由 John99 於 修改