搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Nightly just started crashing while using Outlook, any ideas why?

  • 7 个回答
  • 8 人有此问题
  • 1 次查看
  • 最后回复者为 jscher2000

more options

When I open an email in Outlook (webmail) the website appears to do a lot of connecting to other places really fast, then the browser crashes. I only get the Windows crash dialog and no crash report for Nightly.

被采纳的解决方案

Your plugins like Flash and Java still run in Safe Mode, and .css files are unlikely to make any difference.

Perhaps the problem is with the JavaScript compilers? These are constantly being updated, so a new problem certainly is possible. To selectively disable those:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste java and pause while the list is filtered

(3) Double-click the following preferences to switch them from true to false:

  • javascript.options.baselinejit.content
  • javascript.options.ion.content

Note: this is based on Firefox 26. I don't follow developments in Nightly.

在上下文中阅读这个答案 👍 3

所有回复 (7)

more options

I tried it in the current Nightly build on Linux and can confirm that opening a message gives some connecting messages flashing on the tab, but for me it stops after a few seconds and doesn't crash.

Most of the last request seem to be to the "db3msgr5011103.gateway.messenger.live.com" host if I check the Network log in the web console.

Did you try to clear the cache and cookies from websites that cause problems?

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

more options

Clearing the cache and cookies did not work. Disabling hardware acceleration did not work. Restarting it in safemode worked. So it's either adblock plus, java, or flash that's causing this then? (those are my only add-ons and extentions).

more options

This would only be true if it works in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled.
In that case try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)


In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • default toolbar layout is used (localstore-safe.rdf)
  • Javascript JIT compilers are disabled (javascript.options.*jit)
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
more options

I disabled the extensions and it still crashed. I only have the default theme installed. Hardware aceleration was turned off. So what's left is the .css files and java?

more options

选择的解决方案

Your plugins like Flash and Java still run in Safe Mode, and .css files are unlikely to make any difference.

Perhaps the problem is with the JavaScript compilers? These are constantly being updated, so a new problem certainly is possible. To selectively disable those:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste java and pause while the list is filtered

(3) Double-click the following preferences to switch them from true to false:

  • javascript.options.baselinejit.content
  • javascript.options.ion.content

Note: this is based on Firefox 26. I don't follow developments in Nightly.

more options

Thanks for that jscher2000! Those two options set to false prevent the browser from crashing. So the new JavaScript seems to disagree a little with Nightly, no big deal I suppose? What sort of "adverse effects" would I likely see with these set to false now?

more options

Hi mrobaer, these compilers speed up JavaScript heavy sites, so you'll experience slower response on those sites. You might give it a week and then try reenabling them in case this is a transient problem that will be addressed quickly. I don't know how optimistic to be.