搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

How to set a plugin to "Never activate" without disabling it

  • 5 个回答
  • 4 人有此问题
  • 27 次查看
  • 最后回复者为 mark2

more options

Hello,

Here in Brazil almost every bank use this "Internet Banking Helper" plugin from a third-part local security company in their internet banking services.

I want to enable this plugin only for two domain names from my bank website and get rid of the "Allow domain.name to run 'Internet Banking Helper'?" notification for all other websites.

Basically, the activation rules would be:

- my.first.allowed.bank.com = Always activate

- my.second.allowed.bank.com = Always activate

- * (default) = Never activate

With Firefox 26 I can set to "Always activate" for the allowed domains in site preferences but there's no way to set the default behavior to "Never activate" without disabling the plugin itself and if I do that the plugin will stop working even for the sites were the preferences says to "Always activate" (of course, the plugin is disabled).

I do believe that someone are making a little confusion about these options. You replaced the disable/enable button with activation options in the Addons/Plugin page but these are two completely different things.

Would be perfect if you offer these activation options: [Ask, Always, Never, Disable Plugin].

So, there's a solution for this situation?

Thank you.

Hello, Here in Brazil almost every bank use this "Internet Banking Helper" plugin from a third-part local security company in their internet banking services. I want to enable this plugin only for two domain names from my bank website and get rid of the "Allow domain.name to run 'Internet Banking Helper'?" notification for all other websites. Basically, the activation rules would be: - my.first.allowed.bank.com = Always activate - my.second.allowed.bank.com = Always activate - * (default) = Never activate With Firefox 26 I can set to "Always activate" for the allowed domains in site preferences but there's no way to set the default behavior to "Never activate" without disabling the plugin itself and if I do that the plugin will stop working even for the sites were the preferences says to "Always activate" (of course, the plugin is disabled). I do believe that someone are making a little confusion about these options. You replaced the disable/enable button with activation options in the Addons/Plugin page but these are two completely different things. Would be perfect if you offer these activation options: [Ask, Always, Never, Disable Plugin]. So, there's a solution for this situation? Thank you.

由pauloschilling于修改

所有回复 (5)

more options

Did you try to enable this plugin via the "Tools > Page Info > Permissions" page only for this domain and keep it to never activate as the default?

more options

Yeah, as I said, I can enable this plugin via site preferences/permissions for my Internet Banking sites but when I chose to "Never activate" via about:addons the plugin will be completely disabled. See the attachment.

That's the point, would be perfect if Firefox offer these activation options inside about:plugins: [Ask, Always, Never, Disable Plugin]. Today if we chose "Never activate" the respective plugin will be disabled.

more options

You can set the plugins.click_to_play to true to get an ask to activate choice.

more options

I'm using Firefox 26, in this version it's enabled by default and I checked about:config and it's set to true.

The problem is that if I set to "Ask to activate" I'll be asked on every website I visit and it's really annoying! Also, I don't want to manually block it for every website I visit.

If I set to "Always activate" this plugin causes some strange and unexpected behavior on normal websites.

And again, if I set to "Never activate" this plugin will be completely disabled and if I access my Internet Banking the click to play feature will ask to activate only plugins in "Ask to activate" state.

more options

If I understand what you mean,probably this extension could help: click to play manager