搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

After update to Firefox 25, tabs will "go back" 2 to 3 pages, when switching tabs or exiting full screen.

  • 6 个回答
  • 5 人有此问题
  • 26 次查看
  • 最后回复者为 tahwos

more options

It happens most frequently when exiting full screen from a video. i.e. youtube, dailymotion, nbc.com - any site with embedded video players.

When exiting full screen, the page skips backwards 2 to 3 pages. And no, I'm not clicking related videos while in full screen the whole time - this is while initiating full screen and exiting full screen, all from the same video page.

This happens less frequently when switching tabs - but if I switch to another tab, then back, the first tab will load the page I was on 2 pages ago.

More info: When this happens, the "forward arrow" is greyed out and the page that that loads is on the "back arrow" list twice - further down the list where it should be, as well as at the very top of the list, as though I had clicked on a link to that page.

This all started immediately upon restarting Firefox after updating to version 25 - no other changes have been made to my computer.

It happens most frequently when exiting full screen from a video. i.e. youtube, dailymotion, nbc.com - any site with embedded video players. When exiting full screen, the page skips backwards 2 to 3 pages. And no, I'm not clicking related videos while in full screen the whole time - this is while initiating full screen and exiting full screen, all from the same video page. This happens less frequently when switching tabs - but if I switch to another tab, then back, the first tab will load the page I was on 2 pages ago. More info: When this happens, the "forward arrow" is greyed out and the page that that loads is on the "back arrow" list twice - further down the list where it should be, as well as at the very top of the list, as though I had clicked on a link to that page. This all started immediately upon restarting Firefox after updating to version 25 - no other changes have been made to my computer.

由tahwos于修改

被采纳的解决方案

The problems were with HTML5

about:config > media.webm.enabled > false

Problem solved! BY ME!!!!!

(The attached image is a screen cap that shows up if HTML5 is properly disabled. I had noticed it before the Firefox update, but it was never up long enough to actually read it, and I didn't really care. When it returned immediately after disabling HTML5, I did a screen cap to see what was up. Oh I see... something worked, so some idiot decided to fix it... genius!)

定位到答案原位置 👍 0

所有回复 (6)

more options

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

more options

Thanks for the canned responses, but you guys are way off.

More information: It's related to HTML5 - whenever I fullscreen an HTML5 video, Firefox skips backwards to the most recent HTML5 video before that one, when exiting fullscreen. This last time, it skipped backwards past 4 pages that had no HTML5 content at all, to the one that did.

more options

Which tab history items do you see if you right-click the Back button?

If some JavaScript has modified the page and doesn't change the URL then no new entry in the tab history is created and thus you cannot return to the previous page.

more options

Quoted from my original post:

"When this happens, the "forward arrow" is greyed out and the page that loads is on the "back arrow" list twice - further down the list where it should be, as well as at the very top of the list, as though I had clicked on a link to that page."

I shouldn't have to clarify this, but just in case that wasn't clear enough - the url "is" changing, then loading a whole new page, but with the same url as a page several items down the "back button" history list. The new page becomes the newest item on the list... above all the pages that I actually visited. The new page that loads, when exiting HTML5 fullscreen, is the one that does not belong - because I was already there, 2 to 3 pages ago, sometimes more...

more options

选择的解决方案

The problems were with HTML5

about:config > media.webm.enabled > false

Problem solved! BY ME!!!!!

(The attached image is a screen cap that shows up if HTML5 is properly disabled. I had noticed it before the Firefox update, but it was never up long enough to actually read it, and I didn't really care. When it returned immediately after disabling HTML5, I did a screen cap to see what was up. Oh I see... something worked, so some idiot decided to fix it... genius!)