搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

How can autoplay video be stopped in Firefox 24

  • 1 个回答
  • 21 人有此问题
  • 1150 次查看
  • 最后回复者为 Nellus

more options

I have tried about:config turning "media auto start" to false and "click to play" to true. Videos keep starting automatically. I read that there is an addon that stops this, but that it doesn't work in version 24. This is prevalent on media sites (AZCentral.com and now NPR.org). What is the solution?

Also, despite a popup blocker, there are these obnoxious ads that keep popping up anyway.

I'll get a Windows box saying "Firefox has blocked a popup" with the only option being "Okay." When I click "Okay," the popup ad opens in a separate window. What is causing this? It usually happens on media sites.

所有回复 (1)

more options

To stop ads popup try ABP.

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.