搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

When using the "Open With" functionality to download an eml file, firefox is appending a *.txt extension to the filename. How can I prevent this from happening?

  • 3 个回答
  • 3 人有此问题
  • 7 次查看
  • 最后回复者为 eribs4e

more options

If I save the file instead of open it, the file saves correctly (ie: without the added txt extension). If I attempt to open instead of save, the txt is added, resulting in the file opening as a text file instead of an eml file.

所有回复 (3)

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

more options

Thanx for the suggestions guys, but neither of the above worked. I've thinking that it may have something to do with the MIME type of the attachment I'm attempting to open being improperly declared. If that's the case, then the issue lies not with firefox but with the system generating the attachement.

Does that make sense?