搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Why does spellcheck language setting not match prefs.js?

  • 5 个回答
  • 5 人有此问题
  • 239 次查看
  • 最后回复者为 Paul

more options

I have only one profile in ~/.mozilla/firefox (the default profile), and in it prefs.js contains

user_pref("spellchecker.dictionary", "en_US");

(which is correct). Despite that, about:config tells me the language is en_AU, and that's what is used by the spell checker. I can change it to en_US from the context menu in a text field, and the change sticks until I close FF, but next time I start FF we're back to Australian despite the setting in prefs.js. Syncing before or after changing the setting doesn't make any difference. Running in safe mode doesn't make any difference.

被采纳的解决方案

The value of spellchecker.dictionary should be "en-US" for the en-US dictionary and not have an underscore.

  • user_pref("spellchecker.dictionary", "en-US");

Do you have a user.js file in the profile folder that might override the last saved setting in prefs.js?

在上下文中阅读这个答案 👍 0

所有回复 (5)

more options

选择的解决方案

The value of spellchecker.dictionary should be "en-US" for the en-US dictionary and not have an underscore.

  • user_pref("spellchecker.dictionary", "en-US");

Do you have a user.js file in the profile folder that might override the last saved setting in prefs.js?

more options

Thanks for the reply. I changed the prefs.js file manually to "en-US" (with FF closed) and started FF. It's checking spelling in Australian. I should point out that FF uses an underscore when it rewrites that line in prefs.js.

I do have a user.js file, but it contains only two lines relating to Picassa, and in particular nothing about the spelling language.

more options

Maybe that is caused by the way the Ubuntu has branded that version.

You can try Firefox from the official Mozilla servers to see if it still happens.


Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Thanks, but I'm already using an unbranded version of FF.

I've got a workaround: I turned off "preferences" in the Sync settings. Best guess is that FF upgrades revert to en_AU, and that gets "stuck" in the Sync memory. I tried changing the setting to en_US and then forcing a sync, which didn't work -- not sure if the sync failed or what. After I've got every copy of FF back to en_US, maybe I'll try syncing preferences again.

If it's really upgrades that are switching me back to Australian, I would call that a bug. Upgrades should respect whatever preferences the user has set in his/her profile.

I appreciate the suggestions.

Paul

more options

That workaround turned out not to work, although I'm not sure why. I turned off preference syncing, adjusted the language to en_US, and restarted FF. The language setting survived the restart. Opened FF this morning, though, and it had reset to Australian. <sigh>

So I deleted the Australian English dictionary from Hunspell (sudo rm /usr/share/hunspell/en_AU.*), and hopefully FF will now wake up using the US dictionary. I discovered, though, that something had added symlinks in the folder to make en-AU.* aliases for en_AU.* files. I wonder if that had anything to do with Firefox grabbing the Australian dictionary at startup?

由Paul于修改