搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

I cant untick labels in google maps satellite mode using firefox. It works on other browsers

  • 23 个回答
  • 5 人有此问题
  • 177 次查看
  • 最后回复者为 laugh.atlantic

more options

I cant untick labels in google maps satellite mode using firefox. It works on other browsers

I cant untick labels in google maps satellite mode using firefox. It works on other browsers

被采纳的解决方案

Thanks for the info. I think I will leave this thread .

在上下文中阅读这个答案 👍 0

所有回复 (20)

more options

With no examples provided I assume you mean something like this. First screenshot shows the red mark and the second show the same location with no mark. If this is wrong please provide steps to replicate and screenshots of the issue.

有帮助吗?

more options

Thanks for your reply

No I am talking about all labels.

First image with labels 2nd no labels.

in Firefox I cannot untick the blue box with the tick (these were done in another browser) I have tried on 2 PC s

有帮助吗?

more options

Look at both one has a boxed check the other doesn't - is that what your referencing to? You will have to provide the link your using so others can replicate or verify the issue as well. It could be something related to Addons as well.

有帮助吗?

more options

Okay, the first step is to click the Layers button and then More to get the panel in your screenshot.

Then I can confirm the problem, the click on the Labels button seems to be ignored even though clicking the nearest 3 items work fine. Google's scripts are notoriously complex and I have zero insight into why that one isn't working. Can you post it on a Google forum like the following:

https://support.google.com/maps/community

有帮助吗?

more options

Thanks for your reply.

I have already posted on the Google forum, No resolution as yet.

有帮助吗?

more options

That's better. In Win7 I can replicate the issue. see screenshot Let me see what happens in Safe Mode.

有帮助吗?

more options

It's grayed out in safe mode. see screenshot I get the same issue in Chrome.

由jonzn4SUSE于修改

有帮助吗?

more options

On further investigation this seems to only be a problem on Firefox. Other browsers are working ok.

有帮助吗?

more options

The only problem I am seeing here is there is no URL so others can test their firefox for comparisons and all were left with is just screenshots to compare. I do think having both screenshot of the error and actual link your using would help others test your issues here.

有帮助吗?

more options

Dropa said

The only problem I am seeing here is there is no URL so others can test their firefox for comparisons and all were left with is just screenshots to compare. I do think having both screenshot of the error and actual link your using would help others test your issues here.

Go somewhere on Google Maps and click the button in the lower left that allows changing between map views, then click the More button. See: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-10-01-11-41-53-b6e392.png

有帮助吗?

more options

So, a Firefox problem, or a Google problem?

有帮助吗?

more options

Seems to be a firefox problem. No resolution yet.

有帮助吗?

more options

If Firefox problem, how do we go about asking for this to be fixed?

有帮助吗?

more options

mfly said

If Firefox problem, how do we go about asking for this to be fixed?

As far as I can tell, the site doesn't attach an event to the checkbox when it displays in Firefox. Why is it not working? Google scripts are too complex for me to tell you. If you want to file a Firefox bug report with Mozilla, you can do that over here:

https://bugzilla.mozilla.org/

See: Bug Writing Guidelines

有帮助吗?

more options

jscher2000 - Support Volunteer said

mfly said

As far as I can tell, the site doesn't attach an event to the checkbox when it displays in Firefox. Why is it not working? Google scripts are too complex for me to tell you. If you want to file a Firefox bug report with Mozilla, you can do that over here:

https://bugzilla.mozilla.org/

See: Bug Writing Guidelines

OK, thanks, I will look at getting that done.

有帮助吗?

more options

I'm sorry I didn't think of this before, but when I re-read a related thread tonight, I realized you can use a little script to un-disable the button and click it:

var btn=document.querySelector('button[jsaction="layerswitcher.intent.labels"]');
btn.removeAttribute('disabled');
btn.click();


Although you can execute that in the Web Console (Ctrl+Shift+K), the most convenient way to run it is to assign it to a bookmark on your Bookmarks Toolbar and click the bookmark to execute the script against the page (i.e., a bookmarklet). The syntax has a little extra at the beginning and end:

javascript:var btn=document.querySelector('button[jsaction=%22layerswitcher.intent.labels%22]');btn.removeAttribute('disabled');btn.click();void 0;

I added it to my collection here for easier installation:

https://www.jeffersonscher.com/res/sumomarklets.html#GMapLabels

有帮助吗?

more options

Thanks for the work around, it works great. Do you think that it will get an update ?

有帮助吗?

more options

laugh.atlantic said

Do you think that it will get an update ?

From what I can see, the problem is that Google is changing between <button disabled="true"> -- on the Map layer -- and <button disabled="false"> -- on the Satellite layer. This doesn't work in Firefox because it follows the web standard: if the disabled attribute is present at all then the button must be disabled.

Will Mozilla break with the standard for better compatibility with Chromium-based browsers? That happens on rare occasions, but I don't know whether this will be one of them because there is always some risk that other sites would be negatively affected.

由jscher2000 - Support Volunteer于修改

有帮助吗?

more options

Thanks for the update. Looks like its a dilemma for Mozilla.

有帮助吗?

more options

laugh.atlantic said

Thanks for the update. Looks like its a dilemma for Mozilla.

Honestly it's not a dilemma for Mozilla; they should just stick to the standards. Google is the one doing things the wrong way here!

It's very ironic too, because Google's whole premise with Chrome was that Internet Explorer was deviating from web standards, so pages only were showing up correctly when viewed in IE, which at the time was the super-dominant browser. So they set off to create a browser which could effectively replace IE. Well, I'd say they replaced it a bit too accurately!


Anyway, I have the same issue myself on my Windows 10 work PC. I don't recall if my Windows 11 desktop at home still has this problem. Happens in regular or private browsing. The button works in both Edge and Chrome.


For anyone reading: This is NOT a "Firefox problem", it's a GOOGLE problem. They wrote the script in a way that does not conform to standards, and GOOGLE should fix their code.

有帮助吗?

  1. 1
  2. 2
我要提问

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.