搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Firefox behavior with virtual desktops in Windows 10

  • 2 个回答
  • 0 人有此问题
  • 11 次查看
  • 最后回复者为 ge.brenn

more options

Hello dear Firefox experts,

I have been using Firefox for years and of course I would like to continue doing so. :-)

I work with Windows 10 and have learned to appreciate the virtual desktops, which can be set up via the key combination "Windows + Tab". About the desktops can then be distinguished, for example, in "Office" and "Private".

In total, I have actively set up 4 different desktops.

FF I have set up as the "default app" in the Windows settings.

Now it is the case that I have a Firefox window open in the "private desktop", for example.

But when I work in the "office desktop" and click on a URL, the office desktop automatically switches to the private desktop and opens the URL in the FF already opened there in a new tab! :-(

So I have to remember before to open a new Firefox window in the office desktop to display the desired page also on this desktop.

Unfortunately, this doesn't always work.

If I work in the meantime in another of the 4 active desktops and use Firefox there and return to the office desktop and want to open a URL there again, the desktop jumps back to where I last used the already opened FF. This is quite annoying in the long run.

That's why I ran a test today with Google Chrome and MS Edge and defined each of them as the default app for testing.

Stupidly, these two browsers work exactly as I want them to. If I have already opened one of these browsers in another desktop, the URL will still open in the current desktop and any additional URL as another tab will correctly open in the current desktop.

If I now switch to the private desktop and open a URL there, it will correctly open in a new tab in this desktop.

I hope I was able to illustrate my "problem" so far?

Now my question? How can I change the behavior in FF? This seems to be a standard of FF in contrast to both other browser programs. Disabling in the FF settings "Open links in tabs instead of new windows" seems to be only a rudimentary solution;

but then a new window is opened every time, which is also not useful.


Can something be adjusted in the "deeper" settings?

Many thanks in advance for your tips.

Best regards, Georg

[Translated with "DeepL.com"]

Translated with www.DeepL.com/Translator (free version)

Hello dear Firefox experts, I have been using Firefox for years and of course I would like to continue doing so. :-) I work with Windows 10 and have learned to appreciate the virtual desktops, which can be set up via the key combination "Windows + Tab". About the desktops can then be distinguished, for example, in "Office" and "Private". In total, I have actively set up 4 different desktops. FF I have set up as the "default app" in the Windows settings. Now it is the case that I have a Firefox window open in the "private desktop", for example. But when I work in the "office desktop" and click on a URL, the office desktop automatically switches to the private desktop and opens the URL in the FF already opened there in a new tab! :-( So I have to remember before to open a new Firefox window in the office desktop to display the desired page also on this desktop. Unfortunately, this doesn't always work. If I work in the meantime in another of the 4 active desktops and use Firefox there and return to the office desktop and want to open a URL there again, the desktop jumps back to where I last used the already opened FF. This is quite annoying in the long run. That's why I ran a test today with Google Chrome and MS Edge and defined each of them as the default app for testing. Stupidly, these two browsers work exactly as I want them to. If I have already opened one of these browsers in another desktop, the URL will still open in the current desktop and any additional URL as another tab will correctly open in the current desktop. If I now switch to the private desktop and open a URL there, it will correctly open in a new tab in this desktop. I hope I was able to illustrate my "problem" so far? Now my question? How can I change the behavior in FF? This seems to be a standard of FF in contrast to both other browser programs. Disabling in the FF settings "Open links in tabs instead of new windows" seems to be only a rudimentary solution; but then a new window is opened every time, which is also not useful. Can something be adjusted in the "deeper" settings? Many thanks in advance for your tips. Best regards, Georg [Translated with "DeepL.com"] Translated with www.DeepL.com/Translator (free version)

所有回复 (2)

more options

I'm no expert on virtual desktops, but have you already tried the following?

Press win+tab to open the virtual desktops organiser. Right-click the Firefox tile to open its context menu. Experiment with ticking and unticking the options there, such as 'show this window on all desktops'.

more options

Hello and thank you,

Yes, I have tested this in all possible variants, but none of the possible settings leads to the goal.

Translated with www.DeepL.com/Translator (free version)