搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Restore Session is disabled but still runs

more options

I'm just trying to NOT have Firefox open my last session when I open it up after rebooting Linux. I've tried many chosen solutions on this site but nothing is working. Here are the settings I've tried with no success (note that I have tried each one individually with a restart between):

"Open previous windows and tabs" is unchecked. "browser.sessionstore.max_resumed_crashes" is 0. "browser.sessionstore.restore_on_demand" is false. "browser.sessionstore.restore_tabs_lazily" is false. "browser.sessionstore.resume_from_crash" is false. "browser.startup.couldRestoreSession.count" is 0 but it sets itself back to 1. "sessionstore-windows-restored" within "sessionCheckpoints.json" in the profile folder is false but sets itself back to true. Deleting "sessionCheckpoints.json" does nothing. I don't have "user.js" in my profile folder.


Here's my system info:

Firefox Version: 95.0.2 (64-bit) Manjaro KDE KDE Plasma Version: 5.23.4 KDE Frameworks Version: 5.89.0 Qt Version: 5.15.2 Kernel Version: 5.15.12-1-MANJARO (64-bit)

I'm just trying to NOT have Firefox open my last session when I open it up after rebooting Linux. I've tried many chosen solutions on this site but nothing is working. Here are the settings I've tried with no success (note that I have tried each one individually with a restart between): "Open previous windows and tabs" is unchecked. "browser.sessionstore.max_resumed_crashes" is 0. "browser.sessionstore.restore_on_demand" is false. "browser.sessionstore.restore_tabs_lazily" is false. "browser.sessionstore.resume_from_crash" is false. "browser.startup.couldRestoreSession.count" is 0 but it sets itself back to 1. "sessionstore-windows-restored" within "sessionCheckpoints.json" in the profile folder is false but sets itself back to true. Deleting "sessionCheckpoints.json" does nothing. I don't have "user.js" in my profile folder. Here's my system info: Firefox Version: 95.0.2 (64-bit) Manjaro KDE KDE Plasma Version: 5.23.4 KDE Frameworks Version: 5.89.0 Qt Version: 5.15.2 Kernel Version: 5.15.12-1-MANJARO (64-bit)

所有回复 (3)

more options

Consider three possible scenarios:

(1) Firefox restores your previous session at startup after you shut down Firefox normally

(A) On the preferences page, this is controlled by the first checkbox.

Or if you prefer, in about:config, it's browser.startup.page =>

  • 0 => blank page
  • 1 => home page (default)
  • 2 => show last visited page
  • 3 => resume previous browser session

(B) A one-time restore flag is set by a user.js file (and because it's in that file, it repeats every single time). Check the user.js section of: How to fix preferences that won't save.

(2) Firefox restores your previous session after a crash (or after the removal of one or more session history files making it appear that Firefox did not shut down normally)

In about:config, this is the browser.sessionstore.resume_from_crash you already set to false, so presumably this is not what is happening.

(3) Firefox restores your previous session after Firefox was signaled to close itself by Linux rather than being closed by you

I am not aware of a way to prevent automatic restoration in this situation.

more options

Don't you close Firefox when you close down Linux, but let Linux close Firefox ?

This is controlled via this pref.

more options

cor-el said

Don't you close Firefox when you close down Linux, but let Linux close Firefox ? This is controlled via this pref.

It looks like that gets toggled to true at shutdown when Linux signals Firefox to close itself, so I guess it would need to be overridden/locked to false through another means such as user.js/Policy? (I have not tested that.)

https://searchfox.org/mozilla-release/source/browser/components/sessionstore/SessionStore.jsm#2196